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Chapter 1

'Welcome

T'hank vou, and congratulations on, the purchase of Logic 5.0,
Version “Five™ is the culminarion of our grearest efTores in
L.ogic's successful history Tt involved a greac deal of work
which, from o musicians poine of view, should prove to be very
satisfving and useful. "This manuoal introdoces all of the new
funcoons and many improvements made since the release of
Logic 4.0, As a Logic 4.x user, vou mayv already be Familiar with
many of the features introduced in recent updares, That sad, o
little “study™ of these features and enhancements will aid in
accelerating vour work and in saving vou time. Many of the new
facihities are found in contexr-sensinve, hierarchical menus
which vou muy huve overlooked in the releases between

versions .0 and 5.

The most sensationdal innosvition: the 1||1i.|i|!1.|. Lo I{,:]'I'Il,]l,'l:_'i'!.‘
control [.U;_{iq: with the |.1lgir Conrrol and Logic Control X1
expansion module, is documented in the dedicated Logic
Control/Control X'T manual, The workBow and “feel™ of
mixing music productions is so scamlessly supported, that the
"tlesire"—in rerms of phivsical size—For a big studio console,
willl walk out the door. As mentioned, chis addendum doesn’t
deal with the fearures directly ussociated with the Logic
Control. We wish vou countless hours of inspreation, Nun and
success with Logic 5.0

Your Emagic Team

Reference Addendum
Version § b
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Welcome

| Main Features of Version 5.0

Before getting into the details, the following outhnes the
primiary new Fearures of Logic Platinum 3. In addition ro these,
there are countless other small improvements,

New Track Automation System

Independent of Logic’s record-ready, record or plav-status,
every track can be fully auromured. The new Trand Autortion
svatem mherirs all of the advantages of Logic’s former automa-

v o s andd featores many new enhuncements:

® 30 Hhoocesolunon of “Track Automation data;

& Siunple-cenrate processing of Track Auromacion daca;
® Mcones ol aumoniied parmeters are shown in clear texr;

& Sever] anteanation medes, allowing intellipent nunagee-
ment of overdubs and addimional mix automation

recordingis).

Improved HyperDraw
HyperDiaw has been signiticantly improved as a legacy of the
new Trick Automation syvsoem.

® All, or pares of, the automation dara can be moved and
copied.

® Automarion dura nodes can be moved and copied. “I'he
shape ol the carve Between the nodes can be interpolited
fronm hinear to concave, convex or S=shaped., "This Hexibilicy

clhimmiies the newd lor g e nnumber of noddes,

Thoese Boodl i Synthesizers

® | o leatmees theee ditferent subtractive virtual analog
swntlesieciss | he monophonic ES M ES Mono) bass
syt heseeen, ol polyplonie ES E(ES Ensemble) and ES P
S oy ) syntlesizers,

Emagic
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New Plug-In-Effects

& SNubflas
sub buss range, most similur to an extensivelv-featured
“Lroom box™.

penerates synthetie specoral components in the

® [Faciter—penerates synthertic spectral components in the
trebile range.

® [y foover—climinares hiss nowses from vocal takes, Given ies
exrensive range of parmerer controls, it can be used for
frequency-specific compression,

& Phave Distortion—genenites unpredicrable spectral compo-
nents,

& i Distorrion—introduces drastic distornons,

& [enotiev—eliminates noise (F F1-based single-ended noise
reduction).

& Frewofo—vintage-siyle amplitnde modulaton.
& Seevve Spevad—enhances the stereo spectrum.

o [iwmiter—pmversal ool for limiting levels and for increasimg
vialume,

o Adaprive Limirer—delivers maximum volume increase for
hll-'lL':l.U Kl]iﬁ.'ﬂ r!.'l'l]l'l“l'l;_:“i,

& | weltelernd Compressor—ithe most powerful tool for increasing
volume sl improving the sound of complere mixes, espe-
cially in a mastening conrext,

Audio

& All Logic-versions support 24 Bit recordings and sample
rtes ol up 1o 96k z: Micrologic A\, Logic, Logic Gold and

| oogrie PPlacinum.,

® he Sudio Mixer features side chains, allowing the use of a
compressor as 1 ducker (Gain reduction dependent on the
level of another rrack), for example. Ducking instrumental

Reference Addendum
ersion 5 11
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Welcome

plavback by sidechaining the lead voculs is 0 common prac-
tice i pop music mixdowns,

& REXN2 file support. Logic can exchunge data with the Ketlvele
suftware by Propelferbead Nofraare.

i ® Logic allows audio serubbing wich any andio hardware.

& OMET File Compatibility (Open Media Framework Inter-
change b allows for the imterchange of AVID, Pro’lools and

| angric sessions,

® Open L 1Open Track Listd formar comparibiliey for dar
exclumpee with “ascam hard disk recorders.,

& MOV Dhichering doning “bounce ™.

SCore
® Sl Page View for simuloaneons lisplay of multiple pages

with realtime adaption 1o coom level,

& Step Tune Inpun windaw for extremely fast note nput viag
computer Kevboard (“note ovpewriter™),

® MNottion of aliases and loops.

® Colored notes,

Logic Control—Hardware Controller Support

& Scamiless mregration of the Emagic Logie Contral/Logic
Caontral X1 jointly developed with Mackie Designs. The
fewtnres of the ayre Clonoral unies are documented in o
sepaniie nennel Uhe Logie Control featinres mororized
Laelens and gives sou muoch more than the physical feel of a
Il ore msaing desk and hardware autolocator. Conve-
mrenee o workimg How are deamatcally improved by this
nrpegere cestiteeller,

MNew Interface Languages

& Soowoimerfuce linguages: Iaalian, French, Duteh, Spanish,
the Ltter should aady be used on

Soorweeiin and | Apuinese

Emagic
14 Logic
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a Japanese-localized operating system, with corresponding
fonts. Toswirch beween lanpuages, select Options > Settings
» Display Preferences, choose the hinguage, quit and restarnt
l.ogic, Du lault Lan juage s the hinguage of vour computer’s
kevloard,

Reference Addendum
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Chapter 2
‘Operating Systems
and Processors

2.1 CPU Optimization

Audio > Audio Preferences > Processor Type ensures that
Losgics Audio Engine alwavs uses code oprimizations specific
to the processor running on your computer, 1t should alwavs be
switched on, "T'he oprimization can be switched oft] but was
1||'i|‘_-.' included for [L"xlr:l'l‘n:_'h. e f[l-ll'l,l‘.l;ll_}ll'i['!.' FES0TS,

Laogic features speciul oprimizations for these processor types:

Pentim [1]
Penoum<
Arhilon

L
-
L]
® AlniVee (Apple Macintosh Gdb—nor switchable

2.2 Mac OS X: Development in 4
Progress Mac

onzgic does not currently run on MMac 05 X, We stronglv advise
that Logic Macintosh users do not attempr o run Logic on Mae
(5 N,

Fomagic are currently developing a Mae O5 X-native version of
oo, andd will advise users of ailialwlity and further details on
annnr websie,

Lasgrie 5 0s fully comparible with Mac OS5 9.1,

Reference Addendum
Version 5 1
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Operating Systems and Processors

/2.3 USB MIDI on Apple q-
Macintosh Computers Mac

The Logic 5 updarerfinstallation program automaricully adds

the Licest “USB Unitor Family Driver™ version. “Dhis new

dhriver is essential for the Unitor-USE ix ta work, and must be

locuted inside the Extension Folder within wour ."iq..:-.t:_'m
Folder,

2.4 Apple Macintosh G4 *_4_

Laogeie makes efficient use of the processing power of the Apple Mac
Macintosh G through urilization of the Velocity Engine. Logic's =
mterl, native audio engine is able w ke advantage of muol

provessor Apple MMacs, (5N ae AV, Awdiowerk, 1212100, Directl)

O, ASLO), Stud 1O, FASTHL To enable mulao provessor Macin-

toshs, check the Multi Processor Support check-box in the

Audio > Audio Drivers menu option,

Emagic
16 Loge
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Chapter 3

Automation

3.1 Automation Concept

“Auntomation” 1s the ability of a mixing desk ro record, edir and
plav-buck the movements of irs volume faders. Fully auto-
mared consoles not only record the motion of the volume
taders, but the moton of aff knobs and switches, including pan,
EO and sux send controls,

All of Logic’s mix funcrions can be aurtomated, withour restric-
tion, "T'his also applies to all Logic effect plug-ins—i.e. the
parameters of all effecrs and Audio Instruments, This is also
true for VST plug-ins which support sautomation aceonding to
the VST standard,

As Logie 5.0 supports the Logie Control hardware, the dream ol
simultneous control over multiple parmmerers beoomes a
reality. Meedless o say, adjusting multiple mix or effect pariime

crers conctirrently is impossible with a mouse,

! i you've worked with versigns prior 1o version 5.0, please note that
the automation concepts have changed

From version 3.0, the concept behind Logic’s automation
svstem has changed, The former auromation serateFies
explained in rthe reference manual are reined mainly o
ensure complete compatibabity with r."»-;i:\cl;in;_-h songs, and o
imrinnin the QYR T 5 this older waorking sty e, if desired.

T'he new Track Automartion svstem combines all of the advan-
tiges of the former strategies and features many addition:l
“pros”. From the release of version 5, we encourage vou to
acdopt the working methods of this new Trck Automanon

sAsICm.

Reference Addendum
Version 5 17



Chapter 3
Automation

£! Please note that due 1o the changes introduced by the new Track
Automation systér, a new 5ong file format has been introduced with
Version 5. Please consult the New Song File Format section, on page
45, for further information

In Place of MIDI Controllers in Sequences and Regions...

I vou liked to denw level and pan controller streams with
contml change messages 7 (MDD valume) and 10 fpand in
HyperDaw tor the Hyper Editor), vou'll be glad to hear thar
the new soomition svstem is based on g much improved
version of FlyperDrw “he automartion dara generated by the
new swvstem, however, is stored in a completely new area which
does non interfere Gand has nothing to dod wich the MDD daa,
The oew Track Sutomarion dac is assigned o frecfs, not to
imndividual sequences ar regions, "1his is visibly evidenced by
the griy shuded area (which vou drw the auromartion data
curves on, using the reck based HyperDirow) thae covers the
whole track, rather than individual sequences or regions. This
makes it easier to place volume fader informution right Aefare o
sequence or region, for exomple. The fumiliar object based
HyperDiraw rechnigues remain, but now urilize 4 Iighly
improved HyperDraw interfuce.

In Place of Channel Splitter Tracks. ..

Nothing, 1t's time to sav “goodbye™ ro the channel spliteer

objects in the Enviconment. Formerly, these were detined, and
wsed, as track objects, carrving the MIDI controller data for up
to 1O NTDT channels (e, 16 rracks )., They were usually called
AP ek, U B-Plavback” or "GN Mixer Modem™ in former

ale bl sesges.

The Automation of the Adaptive Track Mixer

Phe adupove Track Mixer's automation svstem has always
allivwved the recordimg of MID scquences (contuining M
continwous controller automation data) by engaging Logic’s
record mode and meving the onscreen knobs and faders. This

Emagic
18 Logic
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technigue remains—in all ehannel steips set to MIDIL This also
applies to the Audio Mixer as well.

When—and eafy when—a channel strip s set o J000F and
[.omic 15 in record mode, are the Track Mixers knoby move-
ments recorded as new MIDI sequences directly on the
sitlected rruck, In this scenano, no new 32 Bir Track Automa-
rion data is generated. You should only use this technique if vou
wish to have, and later use, such dara in dedicared sequences,
which can easily be moved, copied or merged with other

sCuences.

The new Track Automation

When it comes to mixing down, the new Track Automation

syvstem s Far supenor to the three technigues mentioned above,
Euch of these automation techniques has its specific benehts,
aned each technigue allows the editing of automation data in any
suitable MDD editor window. The catch=22 s thar the varien

of automation rechnigques on offer wasn™t consistent or self-
evident in use.

With version 3.0, the automation svsrem has been simplified
andd standardized. The new Track Automation combines all
advanrages of the former rechnigues. You can record Mixer
movements and edic them with HyperDiaw Flvperl drow is
now simpler to use and much more Hexible, FHyperdrw allows
Tor convex, concave and S-shaped curves berween the nodes,
clhiminating the need for a huge number of nodes. The editors
vorare familiar wich are sull available for the edinng of auto-
maition diti.

Track Automation

T'he new Track Automacion system, ntroduced with version
Ad) s no longer attached to sequences and regions, but to
tracks. ‘The auromation data is stored in a—normally invis-
ible—fulder which is independent of all M1DI daa. The reso-
Illlll:!ll'l IJI“II:I..H.'LE ."'I.l.l.[“ll'li_l‘l'il.ll'l J.I.i.l.!..l I."'L ;._:. H-i[. R4 |'|I-|.'|'I I I-LHf niore
previse than that of ML

Reference Addendum
Version 5 19



Chapter 3
Automation

£l Thisisan impartant difference between the former, and new, aulo-
mation concepts. The Track Automation system 15 based on a new
type of data, which resembles MIDI control change messages, but is
completelely unrelated

Recording Track Automation Data

Yo can recond Track Auronuanon dac in real time L muon ing
the Mixer's controls (the faders or the pan pots, for example),
while thair olypects fehanme] serips)are set o the Touch, Latch ar
Vet el I real world usage, vou'll rrely (F ever) use the
rither destomenive oot mode, which erases all auromation
e, " he normial “writing” mwdes are Tevch and Latch, These
i les, explamed i deval from pagze 26 onwards, are set for
cvery track olyject G relared channel sorip) individuoally,

i Inpariant. The recarding of Track Automation data takes places no
matter whether Legic's transport s, or 15 not, in record or playback
model In addition, the Arrange window track selection or audia
record ready status is irrelevant, Whatever you tauch will be recorded
when a chanrel strip is set 1o one of the write modes. Tha movement
of Mixer contrals (when in a wrte mode) can be used 10 overwrite
andfor edit existing automation data in realtrme

Behavior in Stop Mode

In Stop mode (Plavback halted by the Stop burton in the Trans-
port), Logic ignores the autonmation modes and won't write any
sutomarion dhata, even if vou move any of the Mixer controls,
There s, however, one exception: As long as no automation
thta ol the selected controller tvpe (valume, pan ete.) has been
weeorded, the corresponding control setting (fader, pan pot ete.)
will attect the whele song, just as with a mixing desk. This is
the de Gl behavior for every mix parameter when vou seare o

[TTRR 1 LIRS

.I I enther weosrdls: 103 sCeénano where you're WOTKING 0N 3 new S0ng,
wingh contamns no automation data and the playback is stopped; The
setting of any cont*ol moved in the Mixer will affect the whaole song
This settng will be cvenwritten as $50n as you starl creating automa-
tion data (during playback in of h rrede, or graphically, in

Emagic
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Swop mode, with track based HyperDrawl—This is, in effect, what the
automation is for: maving the controls automatically during the
song’s playback. Touchirg a contral in Stop mode won't change
exist ng AUTomatscn -data. ot even n i i i mode

Graphical Editing of Track Automation Data

You can write and edit automation data graphically and numer-
ically, The graphical editing of automarion dara is performed by
utilizing Traecd Hyper Dragw, introduced in Logic 5.0, As
mentioned eurlier, it's also possible to draw MIDI dara into
sequences and regions with the—lighly improved—Hyper-
Draw. You could still automare your mix this way, but this is not
recommoended in most sitnstions.

Yellow Track Hyper Draw Curve of Audio-Otyect T's “Volume™ pardineler
Alongside the nodes, numenical expressions i db can be seen Although
no region exists in the displayed area, the volume fader of the Audw |
channal strip wiil move when playing bars ! to 8. That is, as long 4as ifs
autornation mode isn't set to “Off" or “Wiite™. The graphic 15 a screen
shot of the PC-version. The 5-shape has been achreved by pulling the line
to the night wath the Autamation Tool (Curve setting)

T dlisplay Track Auwromation data in the Arrange window,

selece Ulew * Track Automation. This s also available as o ke m
o, As long as this function 15 unchecked, sequences

aned regions appear as per usual. The gray, shaded Track Auro-

nation are 15 only displaved when the vertical zoom level is sen

to o sufficient heighe, as is the case with conventional object

Lsead Ty l"‘”l Jraw, As n-|1|1n'~.r._'t,l o the conventional 1 |'_n e rD

luncron, engaging the "Lrack Automation data display will
antomatically sera suitabile zoom level, The "Track Autonaition

chata s displaved on a transparent grey shadowed are:, allowing
somp tosee Ehe aodio wive form in regions and notes in
segjuences ot o redoced contrast level.

Reference Addendum
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You can edit the Track Automation data directly in this display.

&' Each track can be displayed at an indmdual vertical zoom level: Clhick-
hold on the very left lovwer edge (1o the left of the track number) of
the desired track in the Track List and drag downwards

T Zooming 1s performed with the telescope (Mac 035), or the 2o0m bars
(see picture} of the PC version. Alter natively, you can alsa use the
magnifying glass of the 1ool box

=l

-

Maving Automation Data When Moving Regions And
Sequences
It's possible to move sequences and regions with, or indepen-
demt from, the Track Avtomation data. Switch the modes by
selecting Options > Track Automation »* Automation Settings >
Move Automation with Objects. You can choose berween Never,
Cand Ask, which should be self-explanatory. Ash s the
default setting,

i It 15 also poss:ble 10 move a node, along with all followang nodes, by
haolding [Bg) (Mac) or (PC} while dragging

Choosing the Parameter To Be Displayed

In the Hip menu of the sop panel which appears in the Arninge
window Track List, vou can select the parameter which you
wish to display and edic. "I'his can be the volume fader, the pan
pot, or any other paramerer of the corresponding Mixer channel
seeipy, " he parameters are represented by different preset colors
when displaved as o curve in the automation track. When vou
coit g purmmerer in the Trck Miser, a plug-in-window, or via a
Lasprie Clonreol unir, the mose recenty edited paramerer will be
displaved,

§' Tip: As a quick note on the handling of the “Pan® parameter in Logic:
Mono Tracks: If the track s mong, the Pan parameter really 15 a
pancrama which allows the panning ol a mang track from left 1o
nght
2. Stereo Tracks: If the track 15 stere, the Pan parameter works as a
Balance control between the left and right channels. It reduces the

Emagic
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volume of the lefinighy cnannel as it is turned further o the other

channel

Viewing Multiple Automation Parameters

You will commonly automate Volume, Pan and Muote parame-
ters For most tracks. As mentioned above, vou can select the
desired duromuition parameter via the top Hip menu panel of

(LA T |I travk.

e the loswer lefr of each wrack inche Trick Laist, vou will see 2
sttt arrerw head, poinong o the nighe, IF chis s chicked onee, an
aelelimnoal sub-track will become visible.

1' Logic automatically sets the automation parameter type to a type
already recorded, but not currently shown, It applicable,

You will note thar this sub-rrack doesn’t feature the rrack nume
ar the auramarion Med panel. This is because the “parent”™
track is globally responsible for these sub-tracks,

Fach sub-truck can have a different automartion parameter set
i the Hip menu, which allows vou ro view mulople auromarion
it rvpes for the parent audio or NIHDI track.

Fiv the lower lefr of the sub-rrack, a further rghe-pointing armow
pvavatlable, Phas allows von o creare additional sub-rracks For
other auronution rypes, A muaximum of 40 such sub-tracks,
associted with a particular parent track, can be created in tlas
Fashion.

i {Mac) (fad] on Wingows) clicking on the closed triangle will add as
many fracks as needed 1o show all types of prewously recorded auio
mation data. 1o avod the unnecessary creation of 100 many tracks,
up to ten {existing) parameter tracks are created with each chick. You
can, of course, click a second time 10 add mare autornaton tracks

i! By pressing [B)E) (Mac) (ERE) on Windows) and click.ng, up to 40
tracks will be created with a single click
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To close individual sub-tracks, simply click on the arrowhead
(which now points downwards) on the desired sub-track or
parent rrack.

1! /8 (Mac) (B on Windows) clicking on the apen triangle will close all
sub-tracks created for this mult-automation view. Flease note that
orly the view & closed, not the avtomation data deleted. The auto-
mation data remains active and can be viewed again by [58] (Mac) (o]
on Windows} clicking on the closed triangle a secong time

Boate that when all sub-tracks have been “collapsed”, then
anramarion daca is stll visible in the Automation “Track of the
parent track, provided that the Zoom level is sufficient, These
apppear in o different color, and at 3 reduced contrase level,

Pletinman onfv: To inerease the visibility of the automation dar
of these sub-rracks, open the Options » Settings » Display Pref-
erences, [n this window, use the mouse as a slider on the panel
alongside the Other Data Transparency in Arrange cntry
(defaule 25% ). A value of around 30 or 60% will provide great
contrast for the suls-track surtomarion data. You con also change
thic Object Transparency in Arrange option to further enhance

visibsility (defunle: 339% ),

summary: To Create And Edit Track Automation Data
FFollow these instructions to get o “feel™ for whar it’s all about

® [Press an appropriate numerical key in order to open a
Screenser with the environments Audio Mixer, or adaprive
Trick Mixeropened. Alternately, just open one of these
Aisers by selecting Audio > Rudio Miger or Windows > Track
MiHer.

® Jusrabove the pan pot of each track vou'll see a small param-
crer window with the word OF in e Click-hold in this punel
aned select Weite here, inone {or more) of the channel strips.
Mote: T'his must be set independently for every channel
strip (for every track ).
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& Sart PMayback., Remember: Recording Track Automation
thara docs not require Logic to be in record maode!

® hlove some of the channel strip controls ... say, the volume
Buder amd pan pot,

® 'ress the uppropriate numerical key in order to open a
Sercenset which contuins an Arrunge window,

® lngage View > Track Automation. Logic automatically

o in vertically, allowing the daura to be seen. To zoom in
Trther, inerense the vertieal 2oom with the telescope (Mac
C¥shor soom bars (Windeoaws version) at the lower right edpe
of the Arrnge window. Alternately, drag down the lefi-mose
lower edge of the Track Last (1o the lefr of the track’s
number) entry with the mouse, in order to zoom in the track
vertically,

® [eneath the name of the track i the Track List, paramerer
panel appears, showing the displived pammerer’s name—or
Display G Click-hold on this panel and selece Volume, The
word appears in bold letters, in cases where such dara
(volume) already exises on the track. Given that yvou just
messed around with the volume fader during playback, and
thit the track was ser to Weite mode, volume data should

indeed exist,

® The recorded volume automation dara stream appears as o
vellow curve. Pan data s displaved in green.

& You may want o increase the honsontal 2oom as well, Touch
the nodes of the automation dac curve and move them, See
how touching a line between two nodes feels (when moving
i), and see whar happens when vou click on the grov back-
ground of the avtomanion track (e, not on o line or node),

® Change rthe curve Deoween two nodes with the Autemation
Tool using its curve setting by touching the line between
them, Move the mouse vertcally and horizontically to ger a
feel for how vou define convex, concave and both tyvpes of S-
shaped curves, This ability saves on the creation and editing
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of a lot of nodes (altermatively: use the standard Arrow "Tool

with held),

i Piease note that all parameiers of the Mixer's channel strip (of the
audio object ..} are fully automated—mcluding equalizer and bus
send controls. Data winch you Create and edit here 15 independent
from the sequences and regions on the track. In other words, this
aulomation data wall remain, even if you Qelete the reqions and
sequences!

L Please don't confuse the Track Automation data display with that of
the object based HyperDraw, which offers the same new interface,
ncluding the vanety of curve 1ypes between the nodes, olyect based
HyperDraw offers the editing of Control Change Messages 7 (MIDI
YWolurne) and 10 (Panorama). it can be used 1o edit recordings made
with a channel stop aan I mode
Tip: Avoid the use of this functionality and try to use the Track Auto-
mation instead, oarticularly if you're not a * power user”

Context Sensitive Display

In order to reduce the number of paramerers displaved, the
chisplay s context sensitive, which greatly simplibies operation,
Whar this means is char only the parameters which aetually
control something in the selected Mixer channel sorip (or inirs
plug-ins}, will be displaved. The display of the paramerer
names is also context sensitive: this is a major plus, beciisy
rather than secing an anonymous number, vou can see the
e of the funetion vou're dealing wich in plain texr, Panme-
ters which already exise in the track are displuved in haold
lettering in the context-sensitive menu.

3.2 Automation Modes

I every channel serp of the Track MMixer or Audio Miser, vou
e seleet the auromarion modes individuallv, Ar higher verneal
soom levels, the automarnion mode prin M ter is also visilale i
the Track List of the Arrange window, Given thar Track Auro-
marion data can be recorded during plavback mode, the defanlt
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sertmg is U, as any mix automartion may prove disconcerting

wlhile arranging, You can choose berween the following automa-
tionimoedes inany MITDT o audio Goeluding Audio Instrument,
B ] onrpur ) abyject:

i

Ca b sl alisable the current Track Avromation dar withoue

dlelenimge e, Moo automation data will be written, nor read and m
(lived bawk, 1 the current antomarion mode is 00, any edirs o

Pk Auromacion data in the Arrange window will automan-

callv sweh the untomation maode ro Head, This ensures thar

the dhata, as currently edited, will be plaved.

|':'| wil

Foadbwill anromate the current track using the existing autonm-

tion dlar, Uhe dara cannat be changed in realtime by touching m
the Fider.

Frich
it wall automare the current track i the same Faslion os
ivieatl, Should the fuder be touched, the exisuing " Track Autema-
tion dita of the current Fuder tvpe will be replaced by new
movements—for as long as che fader is pressed. o b s the
micsst appropriate, Cstundard” mode, used for designing the
i, Wirh automarion engaged, it provides vou with the apoon
ol correcting and improving the mix ar any time, he tioe
required by o paramerer o retumn to its previously recorded
st s selecred via Dptions > Track Automation > Automa-
tion Settings... > Automation Ramp Time (ms) (sce page 28).

Latch
f Lasically works like Tooch, but afrer releasing the fader :
the current value will replace any existing auromarion data—for “
as long as the sequencer s an plavincek (or recordh mode, Press

stap to finish or 1o define the end of vour parameter editing by
stopping plivback (or recording),

In W Mode, existing Trock Auromuation dara s erased
according to the Track Automation Settings as the Song Position ”
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Line passes iz Options > Track Automation » Track Automation
Settings » “Write” mode erases. [Fvou move any of the
Aixers controls, this movement will be recorded—if vou don’,
according to che Track Automation Settings existing duta pussed
v the SPLL s simply delered: Options > Track Automation >
Track Automation Settings » “lWrite” mode erases, S0 e
carchul to ensure thar vou don't erase vour pan, buos, and FQ)
anrenmation by nustake, Fvour imrenoon was o only erise some
volume fader information! After stopping the transpor, all
tracks ser o Vo will antomatically be reser according to the
Track Automation Settings: Dptions > Track Automation » Track
Automation Settings » “Write” mode changes to, "lis is to
prowect sour remaining daca from accidental ensore,

i The Write mode of raditional mx automanion will rarely e ieeded
wihen working with Logic's Track Automaton, I miginly tlesrar s
complete the selecthion of automaton modes, I's easwer Loy e the
aulomancn data h',r ﬁi—llé-ftlrlg Opltions > Track Autometion * T T
Al Automalion Data of Corrent Track (o ... B Dracks, negas
tively). In earlier analog mix automation systems, the Wote roocde wan
the Unl}r way 10 t’l;}r'ﬂ;!lliu;-‘.ely erase auiomanton dala

pAID

o disconnects the Mixer controls from che Treack Ao

tion. Conventional MNTD1 control chinge message data will Dy -
recorded mnto ST UCTIICCS—% T the auronition vsco by

| Logies Track Mixer in versions prior to 5.0, The Gder will s

lke o standard exeernal MDD source and wall be recorded aml

prhived Baek as normal NI daeain AT sequences,

Automation Ramp Time (ms)

I miler Dptions * Track Automation > Automation Setlings...
vod Il ind the Automation Ramp Time (ms) parameter. Pl is
ety wsed by the oo b automanion mode. In this maode, the
vile of an edited parmmeter will return to 10 former setting,
o the time span (n milliseconds ) defined by rhis apation,
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Switching Automation Modes For All Channels
Simultaneously

ekl (Mac OIS ar ({PCY when switching the mode of
vhannel seoapy and all channel strps which had previousiy been
st o the same automation mode, will switch as well.

Switching Track Automation Modes By Key Command

iy trck s aotomation mode can be ser by a Key Command m
detiped via the Key Commands window: Tagefe Carvene Track

Ln.l'ru.n'.h!.r',rHH Fery r’.:',-"flfq'rﬁf, f_.r.'.f'rﬁ',l"fﬂ'n’.fr’.l'r, Hlf.l’h'.u"fff'.rﬂ'u"l._ _If‘ff_}lflll'f.:“h-fl

When the desired mode is set, the Key Command toggles

between the ser mode and deall, There are also key

Clommunds o set all rracks o one automation mode: Ser A

Frvaeds to Natesation .. COFF, Read, Touch, Latch, Write NI,

3.3 Conversion of MIDI/Track
Automation Data

There are some sitwations where conventional (the old sivle)
amomation dac in sequences is more appropriate than Track
Votemation dars, As an exaomple: When mixing down, this
micthodd should be the exception. We ask that vou ke o
aveannt the possibilities of perfforming fade-ins, fude-oues and
cross=fides with andio regions non-descructively with the cross-

aile rol,

P comnvert daa recorded o MTEM automanon mode, drawnin
alipect based HyperDnaw, or data from songs saved by older
Laseie versions into Track Automation data, two convert func-
treanns sre aveatluble, Access these viao Options »* Track Automa-
Lon »,

i wWith these functions you can convert the mix information of songs
(saved in pre-Logic & versions) into the new Track Automation farmag
Select all sequences and regons in the Arrange window (@A) Mac
Q5 (Windows el A]), and choose Oplions > Track Automation >
=qoue Al Db ject Canbrol Data To Track Hulomalion
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1 Please note that all followang functions require that at least one objecl
pe selecied befare their use,

This funcrion converts the MM contral change message ivpe
currently displaved by object based HyperDraw it Tk
Auvrtomation data,

e Dy niral Dala To Track Aulom At

This Funetion converes all KT control clumpe messape (vpes
into Frack Automation dara, mcloding those which aren’
currently displaved by [ IvperDiraw.

T'he “move™ opriens also include the abilicy to move "Trck

Auromation data to objects, This is the reverse of the functions

above.

Tave Current frack Avtomation Data to Olxect
This function converts the currently displaved Trck Automa-
tion rvpe, and moves ivinoo a selecred object.
Teael 1 n Data T SITR &)

This Function converts all Track Aueomation rvpes, o luding,
those which aren’t currently displived, and woves then oo a

selecred olyect,

3.4 Copying Automation Events
as MIDI Data

This funetion allows von to conveniently copy Autontion dita
iz nomber of wavs, This may be useful of vou swish o ioogquick s

{ duplicare seetions of vour automation track repentivel,

o Select an Aantomation Track. Ensure chat no adeeses (0N
seqquences e selected totherwise, ther dat will he

1'|||‘:it_'[||l_
® Sclect Functions * Copy MIDI Events...

& Adljuse the setrings as desired i the dialog which opens
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| @ (hick the “[Do Ie” buaron.

3.5 Deleting Track Automation
Data

he following, self~explinatory aptions are available for the
ersiine ol antomaton dacy, Choose Dptions * Track Automa-
Thisi =

® lleinte currently visible Automation Data of Current Track;
& lelete NIl Automation Data of Current Track:

® [lelete AN Automation Data of ANl Tracks.

1 A double click, while holaing [=E) (Mach o (PC1 selects all current
dutomation data on the track. Pressing [=] well erase the data

[here is a further “delete™ oprion available.

® Delele Orphan Aulomation Data of Current Track
“Chrphan™ antomatoon data s dota whicho s mis connected 1o
any parimeter anvmore of has lost its destination pusametern.
This can happen when copying automation dat berween
tracks for example, "This function will delere the “orphancd™
infermanion.

3.6 Automation Tools

I'he toals in the Yooy perform in che following way when
dealing with “Track Automanion/HyperDieaw editing tasks (refer
o the Awromartion/HyperDraa Editing section, on page 33

Standard Arrow Tool

he standiard arrow ool aces as o mulo function automation ool
when nsed with various modifier kevs, Please refer to the
Folloswing: section for specitic deniils on the use of the varous
micilifiers with this ool
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Pen Tool
This ool allows the frechand drawing of autometion events,

incliding curves,

Eraser Tool

T'his tool erases auronEinon evenrs,

Automation Arrow Tool—("Broken Arrow")

This tool has varoos functions which are dependent on the
setting shown in the Hip meno just below the ool e owo Hip
i aprions wre Crere and Sedeen,

Curve

Yoo can bend the line between owo nodes or any selection,
There are 4 differnt curve rvpes available: conves, concive, amd
two different tvpes of S-curves,

k' Note: this function is also available when using the standa il Arew
Tool if the modifiers are pressed simultaneously,

Select

You can rubber-band selecr any limes andfor nodes i the Ao
murion track. I sbe edyecr 1s clicked once, all corrently visibile
autamation events thar fall within the abjeer borders will b
selected, Onee aselection has Been made, vou can |'1'1:1.:|'_. it
the Automation data levels, copy, move them ete,

L note: the rubber-band function is also available when usimgy thes Sliaii
tard Arrow Tool, by holding down [&

ez af vom wann to change the volume tor other conoroller) of
amolygedt, relative o all exestmge automation, vou can oo the

Foslbossw pnge:

o (hoose the “Select™ mode from the Automation Tool fHip
T L
& Seleer the desired parmeter—Volume, for example
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o (lick on the object. This will selecr the duata wichin the
eyt borders,

® M\ ove the selection up or down., This is relative if vou click
oifsicde the line, and absolure if vou click on the line direcrly,

3.7 Automation/HyperDraw
Editing
Yo will have noticed thae HivperDraw has been improved a lot,
Pl penh dow as noe only used For the editing of ST daca Gas o
was bclored, bar also for the edining of Track Automaton dara,
MELEYE chana is drawn in the edyect dased® Hyperfeaae mode,
acvessed Iy Biew > HyperDraw, and Track Automation edits are
performed by fred Sasesd HyperDerar, accessed via Dew > Track
Automation.

§ Please note that in order to see HyperDraw data, a sufficient vertical
eocrm level is required. Switching on the Track Automation display

autcmatically zocms vertically, if the pravious zoom level was il

4 WA

Flw perl Iraw's redesipn makes it much maore ergonomic, lointer
preets pestures and clicks in o perfect fashion You will gquicky
andd intuitively come o grips with its grear new “feel”™, and will
el that many different actions can be performed with o
e of clicks and movements, These are the improve-
icnts fusing the standard Areosw Taool )

® Nuodes are easier 1o chick becavse che chokmg area has been
i reased.

o (lick and move feels berrer now: Nodes don’t “jump”™ when
chivked inexsactly because all changes are relative,

® |.nes can be clicked.

LogiclLaogic "inrelligenty™ analvses the direction of mouse

movements, making the control over nodes in the Track Auro-

nution dar much easier.
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| In cases where the mouse is initially moved in one direction—
vertically or honizontally—the move is “limited™ o this direc-
r tron. This meikes it eusy to rein the nodeds) vilueis) while
changing the positionds), or 1o keep the positiends ) while
changing the valueis), IF the mouse is moved on the other plang
i the A=Y axis (honzontally or vertically), the direetional
“limir™ will be overnidden and vou ean freely position the
nele(s L you can, of course, limit the movement of nodes o ong
dircction. IF vou press the [@] kev while changing the value
lorizontally or vertically the movement will be locked it

dlireytion.
& A shorr click ona node will delere it

Ashort click on, or just ontside, o ne (oot a oode ) will add

new node on the line,

* A long chek on o line allows vori 1o move the line, along with
tts two endpoints—i.e. the nodes thar encompass the line

® Click and hold outside o hine will ereate amd seleet o new
nade, allowing vou to move thar node immedianely,

& A long chick ona node, line or selection, while Dl
(Mac OS) or fetd] (PC), allows the copying of the mode, line m

h-li."ll'.."L'{ILlll.

& A click, withouwt previously making a selecuon, while
haskding (M O8S) or (PCY, will allow von o deag all

waea, begimming froom the current monse Prasition,

® Adouble click while holding Y AT RV RT i,

seleets all sesmvearien e,

® A g olivk, wiale I1|:-||;I':|'|p_ (AL €3S, o i "
o cn menbe, an e o aselecrion allows vanons corves to be ser
o line oracross the entire current selection, Four oy pes of
shapes are available. Curves can also be edioed wsing the
Vietarsneeitrenm Vol set to ey e, Uhese can be ser b o the
s i one of four possible directinns:
& [lorizontal S-Curve: Move the mounse right.
& Verical S-Curve: Move the mouse lefr.
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¢ Conciave: Move the mouse down.
¢ Convex: Move the mouse up.

1! probatly the most useful shape when changing level is the horizontal
s-Curve. Click a line while halding (Mac 05}, or (PC)
and move the mause to the right. Alter nately, make use of the Pencil
or Aulomabon Arrow tools
Mo tip When designing curves, always trust your ears—not your
LL TR |

& he very fiest click into an empty HyperTraw track creates :
new node ar thar position, and another node at the begin-
ming. Uhis ensures chat you won't ereate parameter controls
with “paps” in the middle of sequence, but have full contral
over the paramerter from the beginning of the automation
track. "I'his applies to borth Region/Sequence Hyperlraw
and “Track Automartion.

Multiple Selection of Nodes using the Automation Tool
set to Select
o Ay shorr chick on a node will select the node.

® A shorr click on a line will oggle the selection of the line.,

Right underneath the paramerer name in the “Track List, o
stall numerical display together with a graphical value
merer shows the current paramerer value, A short ehek winh
the rght mouwse button (\Win) or (MMac) on the mumerncal
display (or value merer) will select all automartion data of the
current parameter on that track,

® A click outside of the Track Automarion dara in the Arrange
will deselect all.

® (licking and holding the mouse button allows a rubber-band

selecrion,

Il Additional functions: Clicking and holding the (Mac) er &) (Win) keys
after making the rubber-band selection, will create one new node on
each side of the selected area once the mouse button is released
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When clicking and halding the (Mac) or Win) keys two
new nodes will be created on each side of the selected area,

® MNon-contiguous selections are possible by holding [&).

® A long chick ina selected area allows all selected nodes to e
moved,

® While clicking and holding a selection can be moved. The
selected area automatically “erases”™ any daw which exists in
the area i is been moved over. Immediately moving hack
the selection will restore the “erased” nodes. This works
intelligently in cases where non-contiguous selections have
been made,

& Wihile clicking and holding a sclecrion wirh 5 (Mac) or &)
{(Win} pressed a selection can be moved as a copy. While
moving the selection exisung automation date gets aoutam -
ically "restored™ after the copicd selection has passed over
them, Thns works intelhigently in cases where non=coniig-
TS hl'.'l':L"[il:H'l.‘i I'II.I'\.'L' I:I-L'L"Il “:I.'I{.IL‘.‘.

Relative and Absolute Value Changes of Selections using
the Automation Toof set to Select
There are two choices available when changing the values of o

selection of nodes:

& Clicking on a line or node, vou can change all values by the
sme absolute amount,

o (licking ourside of a line within the selecred area (on o node
or outside a node), all values will be changed proportionally
Iy o percentape value.

® [Right underncath the parameter name in the Track List, a
sl numerical display rogether with a graphical value
meter shows the current paramerer value. A short click with
the right mouse button (Win) or [#] (Alact on the numerical
display tor value merer) will selecr all automation dara of the
current parameter on that track. Right-click (Win) or
(M ac) and drag vertically on the numerical display (or value
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meter) o scale the current auromation dara on thar track in
real time.

Value Display in HyperDraw

M merical vilues dre :tLIlﬁn‘i;lti{';L]]"_r tli:\.plﬂ'}'-r_‘{l ar I-{'g.'|‘u:r]}r;m'
ples if there is sufficient space. Numernical values are contexe-
sensitive—ie. the centered pan posirion is displayed as 0 (not
G 1, and volume is displaved in dB.

I event exists for volume and pan, Logic draws a horizontal
line of the current value (f available). If clicked, a single event
with that value will appear. Further clicks work as per usual.

HyperDraw Mode Velocity

New |Hyperdraw of Note Velocity feature. Onee active—by
selecting Diew > Hyperdraw > Note Uelocity, click-holding ar
any point in a HyperDiraw window will activate the note
velocity line tool, much like that found in the Hyperlidi
window. Releasing the mouse butron will then change the tool
to i ling, which you can visually place onscreen, "The end of the
line is inserted by clicking a second time. This will antoman-
vally seale all note velocities, aligned ro the inserced line, PMease
note that this only makes sense when the sequence area
covered by the line already contains notes,

T'he Note Velocity Lane Tool works in different modes:
1. Absolute: With no modifier key pressed, the velocity of

notes will be changed to the value of the hne.

2. Relative: with the [38) (Mac) key held, or the right mouse
buteon (PC)Y, the original and new note velocity will be ana-
lyzed. The resulting velocity is the average of both.,

A Just Selected: wich (Mlac) or (PC) pressed, only pre-
viansly selecred notes will be affecred.

Both Relative and Just Selected modes can be combined

([@F)FE] (Mac) or (PC) and right mouse button),
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Windows and Editors

4.1 Transport Window

New Look of Transport Buttons
You'll revognize Logic 5.0at first glance by the new design of irs
backlit LED-=style transpore buttons.,

Extended Functionality of Fast Forward and Fast Rewind
keys

IFast Forward and Fast Rewind (Transport): A short mouse click
will jump to the next or previous marker. If no markers exist, a
shaort elick will jump 1 bar forward or backward. Long clicks will
rewind or fast forward as in carlier versions. Moving the moose
lett or right will increase or decrease the rewind/forward

and can even change the winding direction,

speel

Shuttle—Winding Like a Reel-to-Reel Tape Recorder

Ihere are two Key Commands for “winding the reels™—i.c. m
maving the Song Position Lane—<called Shatnde Reaina and

Shuttle Foravard. You will find them in the Key Commands m
window by searching for the Stwile characrer string. Repeated

hits of the key will increase the winding speed. Repeared hirs

of the opposite key will slow down rthe shurtle speed, and even-

tually change the direction. Shutle disables Cyele mode, Shue-

tling 15 halted by the stop command.

Metronome Click ﬂ—
I'he metronome speaker click sound has been changed in the
Mlae OS version. Ie's a non-pitched, neutral click sound with Mac

two different levels for the nominator and denominaror,
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4.2 Arrange Window

Improved and More Flexible Look

You'll alrecady have norticed Logic 5% improved, high-contrast
new look. The background design is more texible and user-
definable. This aids the handling of all Track Automation tasks
in the Arrange window, as it offers more contrast for objects, the
Song Posinon Line, rubber-band selecton outlines and the
punde lines when dragging objects. In situations where multiple
automation dara selections are made, the area turns black,

At higher zoom levels, objects are completely colared,
including the waveform or MIDI content display. Selecied
objects are indicated by a white separation line hetween text
and graphics, This makes it easier to recognize selecred
objects, particularly when surrounding objects use dark colors,
which can be easily confused with the black used to indicate
sclected ﬂh-jr.:[‘t.‘h

Arrange Window Background

In place of the former View > White Background, you'll find
View > Plain Background, which is a light vellow by defanl,

Under Dptions > Settings > Display Preferences, you'll find

wo parameters which control the Arrange window appearanee:

e Background Pattern In Arrange allows you to choose a back-
grownd partern, but only if Diew > Plain Background is
nnehecked,

* Plain Background In Arrange allows vou to choose any RGI

vilor, Bor only it View > Plain Backgrouwnd is checked. Click
the desired color in the paletie o define a new color,

Muted Sequences, Audio Regions and Folders appear
pale or textured

I the Arminge window muted sequences, andio regions or

fulders appear in a pale (muted) color or textured: Dptions >
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Settings » Display Preferences > Muted Dbjects are textured.
Muted sequences, audio regions and folders are also identified
by o ddor which precedes the object name, as per earlicr versions
ol Laogie,

Arrange Window Features

Drag&Drop of Audio Files

Audho files can now be dragged directly from the Finder/

Wi lows Fxplorer/Deskrop/Folders into the Arrange window
fpust lihe AT files) You do not need to drag them into the
Ao window Rrst.

Selecting Looped Sequences

l.ooped sequences can be selected by clicking on loop-reperi-
tons, A shore click will select the looped object. Click-holding
behaves like a click on the background. All objects ure dese-
lecred and rubber-band selection becomes active, allowing
muluple ubjecrs ra be selecred.

New Key Command: Record Enable Track m
New key Command: Record Enable Track. This command

topples hetween armed/unarmed modes on the selected ruck

i the Armminge window,

New Key Commands for Note Lengths

T'he key Commands window offers the following new func-
tioms in the “Various Sequence Editors™ section:

o Note Overlap Correction (selecredselecred)
o Nate Faorce Legato (selecredselecred)
o Nate Overlap Correction for repeated notes.

5.8

Editing Start Point of Sequences and Regions

I'he lefr corner change behavior has been improved, Now drag-
ping the left corner of arrange objects, or notes, is suppressed in
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cases where the objects are very small, This should prevent
accidential changes to the left corner.

Higher Vertical Zoom Resolution
The vertcal zoom has more, and finer steps.

Scrolling
Tinehing the background in che Arrange window, winle

holding the [©)fctd] (Mac OS) or [@)fak] (PC) keys, allows you ta

scroll the window both honizontally and vertically.

4.3 Matrix Editor

Change Note Start Point

In the Matrix window, the head of a note (startpoint) cun he
changed while retaining the original endpoint. "Uhis is done by
grabbing and dragging a note at the bottom left cormer. " hin
function is similar to adjusting the startpoint of o sequence in
the Arrange window,

4.4 Hyper Editor

Hyper * Create Hyper 5et For Current Events croames @ new
Hyper Ser with event types that match those of the selecied
events, This is especially nice if vou want to quickly creare g

I Iyper Set for all event types creared in the conventional object
based Hyper Diraw. You can open the Event Fditor, select all,
deselect the note events, open the Hyper Editor and vse Hyper
> Create Hyper Set For Current Events. All used evenr types
van then be edited in the Hyper Ediror.
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4.5 Environment

Cross-Platform Compatibility of Chord Memorizer and
SysEx Mapper

The "Chord Memorizer™ and "SysEx Mapper™ Environment
ohjects ane now fully cross-plattorm comparible.

4.6 Quicktime Movie Support

Version 5 introdices g l"||_ll:|'!||J-{.'.I'thiﬁ,'}11|j]gi:::i to the ||u.r'|di|'||g of
Quicktime movie files—NAlue OS only.

& A long chick on the Movie window while holding
COMMAND allows the opening of the menu containing the
VITIOUS mavie options,

& A short click on the Movie window while holding
CIOMMANDY toggles berween a borderless big view and the
norml view,

® (licks in the upper righe arca of the Movie window works ax
above without the need for the COMMAND modiher,

In cases where movies have active areas (*Buttons™, for
cuumpled, they can now be used, In previous Logic versions,
such burtons did nor work because all clicks within the movie
arcitaceessed the Hip menu or toggled berween a borderless big
view and the normal view,
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5.1 New Song File Format

Al eelel somgs will avtomatically be converred to the Version 5
fornat when opened. Please note thar Version 5 songs can wet
b apened by any 4% version. Should you wish to use an older
o version, or visit another studio thae uses an older version,
yom nay retn a copy of the song (particularly vour Auroload)
in Version 4 format.

Iestlomwing ehe initial conversion, all further song save opera-
tions will anromarically open the file selector, allowing vou o
save the song with a different name.

As i convenience, there is also an “Export 4.8 format song”
option. Choose File * Enport > Export Song as Logic 4.8 Song...,
tvpe in a file name and click on the Save button,

I&| Please note that not all data can be saved in Version 4.x song format
Generally, this applies to data connected with new version S features,
such as Track Automation

5.2 Unified Virtual and Classic
MIDI Engine

T'his new funcrionalicy integrates Logic’s MIDI and Audio
engines, This allows a range of new options, which are of partic-
ihar use for Audio Instruments.

[0 che Environment window, Audio Instruments can be
processed via Logic's realtime objects, such as arpeggiators,
tlelays ere. Cabling of these objects must run v 1o the Audio
{Mrject which has been detind as an Instrument. This new func-
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tionality allows a number of creative options. An in depth
descriprion of all Environment functions and instructions on
how to use them can be found in the Logic Reference hMManual,

In the Armange window, the unification of the two engines
allows sequences on Audio Instrument tracks to respond 1o
changes made o) the quantise, loop, transpose, delay, velociry,
dynamic and gare nme parameters in the sequence parameters

lrx.

The new MIDI engine is capable of dealing with sample-acen-
e tme .“ilﬂl'l'l.['l il‘lrﬂrlll;ltiﬂl‘h "I."|'Itlll."'| CNsuUres tl'l-'.'ll !'i-'"lllll.L"-;.'lI'.'l.'ll"
rate pluyback timing is retained for Audio Instrument channels
when Environment objects are used for processing,

If you encounter any problems or unusual behaviour:

Unchecking the “Use Unified Virtual and Classic M1DI
Engine” checkbox will disable this new functonality, "This is
accessible via Options » Settings » MIDI Interface Communi-
cation.

@] we would appreciate an e-mail message from you indicating the
nature af the problem, if any, and as many system details as you can
provide. Flease send messages regarding issues vath this new fum
tionality to support@emagic.de In the Subject line, please add the
following: “UME"

5.3 Global MIDI Delay

Laospgie™s andio capabilivies have changed in a way that now
allows many nsers to work withouot an external mixing desk—
b it ailog or digital. When working with one external M1
istroment (or 3 AT sound module with integrated anadie
gt mixing function), vou can connect it's analog audio
outputs dircerly to che audio inpurs of the audio hardware used
Iy Looygric. As all aundio (and NI processing involves Luteney
of ome sert or another—which 1s extremely shore with Logic amd
mast recent hardwarce—you can compensatre for this lag time by
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setting o negative value wirh the new paramerer Delay all MIDI
Output. The amount of latency depends on the audio interface
nsed and irs butfer sertings.

You can find and set the parameter under Settings > Synchro-
nisation > MIDI, in milliseconds,

Al 1o tind the nght value for your system, record a one bar, 4/4 kick drum
sadpience from your sound module as an audio file. Once the audio is
rvoniled, ensure that it sits exactly on every beat—use the loop fund-
fion dor the audio region. Loop the MIDIE seguence (playing the MIDI
mwsdubed in the same way, and run both the recorded souna and the
"l sound of the MIDI module, at the same volume, If necessary,
dljust the Global MIDI Delay parameter while listening to both
sounds. If you hear any “phasing”, tweak this setting until both
sounds run in perfect synchronicity

5.4 New Tool Functionality

Iy suledision to the new automation tools discussed in che Awrs
mation Tools section, on page 31, the Scissors tool now openites
in rhe following way.

When pressing OPTION (CTRL on Windows), while the Scis-
sors tool is selected, and clicking on an object: the object will be
divided equally, The Informartion Line will display " Divide
Mulople™.

As an example, if this method were employed ar position 5 1 1
I of a 12 bar long sequence object (starting at position 1 11 1),
the sequence would be divided into 6 equal pares. Lf divided at
position 5 1.1 1, it would be divided into 3 equal parrs.
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5.5 Key Commands

Nudge Commands

The arsenal of nudge Key Commands has been expanded.
These upply to notes (in the Matrix, Event or Score Editor), as
well as ro regions and sequences in the Arrnge Window, The
mumes of the Key Commands are self-explanatory:

3 3

Nuelpr Foent Length by Beat +1
Nuelge Fivent Length by Bear =1
Nuelor Fvent Length by Bar +1
Nuwelge Fovent Length by Bar =1,

Setting Note, Sequence and Region Starts and Ends to fit
Song Position

You can move the start or end of a selected abject (sequenve,

region or notes inany editor) to the Song Position Line, by use
of a Key Command. Unlike the Piotap Clock commuand, sndin

data is not moved, when using Ser Obect Svaer to SPL Posetion on
an audio region. The relevant Key Commands are:

o Ner Oyect Start to SPL Position
& Ser Obfect Ead vo SPL Posirion.

8 NN

1 Although these Key Commands work in any open editor window,
their use only makes sense in the Arrange Window and the Matrix
Editor, and perhaps in the Score Editon. This is because these editors
are mare "visual”

k| The use of ser Olyect Start fo SFL Position is only possible when the
Song Position Line (5PL) is placed before the start of the event. Simi-
larky Set Obect End to SPL Position only makes sense if the SPL 15
placed afrer the end of the event. If not, the length of the abyect will
e shortened to one format (denominator) value

Key Commands toggle between Tools ]EJ
key Commands which switch to a specific wool, now toggle
berween this tool and the previously selecred tool.
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Key Commands for Tools i)
MNew key Commands far choosing a specific tool,

Video to Song Adjustment @
Option > Settings > Video to Audio ad justment has been
renuned to Video to Song Adjustment.

5.6 Recalling Screensets,
Windows and Editors

Toggling Windows and Editors On and Off

Laogie 5.0 features Key Commands thar switch windows and @
editors of a given type on and off. In cases where a window is

already open, but not topped, it will first be topped. With the

next hit of the defined key, it will close. Open the Key

Ciommands window and search for the fogefe charcter string,

Any of the editor windows can be opened, brought to the top

and closed this way (Arrange, Event, Matrix, Hyper, Fnviron-

ment, Track Mixer, Transpore...).

Recalling Screensets 1 to 9
Screensers 1o 9 can now be recalled by freely defined key and E;I
AIDI remote commands, not only the numerical keys. "'his

wuy, you can redefine the numerical kevs for other puposes,

such as toggling windows on and off, as described above. The
vommands are called Recalf Screenser (... 9, respectively).
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5.7 Hierarchical Menus

A hierarchical menuing structure has been implemented for
audio and MIDT objecrs defined in the Environment, and for
native, VST 1 and 2, DirectX and Audio Instrument plug-ins.
T'hese flip menus are accessible from the Arrange window's
Hirack List, audio channels and from paramerer boxes
thronghout Logic. Lise of these menus greatly accelerares
wevess to different objects and is useful for organizational
purposes, particularly on systems with extensive environments
ur nmerons plug-ins,

o aceess the hierarchical flip menus, simply click and hold on
a MDD or andio track name in the Arrange window's Trck
List, an audio channel’s insert point or on the Cha parameter
value in any audio object paramerer box,

The hierarchical menu structure reflects Environment layers,
Entries in the main and sub-menus are listed in alphabetival
andfor numerical order. Audio objects are sub-grouped by
class—Audio “Tracks, Instruments, Bus, Master, Inputs and
Outputs, plus stereo infoutputs.

Mulel Instruments are hicrarchical and have 16 M1 channels
plus “All"™ as a sub-menu. "The current program name for cach
channel is shown as well.

The “Sort by Layer” setting is also valid for the hierarchical
instrument men: If enabled, the Layer numes will be used in
the hierarchical path, If disabled, some Environment objects
are hierarchical regarding their types (e.g. “Instruments™ or
“Macros™), Empry hicrarchical paths will not be displayed.

T "Dhsplay Preferences™ you can disable the hierrchical
wistonment menu. I disabled, the old stvle, long instrument
menns will be displaved.

O Ml OF computers, the font size of the hierarchical menos ‘:
depends on the global "Large Local Window Menus™ display
sctring under Apple Menu » Control Panels > Appearance » M;H'
Fonmts.
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Hierarchical Menus for Plug-ins

Moo and stereo plug-ins are separately grouped by API—
g, VS o DireceX,

Laogic plug-ins are furcher sub-grouped by type—Helper,
I'.h.:l..l'!..'1 Maodulution, E,Q cic,

VS plug-ims can be manually grouped by creating a folder—
e “medubinen” within the “VSTPluglns™ folder inside the
Laogie progeam folder. Simply drag and drop the desired VST
plug-ins o this newly ereated folder and their menu structure
will be retlecred when clicking on the Logic Mixer plug-in
el

5.8 Extended Zoom Functionality

Laopic enhances its zoom functionality with new navigation
nunagement aptions, These commands allow selecred aljects,
o region defined by the locarors, wo be zoomed o fir the
sereen. In additon, the lase thiney zoom levels and window
seroll-har positions can be freely defined and recalled for cach
window. There are no default Key Commands for these navigg-
Lieein nprions, 5o you will need o assign them in the Key
Clommands window. Open Options > Settings > Key Commands
aned in the Search field, tvpe in “nav™. This will display the
citries described below. Assign Key Commands as per the
mstrnetions found in the Key Commands section of the
HTITIATN

& Niove Navigation Snapstor—ithe current zoom and window
position scroll bars sertings are saved as a “step”™ in the nuvi-
arion pachs,

® Neovigate Back—recalls the previous step in the navigation
prath

® Navigate Forward—advances to the next step in the naviga-
riomn paith
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New Zoom Key Commands

® Zoom fo fit Selection vertically & horizontally, store Nevigation m
Suafushar

® Joom to fit Selectron horizontally, store Navigarion Snapshor m

® Foom fo fit Locarars, stare Navigation Snapshot EJ

All voom commands creare a new step in the navigation path,

The "Navigate Back” Key Command allows you to recall the

AP IS ST .‘SEI."[I.I'II-."..‘L

Remember: Using the magnifying glass allows you to zoom in
sevenl imes. A briefclick with the magnifying glass will return
tor the previous zoom and window position scroll bars serrings,

Auto Track Zoom

This feature automatically togeles between a “zoomed”, ol
standard viewing mode for the selecred track, As new trcks are
sclected, they will automatically be zoomed to a level set by
WO

"To use this funcrion, simply select View > Auto “Irack Zoom,
and resize any track, by grabbing its lower left hand corner and
moving the mouse vertically, Release the mouse button when
done.

Now, as cach track is selected, it will avtomartically zoom to the
track size (zoom level) that you just set up.

MMC Input and “Full Frame Messages”

Laogic can be controlled by MMC (M Machine Control) and
abso by “Full Frame Messages™ (Listen to MMC Input).
“Transmian AMACT has been available in Logie for fuite some

THIvies,

BBy clicking the syne button on the Transport bar, you can open
the synchronization settings, Select the NITDT page and swirch
on Listen to MMC Input.
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Laapie then recognizes these commands:

& [l
o fleferrved Play and
® N,

Deferred Play is a special commund for mechanically slow
synchronisation slaves like reel-to reel tape recorders. Rather
than making the machine play immediately, the machine is
ashed o reach the desired SMPTE position first, before play-
btk os stareeel. You'll find no difference in Logic's response to
the Mplay ™ andd “deferred play™ commands, as Logic can locate
ws apuickly as any hard disk recorder.

e ignores these message, when incoming external MO
(ML Time Code) commuands are being derecred.

o also obheys so-called “full frame messages™, setting
Logic's 5PLL to a new position, without starting playback. Once
agznin, incoming MTOC data receives higher priorivy if
conticting information is received,

Soime synchromizers send “Full Frame Messages™ instead of
METC o locate the slave deviee (Logic in this case) tooa new
prssition, withouoimpheily starting the plavback. "Uhis is nselul
when in slow shurtle or single frame advance with video
muichines, hecause the slave device is perfectly located without
besinnge in playback mode,

MMC Locate also with internal Sync
HMIMC is enabled, the “MMC Locarte™ command is now also
sent ininternal syne mode.

Reference Addendum
Varsion 5 =E|



Chapter 5
Functions

Emagic
54 Logic



logicl|>

Chapter 6

Plug-ins

6.1 Plug-Ins, in General

Open plug-in window on insertion

Inserting a plug-in on anv channel’s insert point will automar-
cally launch the plug-in window. This functionality can be
disabled by unchecking Open plug-in window on insertion
under Audio > Audio Preferences.

All Plug-Ins Totally Automated

Like Logic's own plug-ins, VST plug-ins can alsa be anto-
mared. Automarion i1s not possible with DirectShow plug-ins
(Windows) due to technical reasons based on the principles of
the DircetShow interface.

Effect Plug-In Delay Compensation

The preference Plug-in delay compensation, which you'll find
under Audio > Audio Preferences compensiates for delays of
audio data which may be introduced by some effect plug-ins,
T'he compensation works with Logic internal effect plug-ins:
Ad-Limiter, Denoiser, Enveloper, EnVerb, Limiter, Multi-
pressor, Noise Gate, Spectral Gare as well as with some VST
plug-ins.

For the Plug-in delay compensation to funcrion the plug-in
must be capable of passing on informartion abour its processing
delay to the host application (Logic). Check with the plug-in
manufacturer to find out if your effect plug-ins provide rhis
Fucility,

Plug-in delay compensation is effective on effect plug-ins
mserted in Audio Tracks and Audio Instruments. "lo ensure
that this compensation works with insert effects on Audio
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Instruments, please ensure that the UME (Unified Virtual and
Classic MIDI Engine) is engaged in Options > Settings > MIDI
Iinterface Communication,

6.2 VST2 Support

Peemgin: smapapresrts the ViS'12 formnat for signal processing and
vithual istrmme ne plug-ins,

"WatPlugins™ Folder

I oeder 1o wark, V'L plug-in tiles must be copied o the

Vet apefors toldder, wlieh resides in che Logic program dircctory/
folden. Simply creae a folder with this name if it does not yver
CRISEL

VST Plug-ins Consider MIDI Clock

VST 2 instruments can receive VST clock informarion, making
it possibile to pertectly synchromize delavs, LFOS and other
effects to the song tempo. Note that the plug-in must reguess
this information from Logic, and that #er @l plug-ins do this,
Check with the plug-in manufacturer ro see if this funcrionaliey
applies to the particular plug-in used,

VST-Plug-Ins respond to Program Change Messages
Lagic supporns programs for VST/VSTZ plug-ins, in cases
where a plug-in provides prograom memory, You will find a
e in the hewd of the plug-in window that displayvs the
current by selected program., Dlouble elick on a program name to
rerme i,

With VS 12 imstroments, internal settings (sound programs) can
b echanged vio standand program change commands. Afrer
preessaings stopn an “All notes of 7 message will be sent to the
pse] Ao Instroment channelis).
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Loading Original “Effect” and “Bank” Settings ﬁ—
Load Settings allows the loading of Cubase™=formart “Effect™
aned “Bank™ plug-in settings into plug-in program memaory. MHC

These particular sectings are shipped with many plug-ins and
cun be found in the VsrPlugfas folder.

‘1! Hint: Copy or move these settings into the “Plug-in Settings"” folder,
argd from there into the folder of the corresponding plug-in to directly
MU 1hese settings without having to use the file selector,

Switching VST Plug-Ins with the Plug-In Enabler -
Yoo can nse the Plug-In Enabler to acrivare and deacrivare

I MireetX plug-ins. VST plug-ins can be disabled by moving the
assockied DL file into another folder.

For Users of VST DSP Cards

Should yon nse one of the VST DSP andio hardware cards,
such as the T PoarerCore, Universal Audio UAD- I or Creameare
N1, please use the Plug-in delay compensation preference,
which vou'll iind under Audio > Audio Preferences. It compen-
sates for delays of audio data which may be introduced when
using plug-ins with these cards.

This compensation is effective on effect plug-ins inserted in
Awchio “Tracks and Audio Instruments, To ensure that this
compensation works with insernt effects on Audio Instruments,
please ensure that the UME (Unified Virtual and Classic MIDI
Engine} is engaged in Options > Setiings > MIDI Interface
Communication,

6.3 Proprietary Logic Plug-ins

“Mropretary” Logic plug-ins are the name we give to the plug-
ins included in Logic’s feature ser. All signal processes used in
recording, mastering und broadeast studios, plus those found in
sound reinforcement svstems are included: dynamics of all
kinds, delay and modulation etfects, reverberition and room
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simulation, equalizers, non-harmonic distortion processes,
excirter, sub-bass gencrator, sterco-basis enhancement and
single-ended noise reductions.

T'he following seetion covers the many plug-ins thar have been
added since version 4.0k

Stereo Spread

Fhe "StereoSpread™ plug-in is a standard effect for mastering.
Phere ae several ways to extend the stereo base, including
“Spatinl Soumd™ algorithms of the Ghettoblaster type or

v ring with the signal™ phase, They all sound OK initially,
it ot tend to nullify the transient response and mono-
vompatibilivy, Steeen Spread, however, works differently,

k The (Helper >) Direction Mixer s one such process, Its Basis parameter
allows steren spreading, when set 1o values higher than 1.0, With
non-transient, non-percussive material, for productions that won't be
played back in mono, and for single tracks (like string pads in a
complex arrangement), this effect can be of great benehit.

Fhes Neeere Sprevesed Tollows a pure and simple method: it extends
the stereo base by alternately distributing a (selectable)
rumber of frequency bands in the middle of the frequency
ringe to the left and right channels, This greatly increases the
perception of the stereo effect, especially when “giving™ a
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stereo effect to monaural recordings—withour making them
sound rotally *alien™.

Order
T'he Order knob determines how many frequency bands the
signal is to be divided into.

Upper int.
Ihis parameter controls the intensity of the base extension of
the upper frequency bands.

Lower int.
I'lis parameter controls the intensity of the base extension of
the lower frequency bands.

@ Note that 1. the stereo effect shows up mainly in the middle and
higher frequencies, and 2., by distributing very low frequencies to the
left and right speakers, you will reduce the energy distribution of any
speaker. Therefore, you should abways tend towards a lower intensity
value for the lower frequency bands, and set the “Lower Freq.” (see
below) to around 300Hz (at least)

Upper Freq.
‘T'his sers the upper himirt of the lughest frequency band o be
distributed in the stereo image.

Lower Freq.

I'his sees the lower limie of the lowest frequency band o be
dhistribured in the sterco image (see also the note in the “Lower
Int.” section above).

The Graphic Display

The graphic displays the selected order (i.e. how many bands
the signal 15 divided into), and and how stirong the effect of the
stereo spread will be in the upper and lower frequency bands,

I"he upper section represents the left channel, the lower
section the night channel, and the frequency scale (as wath the
Iar ECY) shows the frequencies in ascending order from left 1o
nghe.
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Spreader

This plug-in is designed to enhance the stereo spectrum, just
like the “StercoSpread™ plug-in, but its functional principle is
totally different. "I'he Spreader, in a way, works like a chorus
effect, bur urilizes a very sophisticated frequency smoothing
techmgue on a sumple-by-sample calculation basis, This offers
wsomie puety which is unknown in conventional chorus effects,
The mendubarion of delay time with a triangular wave resulis in
perss b non-linear frequency shifes, which means that the
prvhoas affecred by the effece. The modulation is phase-
mverted on hoth channels,

1 he stereo version works in “true stereo” {(two channel opera-
tiend, whilsi the mono-sicreo version converrs a mono input
sigial into o stereo signal,

LFO Intensity und Speed can be set freely. High values lead o
detuning effects. Mix defines the ratio of effect signal and dry
original signal cutpur you'll set it to 1700% if vou insert the
effect into a bus.

Channel Delay adds an extra simple delay by the displayed
number of sample words. By delaying the right channel, the
stereo effect becomes even broader.

De-Esser

A De-Esser is a signal processor used for the rejection of
Bissing, or sibilane noises, This s why it is called a “De-Esser™,
s occasionally an *5"-Suppressor. You can, of course, reject
sietling frequencics with an equalizer; Bur a Die-Esser rejects
the frequeney band for only as long as there is a level threshold
which is being overidden in a specific frequency band. This
“lvicanie " ability is why the sound won't ger darker when no
secching consonant is sounding. A De-Esser is a frequency-
specithe compressor which only compresses a particular
frequeney band in a complex full band signal. It features
extremely Fast artack and release times,
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With the Emagic De-Esser, the dynamic rejection does not
necessarily take place in the same frequency range that’s being
wnalyzed, Rather, the De-Eiser performs a gain reduction in the
frequency band displaved in the lower window, for as long as
the level exceeds a threshold which falls within the frequency
rinpge displaved in the upper window,

i Flease don't confuse a De-Esser with an effect krown as a "Voca
Stressor”. The latter reduces the gain of the entire range when the
level exceeds a threshold defined in a gven frequency range. This type
of processing can be achieved with any compressor with a high pass
filter ar EQ inserted in its side chain.

The Emagic De-Esser does not make use of a frequency
dividing nerwork (crossover utilizing low and high pass filrers).
Rather, it s based on a subtraction of the isolated frequency
bunel, leaving the phase-curve untouched.

I&| The De-Esser is important in FM radio stations, because sharp “5°-
“"DF Consonants Can cause harsh r‘ltel'l'r“lt':-dulﬂllfjn aistariion noses

I'hese are the parameters in detail:
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Detector Frequency

Here's where you define the frequency band that the De-Esser
reacts o, 1S not necessarily the same band thae will be
reduced.

Detector Sensitivity

Here's where you define the threshold which has to be
excecded around the Detector FI‘E‘qIJEHE}', in order to make the
De=Pisser reduce the level around the Suppressor Frequency.

Monitor

With this swirch, vou can monitor the side chain signal the De-
Fover avts upon, 1 vou want to reduce sibilant noises, hsten to
the input signal here, and ser the Detector Frequency so that the
staaling frequency range becomes mose audible,

Suppressor Frequency

Here's where vou define the frequency band which will be
reduced, when it falls within the frequency band defined by the
Detector Frequency, and the threshold level, defined by
Detector Sensitivity is cxceeded.

Strength
Strength scts the amout of gain reduction around the
Suppressor Frequency.

Smoothing

Smoothing conrrols the reaction speed of the gain reduction
start and end phases. It's a combination of artack and release
time parameters, as known from compressors.
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Limiter

I'he limiter is also standard effect for processing a summed
stereo signal, i.e. for mastering. A limiter performs a dynamic
campression at a ratio of eo:1, ar a threshold ser close o
maximum—arc least with analog limiter applications,

limiter

Gain

Mast analog imiters would have a “Threshold” control, like
that on a repular compressor, rather than a “Gain® control, "lis
sets the level ar which the limirer will begin to work,

As Logie’s Limiter s digital, and thar limiting is normally
applied before the signal is roured o another digital process
{(which cannot handle more than 0dBFS), we can presuppose
the following:

1) the input signal sometimes reaches O0dB, but docs not exceed
this ceiling, and

2} that the limirer is being used o raise the signal’s overall
volume, This is the reason why vou find a Gain control here—
i.e. to set the desired level of gain for the signal.

(] The Limiter is designed in such a way that if set to 0dB Gain and OdB
Qutput Level, it doesn’t work at all, on normalized regions.
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Loockahead

Lockahead derermines how far the processor “looks into the
furure”, in order ro react earlier (thos betrer) to incoming
volume peaks, and therefore avoiding signal overloads. During
plavback from hard disk, the tracks are (internallv) delaved
slightly, allowing the “lookahead™ process to react before signal
peidiks ovenr. This is not the case with realtime-processing, for
instunce, when the plug-in is insered into an input object in
sty imesle,

Sei Lookahead to higher values if you want the limiting effect
1o take place before the maximum level is reached.

Release
Flere, you can set the time the miter will need after liminng 1o
“releuse " the effect and o restore the gain to its oniginal level,

Output Level
Uising this simple volume control, you can set the desired
maximum level of the Limiters outpur signal.

Soft Knee

The Softéner parameter produces a softer transition from “no
limiting” to full limiting. If switched off, the compression
curve—the output level displaved as a function of the inpur
level—has a hard knee. If switched on, the transition to full
himiting 15 non-linear, meaning softer, The limiting of the signal
will srart before reaching OdB. This will avoid distortion arte-
fucts oceurmng when strong himinng 15 used without a soft knee.

¥ AT yesLwant 1o expenment with the effect of the knee parameter: The
connpressor (and multipressor) algonthm displays the knee parameter
ijFpilag .|||!||I

Gain Reduction Display
Fhe graphic display shows the reduction of level 15'[1|_r|::i|'|17'; from
il downwards).
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Multipressor

The “Multpressor™ (an abbreviation for muftiband compressor)
I5 the epitome of an andio mastering tool. Like no other signal
processor, it can raise the perceived volume and thicken the

sound of a complex arrangement without exceeding the avail-
ible headroom. "That said, a “good” setting is a matter of prac-
tice and experience with mastering on a wide range of marerial.

The Emagic Madeipressor fearures a graphical user interface
thit™s both easy o understand and easy to use. lis crossover
lrequencies and compression paramerers can be edited directly
by prabbving the graphie display with the mouse, The compres-
ston curves in the middle display, and the gain reduction (or
level meters, respectively) for cach band, make che Muftipressor
casier o use than any dedicared, sophisticated hardware
WRISTETINE COMPressor,

It affers a significant advantage over analog and digital hard-
witre multiband compressors, because of s lookahead fung-
tiean, which allows it to “see™ a lictle into the future, T'he
provess pre-reads levels that will be plaved back from hard disk
i sophisticated buffer. T'he audio is then sent from this butfer
through the process and plaved back—with no delay occuring
inits output, What's more, the phase response of the process
wan't be distorted. This is because the Multipressor utilizes a
plizise neutral substraction techology, instead of a conventional
freqency dividing crossover neowork. In conjunction with the
other mastering tools—the Far EQ and Adapuive Limiter plug-
in—ithis process 1s superior to the most sophisticated mastering
provessors, especially when vou consider irs 24Big/96kHz
support within the digital domain.

Ikl The Multipressor requires a lot of processing power. In cases where
your camputer won't allow for another multipressor plug-in, it's sdvis-
able to bounce a mixdown file first, This bounced file can be played
back on a single stereo track and treated with mastening tools, while
the other plug-ins are disabled.
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Function Principle

Tl multi-band compressor splits the incoming signal into two
o four different frequency bands before applyving compression.
These frequency bands are then compressed (and downward-
expanded, to suppress noise) independently, After compres-
sion, the frequency bands are mixed back together.

The aim of independent compression of different frequency
bands is to reach high compression levels on the bands thar
need it, without the “pumping” effect that is normally heard at
high compression levels.

il Heresan example: If the bass drum produces level peaks, a smple
compressor would reduce the level following every beat of the bass
drum. If the signal is 3 mix which includes the voice of a singer, you
will hear the singer's voice becoming softer on each bass drum beal
e, the signal will "pump®. Peak levels produced by the singer woukl
also reduce the level of the bass drum. If you compress the two
primary frequency bands for these elements independently, they
cannot affect each other

Much higher Ratios, and therefore a much higher averapge
volume is possible before the unwanred artefacts of compres-
sion will be heard.

#| Hint; always ensure that the incoming signal is not digitally clipped;
the compressor works best when the signal is below Od8.
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Downward Expansion

Strong mult-band compression allows you to raise the overall
volume level—resulting in a dramatic increase of the existing
noise Hoor and ambient room retlecuons. *Downward expan-
ston”™ allows vou to reduce or suppress this noise. Each
frequency band features a downward expander. This works as
the exact counterpare to the compressor: while the compressor
vompresses the dynamic range of the higher volume levels, the
tliwnward expander expands the dvnamic runge of the lower
volume levels. With downward expansion, the signal will be
weduced in level when iris lower than the defined Threshold
level, "The effect can be compared to a noise gate, but rather
than simply cutting off the sound, it proportionally fades the
volume using an adjustable Ratio. "'he effect is more
pronounced as the level falls further below the threshold.

Bands

This parameter (on the righr side) determines the number of
independently compressable frequency bands, and las o
crucial impact on the amount of computing power necded for
the effect. Classic multi-band compressors use 3 Bands,

Lookahead

Lookahead (just below the Bands parameter) determines how
fur the processor “looks into the future™, in order tw react carlier
tthus betrer) o volume peaks. In plavback mode (when
mastering and bouncing), all rracks are internally delayed in
order to compensate for the lookahead time span. This is not
the case with realtime input signals.

Ser Lookahead to higher values, when the Peak/iRMS control
isee below) is ser further towards RS,

Peak/RMS

Adjusting the control berween Pead (full left) and RIS (Roor
Mean Square; full right) is dependent on the type of signal vou
wish to compress: An extremely short Pead detection setting 1s
suitable for compressing low-powered, short and high peaks,
which do not rypically occur in music, The RS detection
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method measures the power of the audio material over time
and thus works much more musically. This is because human
hearing 1s more responsive to the overall power of the signal
than to single peaks. As a basic setting for most applications, the
center position of the control 15 recommended,

Attack

Allows vou to define the time (in milliseconds) required before
li'l-ll'li'lrt,‘h?iiﬂl'l. i% faded in, At |'|1';_,'l'|1 values for Attack, Fast ]_‘I-lll,‘_iﬂﬁ.
van exceed the threshold, but the sound remains more vivid, ‘1o
aviriel exceedig the threshold, vou can make use of the Adap-
tive Lamirer.

[l The attack of the hMultipressor is extremely fast. If the Multipressor
produces clicks and pops while changing parameters (ie.; during
automation), you can reduce these clicks by setting the attack param-
eter 1o values lager than Sms for the desired band. This will smooth
the compression curve and all resulting volume changes

Release

Defines the time required by the compressor to “release™the
effect, following compression. Just as with the other values, the
best setting for this is greatly dependent on the material to be
compressed,

As an example, with fast drum&bass passages you would need
to set the shortest possible Release time, if yvou wanted all indi-
vidual impulses to be compressed. On speech recordings, it
often makes sense to set values greater than 1 second (10040
ms). The aim 15 to avoid “pumping” of the signal, once this
parameter is set.

Multiband Graphic
The graphic editor to the left displays several sertings, both
graphically and numerncally,

Crossover Frequencies

The crossover frequencies (vertical borders) between the
bands are variable. ‘lo change a band's crossover point, grab the
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Border(s) direcely within the graphic and move them o the left
of right, 'The frequency is displaved numerieally at the bottom
ol the graphic.

Absolute Volume

I'he horizontal line in the middle of cach band displays its
vurrent level (defaule: 0dB), By grabbing the area below this
line and moving it up and down, vou can ser the absolute
volume level of the corresponding band. The level is displayed
nummericilly at the bortom of the graphic,

This abilicy allows the Mufirpressor to serve as a basic equaliza-
tien toel, dependent on how the crossover frequencies are ser,

Threshold Display

T'he hornzontal lines (up to three) in the lower area of the
window represent the Tresbold values for Compression (npper
line), Expansion (middle line), and Reduction (bottom line). You
van ser these values by using the controls of the same mimw (see
helow),

Selecting the Band to Edit

Yo can select which frequency band you wish ro edir, by
clicking in the lower section of each band. Ser the Rase and
Threstadd values for each band as desired.

Comp. Ratio

“I'his 1s the central parameter for compression, in conjunction
'I.\'IIEJI ﬁ-l‘.-'ﬂfﬁf?'.'n'.l{.f‘l‘!# ?;’i’f?'.f.li'l’.l‘fr'?r. T]IL‘ r:f.-'”.l"f:' Hﬂ'fl:ﬂ IIt:ll:rnﬁil\Uh tilu
strengeh or rare of reduction of the range to be compressed. In
most cases the most useful combinations of these two settings
are either 1} low Thoesdodd and low Ratie or 2Y high Thresbeld and
high Keatio,

The first set of settings is suitable for speech recordings which
contain passages of differing volume, that need to be levelled
oL,
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The latter is suitable for any material containing pereussive
instruments. As short transients have a high level, the instru-
ment cannot be nmuxed at the desired volume, so the overall
signal becomes too low. In this scenario, vou would select a high
compression rate (Ratio), which comes into effect at higher
vilume levels,

Exp. Ratio

This is the central parameter for controlling downward expan-
ston, in conjuncrion with Expansion Threshold, It determines the
strength of expansion, applicable to the range to be expanded.

1 he general idea behind “Downward Expansion” is to get
“berween” the level of the noise (raised by the compressor
el and the level of che Compression Threshold, in order to
reduce it Ldeally, this will resule in only the “noise™ portion of
the signal being affected Ly the expansion process. Lise the
Expander with care: It can cause a loss of signal energy that you
had intended to “push™ with the Multipressor.

¢ Normally, on signals with a relatively low noise floor, the
Expansion Threshold can be set low. This way, a greater range
of the middle volume levels remain unaffected, and only
very low passages will be expanded (i.¢. reduced in level). At
extreme serings, vou can almost achieve the functionality of
a MNoise Gare (cutting off the noise floor down to almost
OdB),

® [n signals with o strong “hiss”, expansion should start
shightly below the Compression Threshold, av a low Ratie, to
prrevent noisy passages from being reduced too much in
lesweel,

Graphic curve

The graphic area in the middle of the editor shows the ratio
berween the input level (horizontal scale) and outpur level
(vertical seale) of all bands, “T'he colors correspond to the colors
of the frequency bands in the left graphic area. By adjusting the
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Ratio and Threshold controls, you can change the curvatare of
the selecred frequency band,

Thresholds: Compression

Here, vou can set the minimum level at which the compressor
will begin ro work. If the control is ser all the way 1o the right

(OB), the entire compressor section of the Multipressor is “off-
hne™. "The furcher the control is moved o the left, the lower the
vvel above which the compressor will work.,

Thresholds: Expansion

Here, you can set the maximum level ar which the expander
should work. If the control is setall the way to the left (-50dE),
expansion will only ocour on signals thar fall below this level
i'I'he Exp. Rarie can be setwo a minimum of 1.2:1; below <5048
the expansion always takes place ar this low ratie,) The further
the control is moved to the right, the higher the level below
which the expander will work,

Reduction

Allows you o detine how much the noise level should be
reduced (this is not a threshold value). If vou move the control
all the way o the left, the reduction will be maximized (by
-5 B). If the control is set all the way to the right, no reduction
will nccur.

Level Meter

In the level meter to the right, you may monitor eicher the
change of level caused by the compression, or the ourput
volume of each band, depending on whether vou have selected
Cretrnr change or Churpre (see below), You can individually switch
the bands on and off, in order to listen o single bands, by using
the switches below the meters. IF the swirch below a band’s
merer s it (light green), then the band will be audible, IF it s
chirk, the band will be mured.
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Gain Change/Qutput
The Gaen change and Chetpes buttons can be used o switch the
operation of the meters,

& [F Cevw change 15 selected, the meters indicate the sirength of
reduction o the level of the audio marerial by the
COMPIESSor,

o IF fdurpnt is selecred, the meters show the absolute output
level af the corresponding frequency band.,

Master Gain

Adlsws vomn 1o reduee the overall gain increase (or increase the
overall gain reduction), resulting from the Wultipressors
sCHEs,

Ad-Limiter

With its Compressor, Multipressor and Limiter—non 1o forger the
destructive pracess of normalizing—Logic features several
extremely versatile oprions for increasing perceived volumes, A
further tool which can be used to increase the perceived level of
signals is the Adaprioe Limiter plug-in. In the world of analog
processors, it could be more closely compared to a “clipper”,
rounding and smoothing only harsh level peaks, rather than o a
VOA-tvpe limiter, Ir allows vou to achieve maximum gain,
without having to fear exceeding 0dBFS. The Ad-Lawiter may
shghtly color the sound. An effect most similar to an amplificr
when driven hard.
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Following the Adaptive Limiter process, tracks normalized o
ikl appear to sound about 2dB louder, ni::p::nd'ing an the
source signal, As with other Logic dynamic processes, this plug-
inalso features o lookahead facility (ser o a Axed time span),
allowing it to “look into the future™. T'he Adaprive Limirer
reacts o level peaks in signals streaming from the hard disk
Iretore they are plaved back, and delaying the monitored signal.
Tl pypical use of the Adaprive Limiter is in the summed mix,
Vs pluced after the Jeftigeessor and before Vodiae, in order 1o
produce o C1) of maximum loudness. As limiters compress
siprinals, it con produce resules which sound louder than those
resulimg from normalizing in the Sample Edivor.

St the process by adjusting the Input Scale, jusrt as you would
seta nixing desk’s Gain parameter, or a digital recorder’s
pevorling level, The parameter behaves much like a Gain
vomtrel, but its purpose is o adjuse the mput level, which must
never exceed OdBFS. Adjust the Gain parameter to *musically™
vontrol the internal process of peak smoothing and gain
increase. Out Ceiling reduces the output level of the process in
very fine steps within a range of only 2dB. This is no threshold
control, just a simple outpur gain. The Margin-Display shows
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the maximum measured level, In order to reset the Margin
display, click the “Over” lamps.

SubBass

This plug-in gemerafes harmonic signal portions in a frequency
band which is lower than the inpur signal it is derived from—
i.e. an artificial bass. This may remind you of a distortion or
overdrive effect: These generate harmonic contens, which
means that the new frequency portions have “n™ times the
frequency of the inpur signal. As opposed to these effects, the
sudBass is a synthesizer which generates sub-harmonies. It is
most similar to units often found in the power amplifier racks of
discotheques. By comparison, the subBass plug-in is far more
Hexible, Caution: The process is known as a loudspeaker killer!

1! Choose moderate monitoring levels, and never try 1o playback sub-
bass frequencies with loudspeakers which aren't capable of doing so
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Mever try to force a loudspeaker to cutput these frequency bands
with an EQ.

The simplest use of the subbass plug-in is as a simple
“octaver”, just like rthe effects pedals available for clectric bass
guitars. A simple frequency division circuit in such octaver
pedals requires a monophonic input sound with a clearly
detined piteh. Ocravers are usualyy only capable of producing
an oncput signal which sounds one or two octaves lower than
the imput signal. An octave 15 a frequency division by 2. A rato
of 4 means two octaves, and a rato of 8 ::quu.l:_. three octaves,

i Al whole fractions between 2 and 8 are possible as well, but don’t
necessarily suit the key. A ratio of 3 results in a transposition of a
duodecima (1 octave and a fifth, about 19 semitones) dowmsard.
This transposes a ¢l imio an F.

As apposed to a pitch shifeer, the waveform of the signal
svnrhesized by the sedBass has nothing o do with the wave-
form of the input signal. 1c's shape is sinusoidal—bur i pure
sine wave is rarely achievable (or heard) in complex armange-
ments, It is mixed with the original signal. The mix ratio is
detined by the Mix parameter.

I'hve swhHass creates two bass signals, derived from two freely
definable portions of the incoming audio, "This means thar
processing is not limited to monophonic signals with a defined
pitch, but also complex summed signals. Center High and
Center Low define the center frequency of the band that the
transposed signal will be derived from. The Bandwidth of the
analyzed band(s) isfare ser by dedicated paramerers. Wirhin
these frequency bands, the Altered signal should have a reason-
ably stable picch, in order to be analvzed correctly. The graphic
shiows the frequency bands of a typical boom box, which trans-
poses two frequency bands—with the widdh of a fifth—by one
octave each. If the analyzed frequencies chosen are a little
higher, the sudfiass plug-in plays these frequencies, much like a
bass plaver doubling the lower notes of a guitar player.
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In real life, narrow bandwidchs lead to the best results as they
avoid unwanted intermodulations. Ser Center High a fifch
higher than Center Low, which means a fuctor of 1.5 for the
Center Fregquency. Derive the sub-bass to be synthesized from
the existing bass porton (only) of the signal, and transpose by
only ane octave in both bands (Ratio = 2. Do not overdrive the
provess, tosvoid distortion, 1f you recognize (hear) frequency
gaps, move the Center Frequencies, or widen the Bandwidth a
Livtle,

He prodent when wsing the sedBass, and compare your super-
low e sigial pertions with other productions.

Denoiser

1'he Deaetser elimimates or reduces noise in recordings, Being a
single-ended noise reduction process, the effect causes audible
artefacts,

Threshaold

Fhis vidne allows you to adapt the process to match the noise
thonr level of the source marerial,

b Tip:Finda passage where {almost) only noise can be heard, and set
the Threshold so that only signals of this valume will be filtered ou
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Reduce
Here, vou derermine the amount of reducrion in dB.

Noise Type
The naise Aoor may mainly contain high frequeney or mainly
lovw frequency portions:

® ‘I'he value D means white noise (neatral, equal frequency
dhistribution in each bandwith measured in [z,

® With positive values (above 0), vou'll mainly reduce pink
mise, which contains more bass (warmer, darker sound, or
cejual frequency distribution in cach bandwith measured in
muosicil interval ratios),

& With negative values (below 0}, vou'll mainly reduce blue
noise, which contains more hiss (sharp sound).

Smoothing Parameters

I'he Denoiser works on the basis of FFT analysis, ro recognize
frequency bands of a lower level and lesser harmoniciry. Le then
reduces these bands to the desired dB value. In principle, this
method is never exact, us neighboring frequencies will also be
alfected. 1T you use the Desodser too agressively, the algorithm
will prodduce the so-called “glass noise™ effect, which is oruly
inieresiimg, but in most cases 15 even less desirable than the
CRINIE s,

There are three parameters for reducing this effecr in three
e nsions:

Time Smoothing
This s the simplest form of smoothing, Here, vou set the time
the Dlenoiser requires to reach or release maximum reduction.

Frequency Smoothing

I ere, vou define the wideh of a frequency band which overlaps
neighhoring frequencies. As mentioned, these neighbors will
also be reduced by the noise reduction. More precisely: If the
| Yenoiser recognizes that only noise is present in i cerrain
Frequency band, the higher the Frequeney Smoothing puram-
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eter is set, the more it will also change the neighboring
frequency bands, in order to avoid the unpleasant “glass noise™,

Transition: Level Smoothing

Here, vou can ser a factor for a smoother transition of the
denoising process to the “neighboring” volume levels. More
precisely, if the Denoiser recognizes that only noise 1s presentin
a certain volume range, the higher the Transition Smoothing
parameter is ser, the more it will also change similar level
values, in order to 1o avoid glass noise.

The Graphic Display
The graphic displays the Threshold, Reduce, Noise Type and
Transition parameters.

Exciter

An exciter gewerates high frequency portions that are not present
in the input signal. It is somewhat akin to a non-linear distor-
tion process, resembling overdrive and distortion effects. As
opposed 1o these rypes of effects, however, the distorted signal
is mixed with the drv signal.

The harmonics generator is fed by a high-pass-filtered version
of the inpuot signal. This means that the artificial harmonics
have frequencies at least one octave above the lowest
frequency allowed to pass by the high pass filter (ar least the
double frequency). Humans can barely distinguish the original
treble signal from artificial harmonics in very high frequency

e,
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The Cutoft Frequency parameter of the high pass fileer is
valled Frequency. The graphic displays the frequency range
thut is used as the source signal for the process. Harmonics
cantrals rhe level of the effect signal mixed with the original
signal. IF you disable Input, the original signal won't be fed
through. "T'his should be disabled when using the plug-in in a
s rerurn object, being fed by auxiliary bus sends from several
vhannel strips simultaneously, or when you wish to listen to the
ellevt signal i isolaton,

Tl loower yoni tine the filter; the more harmonics the effect
will prinluey, the lower the frequencies of the artificial
harmonies will he—uand the less natural they will sound.

Color

Yo can clioose between two sound characteristies of the distor-
tion, Color 11s less dense in spectrum than Color 2, The effect
ol Color 2 15 more intense, but it also introduces more

Can wanted intermodulation distortion,

B basic ally, migher settings for Frequency and higher Harmonies (Mix)
settings are preferable, because we can't distinguish between artifi-
cial and original treble frequencies very well, Exciters can give “life”
1o digital recordings. They are especially well-suited for audio tracks
where the treble somehow got lost, Exciters are very commonly used
an guitar tracks.,
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Tremolo

The rremolo effect is o oyelic modulation of the amplitude,
resulting in periodic changes of volume. As opposed to the
vibrato effect, the amplitude (not the frequency) is the modu-
lated parameter. You'll know this effect from vintage guitar
combo amplifiers (somertimes erroneously called “Vibrato” on
some amp combos).

tremolo

The intensity of modulation is set with the Depth paramerer.
Rate defines the speed (frequency) of the modulation, Tf
Symmetry is set to 50% and Smoothing to 0%, the modulation
has a rectangular shape. "This means thar the time of the full
volume signal is equal to thar of the low volume signal, and
switching berween both states ovccurs abruptly, Define the
loud/quiet time ratio with the Symmetry parameter, and make it
fude gently infout with the Smoothing parameter. Stereophase
defines whether the modulation takes place in phase or out of
phase, when in stereo mode. It can be set to any phase angle,
Set to “out of phase™ (—180°), the balance cvclically “wanders™
from left to right and back (Stereo Panning). When ser o 07, left
and right channels are altered in volume simultaneously (in
phase),
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I'he graphic display is self-explanatory: All parameters, except
modulation specd (Rate}, are displayed,

Clip Distortion

‘I'he Clip Distersion plug-in is a non-linear distortion process
which produces unpredictable spectra. Bevond drastic distor-
tions, it's well suited for the simulation of warm tube overdnve

!‘illll[IdS.

|

. Yommmet | Clip distortion

You'll probably check out the effect of each paramerer as a
matter of course for any given input signal. At any rate, this is
what the controls actually do in the signal How of this algorichm:

The input signal is irst amplitied by the value defined with the
Drive parameter, which is a simple Gain control. The signal is
then sent through a high pass fileer. "The filter cutoff frequency
is defincd by the Tone fader. The actual non-linear distortion
process follows this.

Ssymmetry controls the sound characreristics of the distortion
effect, from transistor (extrem left or right settings) to valve
type sounds (around the 0% mark).

|&] Imagine a systern diagram, displayed as an X-Y graph. The output
signal is shown as a function of the input signal, with the output
representing the x-axis and the input regresenting the y-aws: The non-
linear distartion circuit curve looks like an 5. (No treatment at al

Reference Addendum
Version 5 a1



! |1.l|||l'J LI

Plug-ins

wouid result in a straimght line with a 45° angle. Amplification would

raise the angle.) The Symmetry parameter allows you 1o stretch and

bend the S-curve, 50 that for any value other than 0%, it is asymmet-
rical

Once distorred in this way, the signal then passes a low-pass
filter, the curoff frequency of which is set by by the Filter fader.
The Mix parameter mixes the effect signal with the dry signal.
This signal then passes yver another low-pass filter, the cutoff
trequency of which is set by by the Sum Filter control. All filters
have a low rejection of 6dB/octave. The last stage of signal
processing 1s a tunable high shelving fleer, If vou set its
Frequency to abour 12kHz, it will behave like a normal treble
vontrol, as found in any Mixer channel strip or hi-fi amplifier, As
opposed to such treble controls, the Swm Filter allows signal
boosts and rejections of up to £30dB. This somewhat unor-
thodox combination of serially-linked filters allows many
different frequency spectra to be defined and creared. With
particular “gaps” in the signal, this sort of non-linear distortion
can sound very nice indeed. The clip circuit graphic displays
every parameter symbolically, with the exception of the
shelving filter controls,

It Check out filters and EQs, inclucing the simple parametric EQ,
inserted before the Clip Distortion. Also try combining the Clip Distor-
ticn with other drstortion plug-ins 10 create interesting results

Phase Distortion

Vhe Pheese Distortron plug-in is based on a modulated delay line,
much hike the well-known chorus or fanger effect. As opposed
to these, the delay time is not modulated by a low frequency
oscillitor (L EFOY), but rather by a low-pass-filtered version of the
anchio inpur signal iself. This 1s how the signal modulates its
own pluse position.

Emagic
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distartion IJ

[n the signal How of this effect, the parameters do the following:

T'he input signal only passes the phase delay line and is not
affected by any other process. With Mix, vou can mix the
effected signal with the original signal. The phase is modulated
by a sidechain signal—i.e. the input signal. The input signal
passes through a resonating low pass filter, the Cutoff
FFrequency and Resonance of which can be set with dedicared
vontrols. You also can listen to the filtered sidechain (instead of
the Mix signal), if vou engage Monitor, The maximum phase
shift is set with Max Modulation. The depih of the madulation
itself is controlled with che Intensity paramerter which will not
excecd the maximum phase shift, defined by the Max Modula-
tion setting.

In Conrtrols View, there is one more parameter which can't be

seen in the plug-in window. Tt is only valid for the stereophonic
version of the effect. Normally, a positive input value results in
a longer delay time. If you engage Phase Reverse (0n), positive
input values result in a reduction of the delay time on the right
channel only.

1 Youcan change the phase of the signal before and after the process
with the (Helper >} Gainer plug-in, thus reversing the stereo effect.
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6.4 Plug-in Improvements

Reverbs Optimized for Athlon AMD
I'he performance of reverb plug-ins has been improved for %

vompaiters utilizing the Athlon processor,

Fat EQ slope characteristic adjustable
T'he shelving hilier’s slope characteristics for bands 2 and 4 are
now adjustable via the Q parameter,

New Plug-in Parameters

New plug-in parameters have been added to some plug-ins,
Please note that all new paramerers are accessible when the
plug-in view is switched tw the Controls View. To see the new
paramcters in the Editor view, please activare the 001011
switch in the gray header of the plug-in window. This button is
only visible when a plug-in actually has additional parameners
available in the Controls view.

Compressor: Output Clip

Output Clip clips the ourput at 0dB. You have the choice of two
knee curves when approaching the limit. Settings are: OFF/Soft/
Hard.

Oscillator: Sine Wave

Osc Mode ~witehes the puEput of the oscillaror berween Normal
ani] Sinve, When sen v Sine, the volume sliders for all waveforms
exvept Sine are disabled, bt nng modulation still works, Selecr
S fon the smoothest and purest ring modulation effects.

Autofilter: LFO Syncable to Logic’s Tempo

Pl LY as s syneabile to bars & bears. Switch Beat S-'j'ﬂt. o
(i, e BPM Rate to adjust the ratio berween LEFO speed and
the sequenver tempo, You can shift the phase relationship
between the LFO and the sequencer with Sync Phase.

Emagic
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Tape Delay: Delay Modulation, Flutter Simulation and
Freeze

The Tipe Deday features an LEFO hidden in the Editar View,
The LEFO modulates the delay time, enabling yvou to achicve
vilwato and chorus effects with it—even when using long delay
times. The LFO (with adjustable speed and modulation inten-
sity) produces a triangular wave, which can be smoothed with
the Smooth paramerter. This also smoothes out any “Hurrer”.
Flutter simulares the irregularitics in tape speed of the original
tape transports used in analogue tape delays. I is also adjust-
able in speed and intensity. Freeze prescrves the delay feed-
back at the time of its uctivation: Freeze (ON). The delay feed-
backs are repeated with constant volume until Freeze is deacti-
vared: Freeze (OFF).

The Tape Delay plug=-in is available in mono and stereo
VErsions.

6.5 Enverb and Automation

The main parameters of the Enverb Plug-In can’t be auro-
mated. This is due to the fact thar the algorithm requires
constant recalculation of base values over the time axis,

This 1% a small price o pay for the Enverbs unprecedented
ability 1o apply a constant reflection cluster to the input signal,
continuously and in realtime. This approach is in sharp contrase
to the shaping of a reverberation signal chrough the use of a
post-signal volume envelope, as would be the case with a
conventional “gated reverb”. Realtime parameter movements
will mute the Enverbs outpur This restriction on the auroma-
tion of the Enverb plug-in is unique in Logic. All other plug-ins
can be fully automated.

In a real-world scenario, you can achieve dynamic “morphs™
berween two Enverb reflection clusters in the following way:
Insert the Enverb into two return objects and feed them with
two independent aux sends. You can easily auromare the send
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levels (even independently for each track, if you wish)and thus
create reverh cluster crossfades between two (or more) Enverb
reverberation effecrs.
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Chapter 7

Audio Instruments

7.1  Audio Instrument Objects

Lawgie supports the use of virmual instruments such as Emagic's
ES1,ES2, EUPBE, EXS 24 and the included ES M, ES E and ES
P syoihs, plos VST Z-compartible sound generators. To facilitate
e use of these software instruments, Logie features a category
ol auchio objects called Awdo fustraments, Virtual instrument
plug-ins are inserted ino che fap insert slot of these Audio
Instrument channels. The default song—the song that opens if
vou move your Autoload away from the Logic folder—features
a number of ready-ro-go Audio Instrument channels.

Audio Instruments integrate seamlessly ino Logic's internal
dhigital AMixer; all plug-in effects can be used, and all paramerters
v be aneemared, The direct connection with Logic's
sequenving engine guarantees unsurpassed precision through
simiple=accurate plavback timing, superior to that of any
eatenmld M synchesizer, This plavback precision is due o
the Facr that no conversion into MIDI data is required—despite
the Awdio Instruments being plaved by the same MIDI events
and AT sequences thar external MIDT instruments use.

An Audio Instrument is an audio object with the Cha paramerer
swirched o one of the Instrument channels, Each audio object
van behave as an Audio Instrument by changing che Cla param-
eterin its object parameter bosx, You can only insert the ES 1 {or
other instrument) plug-in into an audio object—created by
selecting New > Rudio Object—after its Cha parameter is set o
an Instrument channel,

The muaximum number of Audio Instruments is 32 with Logie
Placinum, These include: ES1, ESZ2, EDP 88, EHS 24 or VS'1'2

msirments.
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Global Instrument Tune

This new paramerer, found under Rudio > Audio Settings,
remotely controls the main tuning parameter for all Audio
Instruments (plug-in synthesizers, like the ES1 or EXS24
sampler and others) by £50 Cenrs, 'This parameter also affects
VST 2 plug-in instruments, Some instruments from other
manufacturers may not recognize this remote command.

7.2 Three Integrated
Synthesizers

Lasgie features three integrated synthesizers, which are used in
the same fashion as the optional EUPBE, EXS 24, ES 1, ES2 ar
VST2Z instrument plug-ins. In order to open and use the
included synthesizers, click-hold on the upper-most insert slot
of an Audio Instrument channel strip (in the Audio or Track
Aixer), In the ensuing fip menu, sclect Stereo > Logic » ES E or
ES P, or Mono > ES M, from the hicrarchical menu, If you
haven't already activared the Preferences > Rudio > Open Plug-
In Window automatically, double-click on the (now blue) slor,
and the plug-in window will open. Select a track which corre-
sponds to the Audio Instrument in the Arrange window, and
check that it is in record-ready mode (red R switch).

8 7S wudiolnet

10T FFE astisieat 2

The Audio instrument track must be in record-ready mode, when you
want to play the plug-in-synthesizer in realtime. Only the plug-in intng-
ment of the currently selected Irack can be played.

All three synthesizers are subtractive virtual analog synthe-
sizers with easy-to-understand user interfaces—a jov not only
for experienced synthesizer fans, but also ideally-suited for
beginners. If vou're new to synthesis, vou'll find that vour first
steps in synthesizer playing and programming are easy, The es
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svnths are modelled on the marvellous analog synthesizers of
the seventies and eighties.

The three synthesizers—ES M, ES E and ES P,

"I'he ES M, ES E and ES P synthesizer plug-ins are designed for
specific musical purposes:

® The ES M (ES Mono) is a monophonic bass synthesizer. lts
design is so simple that you'll find it hard to create a “bad™
sound, It resembles o well-known bass synthesizer which is
very popular in techno and dance music sryles.

® The ES E(ES Ensemble) is LlEhigm;(l to deliver |!|;|{|
sounds—classic string synthesizer sounds, for example,

® The ES P (ES Poly)is a sophisticated synrhesizer. Is ADSK
envelope generators are well-suited for percussive and
classic synthetic brass sounds, plus hundreds of other well-
known svnthesizer sounds.

T'he ES E and ES P feature eight-voice polyphony. 'The ES M is
monophonie, All synthesizers fearure one oscillator per voice.
T'he polyphonic synthesizers feature integrated chorus effecs.
All three synthesizers are designed to make the most efficient
use of availuble processing resources, You can open several
wlentical plug-ins with different sertings in different Audio
Instrument channels.

ik For more complex subtractive virtual analog synthesizer sounds, the
apticonal Emagic 5 1 and E5 2 synthesizers are recammended. These
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instruments also benefit from the same seamfess integration into
Logic

T'he description of paramerters is brief in this manual. We have
made the presumption that, as a Logic user, vou will have had
at least some basic expenience with the world of subtractive
swnthesis. If this 1s not the case, simply check our some of the
mcluded Sestrmgs to see how things work. As a reminder: Along-
sitle the Mvpass switch in the plug-in window, there is a flip
e aceessible via the downwards-pointing arrow. Click-hald
oy thes arrow, s select Load Setting. In the ensuing dialog
Ik, seleet the desired Seming. Feel free o edit the parameters
whinle playing andd listening. In the following pages, you’ll find a
bl descerigmion of the vanous synthesizer paramerers.

ES M

I'he £S5 M (ES Mono) is designed for use as a bass synthesizer,
That said, you may want to use it for other, higher-pitched solo

VOICES,

Fmagic ES M panel
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Octave Select

Choose the octave transposition here. You can also transpose
the Audio Instrument using the track playback paramerers in
the Arrange window, as wicle MY rracks.,

Glide

T'he ES M s permanently in a “Fingered Portamento™ Mode,
with notes plaved in a legato stvle resuloing in a glide (porta-
mento) from piteh to pitch. The speed of the glide is ser with
the Glide parameter. At a value of 0, there is no glide effect ar
all.

Mix
Mix cross-fudes berween a saweooth wave and a 30%-rectan-
guilar wave, which sounds one octave lower.

Cutoff
Curoff Frequency of the resonance-capable dynamic low pass
filter. Ius slope is 24dB per octuve.

Resonance

Resonance parameter of the dynamic low pass filter.
Surrounding the cutoff frequency is a band of resonant
frequencies, the intensity of which is ser by this parameter,
With this filer, the loss of bass caused by Resonance can be
compensated for by a bass boost.

Int

The ES M features two very simple envelope generators with a
single decay parameter. Int sets the modulaton of the cutoff
Frequency by the fileer envelope.,

Decay (Filter)

ecay Time of the filcer envelope. This paramerer is only
effective if Int is not ser to 0.

Velo (Filter)

Velocity sensitviry of the filter envelope. This paramerer is
only effective if Int is not ser ro 0.

Reference Addendum
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Decay (Volume)

Decay Time of the dynamic stage, Attack time and Release
time, as well as the Sustain level of this synthesizer always
equals zero,

Velo (Volume)

Velocity sensitivity of the dynamic stage. The parameter
ttefines how sensitive the level of an ES M voice is to harder key
strikes,

Wil

Master volume of the ES M,

Chverndnve

Overdive/distortion for the ES M ontput. Caution: The over-
drive effect significantly increases the output level.

ESE

The eight-voice polyphonic ES E (ES Ensemble) was designed
for “pad”™ and ensemble sounds, but please feel free to design
totally ditferent sounds.

Ermagic £S5 E pane/
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Octave Select

Choose rthe octave transposition here, You can alse transpose
the Audio Instrument using the track playback parameters in
the Arrange window, as with MUDT cracks.

Wave

At the lefi-most setting of the Wave paramerter, the oscillators
output sawrooch signals, which can be modulated in frequency
by the integrared LFO. Acrass the remaining range, the oscilla-
tors cntpue rectangular {or pulse waves), with the averge pulse
width heing defined by the Wave parameter. 'The pulse width
cunt be modulared—char’s whar “PWA (Pulse With Modula-
tion) stunds for.

Vib/PWM

[fWave is sct to sawrtooth, this parameter defines the amount of
frequency modulation, resulting in a vibrato or siren effect,
depending on LFO specd and intensity, [f'Wave has been set to
it pulse wave, this parameter controls the amount of pulse width
modulation (PWAL). When the pulse width becomes very
marrow, the sound sounds like i is being “interrupred™. As
such, set the PWM intensity with care, and select the Wave
priramerer’s 12-o'clock-position (30% rectangular) for the pulse
width, if you want to achieve the maximum modulation range.

Speed
Speed conrrols the frequency of the pirch (sawrooth) or pulse
width modulation.

Cutoff
Conroff frequency of the resonance-capable dynamic low pass
tiler.

Resonance

Resonunce parameter of the dynamic low pass filter
Surrounding the cucoff frequency is a band of resonant
Frequencies, the intensity of which 1s ser by this paramerer.
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AR Int

The ES M features one simple envelope generator per voice., It
features an Attack Time and a Release Time parameter. AR Int,
defines the amount of cuteff frequency modulation applied by
the envelope generator, Negative modulations are possible.

Velo (Filter)

Velociry sensitivity of the cutoff frequency modulation applied
by the envelope generator. This paramerer is only effective if
AR Int i~ 1um sl lnﬂ,

Attack
‘I'he Attack Time is the time required for each note to “fade in”,

Release
I'he Release Time is the time required for each note to fade out,
fullowing the release of the key.

Velo Volume
Velocity sensitivity of each notes level.

Volume
Master Volume of the ES E.

Chorus/Ensemble
The ES E fearures a chorusfensemble effeer, switchable in
three values (plus off),

ES P

The eight-voice polyphonic ES P (ES Poly) is quite a flexible
syothesizern Functionally, (despite its velocity sensitivity) is
somnewhat reminiscent of the affordable polyphonic synthe-
sieers of the leading Japanese manufacturers: Its design is easy
to understand, it is capable of producing lots of useful musical
soneds, and vou may be hard-pressed to make sounds with it
that ean’t be arranged in at least some musical sevle. Classic
amtlog synthesizer brass sounds are just one of its many
poailies,
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Emaqic ES P pane!

Octave Select

Chhoose the octave transposition here. You can also transpose
the Audio Instrument using the track playback parameters in
the Arrange window, as with M1 vracks.

Wave

I'he faders on the left side of the panel allow vou to mix several
waveforms, outpurt by the oscillators of the ES P, In addition
trngular, sawtooth and rectangular waves, the rectangular
waves of two sub-oscillators are also available. One of these
sonnids one octave lower than the mon oscillutors, and the
other, two octaves lower. "The pulse widch of all rectungular
waves is 50%. The right-most fader adds white noise to the mix.
“I'lns i the raw marterial for classic synthesizer sound effects,
such as “ocean waves”, "wind” and “helicoprers”.

Vib/Wah

The ES P fearures an LEFO which can either: modulate the
frequency of the oscillators, resulting in a vibrato, or the cutoff
frequency of the dynamic low pass flver, resulting in a wah wah
elteet. Turn the concrol to the left in order to set a vibraro, or to
the nght to eyclically modulate the flter
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Speed
Speed controls the rate of the oscillator frequency or cutoff
frequency modulation.

Cutoff
Curtoff frequency of the resonance-capable dynamic low pass
filrer.

Resonance

Hesonunee parmerer of the dynamice low pass filter.
Surronmling: the coroff frequency is a band of resonant
lrequenvies, the intensity of which is ser by this paramerer,

113, 2/3, 313

The cutofT frequency can be modulated by MITDI note number
theyhoard position) You may know this parameter as
“heybourd Follow™ on other synthesizers. You have the choice
of no modulation, one third, two thirds or full keyboard follow
(313, or 100% ) When set o 3/3, the relative harmonic content
of cach note is the same, independent of its pitch.

ADSR Int

The ES P fearures one ADSR envelope penerator per voice,
ADSR Int sets the amount of cutoff frequency modularion by
the ADSR envelope gencrator. The ES E allows for negative
filter modulunons as well.

Velo Filter

The cutoff frequency modulation by the AIDSKE envelope
pencnitor, controlled by ADSR Int, is velocity sensitive, The
amount of velocitly sensitivity is set by this paramener.

Volume
Mlaster volume of the ES P,

Velo Volume
YVelocity sensitivity of cach notes level,

A (Attack Time)
Artack time of the envelope generator.
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D {D&{ay Time)
The time the envelope needs to fall from maximum level to the
sustin level,

5 {Sustain Level)
Laevel that is sustained after the completion of the artuck and
release phases. Ieis only valid as long the key is sull held.

R (Release Time)
Iade out time of each note, following the release of the key, or,
to e more precise, after the Note OF Foenr.

Charus
Intensity of the integrared chorus effect,

Overdrive
Overdive/distortion for ES P outpur. Caution: The overdrive
effect significantly increases the outpur level.

7.3 ReWire

L.ogic suppores the RelWire software interface from software
manutacturer Frogelferfead, ReWire is an interface berween
sequencer and audio applications. ReWire works with
fullowing cards and drivers using Logic’s internal audio engine:

... under Mac OS; ﬂ'
Mac AV

Aundiowerk MB.E
1212 JO

Dyirect 1O {Dhigidesign cards)

ASIC)

Stud /O

. under Windows:

PC AV (MME, EASI, DirectSound, WDM) ;E
ASIO i
o Andiowerk
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® [irect /O (Dhgidesign cards),

Please start Logic first, and then start your ReWire applica-
tion(s) Propellerhead’s ReBirth, for example. Please also refer to
any notes regarding this in ReWire's “read me” files.

l.ogic will display the audio returns of ReWire-connected
applications as audio objects: You're able to insert plug-ins and
creite sends to busses on these returns, as per a normal audio
trik

v eoreder o nise the audio returns of ReWire-connected applica-
tiens, select an andio object and choose the desired ReWire
andliv=returm in the Hip menu of the Cha parameter of the audio
abjeer. In this Hip menu you will find ReWire channels listed
with their names along with the audio rracks, inpurs, busses and
autputs. ReWire or the application to which the connection
belongs generares the names for these channels. The naming of
a ReWire channel is not relevant to Logic: For example, if a
channel is called “Mix™ it has no specific function related to
thatr name as far as Logic is concerned. It is up to decide what to
do with wharever channel. If there is no audio objecr for a
ReWire return created in the Environment, no audio is trans-
ferred berween a ReWired application and Logic. How docs
this work in practice with ReBirth, for example? In this case,
vou will find two channels called “Mix L™ and “Aix R” within
Lome. The vwo hMhix channels return the summed mix of
ReBirth’s ourputs. You will also find channels for every indi-
vidual instrument. When ereating an audio object for another
channel such as the bass drum, for example, vou will only hear
the Bass droim l]lruLIp‘J'l thar 1_'|!'r.|['|1u','|1 and it is removed from the
TEN LT ES

& In comparison to VST2, ReWire has a relatively high MIDI latency due
to technical reasons, This is not an ssue when using software like
"Rebirth® with Logic, as both applications are audio sequencers that
dre sampke-accurately synced via the audio clock. Logic is always Sync
master. As Logic is also the Cycle master, *5Skip Cycle” works, too.

These functions are shared berween the applications:
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Surg/Stop,
Repositioning,
Civele Starr and End,
Tempo Change.
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Chapter 8

Mixers

8.1 Improved Design

I'he adaprive Track Mixer can be reconfigured to only show
desired rracks and objects, The design has been changed to
suve display space and o be more ergonomic. "'he Audia
Mlixer, which has, in facet, been a liver of the Environmene ever
since the first version of Logic, benefits from most of these
improvements as well, Given thar the Track Mixer is so easily
configured, and the “Track Auromation has been standardized,
you'll probably find that you prefer using the "Irack Mixer, even
.II'-":.[III ].'r]'ﬂ'l.'i{'rll'-ii'!..' used rthe Audio Mixer to pcrfunn VOUT MIXes.

8.2 Track Mixer

il Open the Track Mixer by selecting Windows > Track Mixer and e
Audio Mixer by selecting Audio * Audio Mixer. or via the appropnate
Key Commands, Both Mixers can also be launched wia default
screensets,

L-Shape: Displaying Long Instrument and Program
Names

All channels have a recrangular shape by default. Diew > L-
Shape engages an “L” shaped display of instrument and
[PROERIM Dames,

Track Filters: Selecting which Kind of Objects to
Display

Normally, the Track Mixer is “adaptive”. This means that it
only shows the channel strips which correspond to the inscru-
ments and audio objects, as they appear inin the Track List of
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the Arrange window. Under Ulew > Parameters, you can hide/
show several button which define the type of channel strips and
objects to be displaved or hidden, These are called the Fract
Fifrers. As an alternative to these Track Filters, vou can choose
the appropriate entries in the Track menu, in order to make the
desired objects visible.

Global View and Local View

Wit version 5.0, the “Trick MMixer allows a Global View, Choose
Tracks » Blobal Mew or press the Global View switch (if you've
cigiged Wi » Parameter). his ullows vou to see the entire
“Mlixing resk™, including MIID tracks, not only the audio
prsrriean, s s the cose with the Environment's Audio Mixer
he Cilobal View shosws all Instroments used in the song:

 AlLMIDI Instruments (Mult Instrument, Mapped Inseru-
ment) where the “Visible in Flipmenu™ box is checked;

& All valid Audio Channels which exist in the environment:

& All valid virtual Audio Instruments which exist in the envi-
FONIMent;

& All valid Audio Busses which exist in the environment;

& All valid Audio Ourpurs which exist in the environment;

® All valid Audio Masters which exist in the environment:

® All valid Audio Inputs which exist in the environment;

& All valid Awdio Avxiharies CUDMADY which exist in the envi-
ronment,

I st 1o Global View, the " Track Mixer allows easy access to all
wvinibalale Linesses, ofpmits, tracks ere.

HEGalodval View s s engaged (Local View), the Track Mixer
only shows channels which correspond ro those shown in the
Tk Last of the Arrnge window, or its current folder,
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I4] The Glabal View of the Track Mixer also shows all tracks which Appear
in the Autamation Folder, Logic autcmatically creates, deletes and
sorts all tracks in the Automation Folder.

Track Filter Switching Techniques

You can independently set the Track Filters for both Global
and Local View modes, Wich (88 (Mac OS) held/right mouse
buttan (PC), the Track Filter setting remains unchanged when
switching Global Mode on and off.

®* (Clicking without a modifier on a disabled type will enable
the view of this type and disable all other types.

® Clicking withour a modifier on an already enabled type will
enable all types. A further click goes back to a single enubled
type.

e [B)-Clicking allows you to individually enable and disable
rvpes, inany combination.

® Chicking with (3] (Mac OS)right mouse butcon (PC) if
Global View s disabled will activare the Global View, anil
enible the view of the current type.

o Clicking with [2] (MMac OSYright mouse button (170 i
Global View is cnubled simply disables Global View.

® (llicking with {Mac [,)ﬂ]fl’{:] locares hie window o
the first track of the current tvpe. Filter and Global view
mades remain unchanged—with one excepuon: If the
clicked tvpe is currently disabled, it will be enabled to
ensure that the command was successful,

1| The Glabal View can dizplay channels which do not exist in the
current arrangement as tracks. If in Global View such a track has it's
automation armed (Write, Touch, Latch mode), and data is recorded
1o, a correspanding track wall automatically be created, and selected
in the Arrange window,
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Mavigating Specific Channel Strips

The Track menu offers the following entries:

Goro MID] Instruments
& Goro Audio Instroments
® Cioro Audio Tracks

® Cioto Andio Busses

& Linto Apdio Ot paaes

& Cioto Addioe Ay

& Cioto Andas Tnpn

The window will seroll tothe position of the desired track type.
I cases whene o selecred rrack tvpe doesn’t exist in the current
foleler, Cilabal View wall antomancally be enabled and the track
type will be searched for,

The Track Mixer's MIDI Tracks

The rotary controls of the MIDI Instrument Tracks feature
name ficlds for their parameter names, eliminating the need for
legends. These knobs usually defaulr to control over parame-
ters like the Chorus and Reverb levels, or the Freq (Cutoff
Frequency deviation) of the MI1DI expander’s low pass filrers,
Click-holding on these names will open a flip menu which
allows vou to assign any MIDI controller 1o the corresponding
knob. This method of paramerer definition 15 the same for all
MIDI instruments. Under the liew menu, you can add more
controls, allowing the display of further parameters,

The program name fields of the MIDI tracks are blue, as with
effect or Audio Instrument plug-ins. Clicking on them, with [58)
(Mae OS)er) (PC) held, allows the enabling/disabling of
program change rransmission. his parameter is also displaved
as a checkbox in the PRG parameter field of the object param-
eter box (in the Armange and Environment windows, along with
the MHDI Port and Cha sertings).
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Removed Parameters

As Logic 5.0 fearures the new Track Automarion svstem,
certain automation parameters for the Track Mixer have been
removed from the record button menu, and the Track Mixer
and Environment Options menuis). In addicion, the legend
previously found to the left has been removed, as these param-
eters have moved w dedicated knobs on the MIDI channels
themselves.

Improved Navigation in the Mixer

[Jouble clicking on a send or out assignment panel on any audio
channel will “jump™ to the allocated Bus/Outpur channel fader,
muking navigation in the Environment's audio laver faster,
This funcoionality also works in the Track Mixer [Here, a new
Environment window will launch and the destination objece
will be selected in the Environment's audio laver, Should an
Environment window already be open, (with link mode active)
this will be used and will update us deseribed.

Peak/Clip Detector Display

Above the level meter each audio channel features o new peak/
clip detector display. It shows signal peaks in dB—up tooa
maximum of +6dB. Above 0dB the highest peaks are hold vl
reset by a mouse click on the dB value, To achieve an optinal
signal level lower the volume fader by exacely the displayed
clip amount.

8.3 Audio Input Objects

Audio inpur objects are available for these audio hardware
Iy pes:

Mac AV (Mlac O8S)

PO AVIEAST (Windows)
Audiowerk

Direct [}

Stud /O (AMac O8)

L]
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e Korg 1212 (Mac OS)
& EASI (Mac OS)
e ASID

T'his new class of audio object represents the audio inputs of
vour andio hardware. You can open an audio input object this
wary:

1. Choose the Audio Liver in the Environment, or alternately

select Rudio » Rudio Miker,
2o Seleer New » Audio Ob ject,
L Donble-chick on the newly-created audio object.

A Do e paramieter box of tas new audio object set the Cha
parameter to Input 1,

T'he design of the andio input object is vircually identical wo the
ather audio objects vou are already familiar with, This makes
the functionality of the audio input object self~explanatory,
Effect plug-ins, such as Logic's reverbs and delays, also work
while Logic is stopped. This allows the appealing prospect of
insering compressors into Logic's inputs, withour the need for
external compressors, Tt becomes even more enticing when
using 24 Bit hardware. The plug-ins behave just like external
hardware processors. Bus sends can be configured as either pre
or post-fuder.

The audic 'mpu[ ::11ju4;'|' f‘lllll,'l:'i.l:lﬂ'.lliﬁ_.' coitld be used in pl-_“:e of
vour old mixing desk, or can save time while bouncing,

1| Please note that at the moment while recording (not while bouncing),
thue ol fee 15 ol aclion inpun objects are not active and are thus not
tecnitehiad Thes will e changed in upcoming versions

Audio input objects simplify bouncing

The andie inpor objects make the bouncing pru:_'a:du[r: much
wisier, as there is no longer any need to record the audio signals
of your MIDI devices before their output can be bounced
tmixed downd with other audio recordings. Thanks to the live
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anglios input objecrs, vou can mix down the audio signal from
your external hardware MDD synthesizers and sound modules
inra a stereo mix (by bouncing an outpur object).

8.4 Surround

Eight Channel Surround

Surround is available for these audio hardware types:

TDM (Mac O8)

PC AV Gincluding EAST and EAST MMIE)
Audiowerk

irect 1/O

Stud Oy (Mac OS)

Korg 1212 (Mac O8)

EASI (Mac OS)

e ASIO,

L.ogic Platinum allows for mixdowns in surround format, with
up to eight loudspeaker outpur channels. Surround formuars
supported include all common formats, including the mast
demanding, like the 7.1 format. To effectively use surround,
the audio hardware and driver must support (and be equipped
with} more than two outpurs,

lincoding or decoding does not take place. The use of surround
does not imply any manipulation of frequency response charac-
teristics or delay trearment. The processing only affects the
relative volume settings for the outpur pattern selected for thart
channel. It's up to vou to insert plug-ins, such as delays or EQs,
high or low pass filters etc., into the output objects serving as

the surround channels.

All chunnels and busses can be set to different surround formats
independently. Click-hold on the outpur paramerer field of the
bus objects (above the panorama control), and set the ourput to
Surround in the Hip menu. The pan control is replaced by o twao-
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dimensional surround control. The loudspeakers are repre-
sented by colored dots, and the pan position is indicated by u
white dot thar can be grabbed and moved.

Changing the surround settings of multiple channels
simultaneously

You cin change the surround serings of all selected channels
summlncously, Select all the objects you want to set to the
same assignment, and hold (Mac O8) or (Windows). If
v do not hold the modiier key, Logic will ask vou if this is
SOHET TIECTIL RO,

The Pan Window

Double-click the surround control which has replaced the pan
control. ' T'he pan window will launch, giving vou a closer look at
the surround control. Grab the parameter field ar the rop of the
window, and select the desired surround format—formar 7.1,
for example, which is designed for big cinema thearers, ‘The
seven loudspeaker symbols appear around the surround
control, ‘The routing of the signal to the speaker outputs is intu-
itively controlled by the position of the blue dot in the surround
field, which can be dragged and dropped.

The Aip menu above the surround panner allows the selection
of the following surround types:

Stereo, LCR, Center only, Quadro, Pro Logic, Pro Logic wio C.,
5.1, 5.1 w/o Center, 7.1, 7.1 wio Center, EX, EX w/o Center.

[0 Hemembser that this mode can be set independently for each audio
i bl

P loer resunnenge aof the signal o the Imul_t.p{:,lkur channcls takes
place most intwinvely by dragging the light blue dot in the
dueciion of the dedicated speaker symbaols. The movement of
the surronnd position on a given axis and diversity is supported
Ly these funcrions:
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® llold [88) (Mac OS)/Right Mouse Button (PC) to lock the
angle,

* Hold (Mac OSHak] (PC) to lock the diversicy.

& [lold {Mac OS)/eta] (PC) to reset angle and diversity 1o
the middle,

[&] Move the light blue pancrarma dot and check out the modifier keys,

LFE: Subwoofer Effect Channel

‘T'he abbreviation stands for “Low Frequency Enhancement™
or “Low Frequency Effects”, as the LFE outpur most
commonly leads to a subwoofer amp. "The use of a subwoofer
type speaker is not a must, ‘Technically speaking, the LLFIL
output is nothing more than an additional post fader auxiliary
send, with the LFFE control as its volume fader. If you only want
low frequency signals to reach the output, inserra low pass filrer
plug-in into the output object defined as the LI'E “subwoofer™
ourput. A cutoff frequency of 120Hz 15 standard for surmouod
applications, The LFE fader determines the amount of signal
from the source audio to be routed to the LFE outpur. In the
surround settings of the Asdfe Hardfoare & Drrvers menn, youn
cun define which output of your audio hardware will serve as
the LFE ourput (see below: Assigning surround channels 1o
adio outpursh.

[£i The LFE channel isn't meant to play back all low bass portions of a
cinema soundtrack. It's not appropriate to route the kick drum from a
film score to the LFE channel, These bass portions are played back by
the front speakers: The PA system might utilize active crossovers and
subwooters 10 play back the bass, but it won't be adressed by a sepa-
rate channel of the audio you produce with Logic. The LFE channel
serves as an effect channel for particular low frequency (bass) events
which accur in a handful of (action-) scenes in a movie, e.q. when the
alien spaceship 15 landing.
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Surround Automation

As with all of Logic’s mixing functions, you can record, editand
E play back every surround movement as per pan or volume, The
Track Automation, described in thedwfomation section, on page
17, is recommended for the automation of surround move-
ments, he following controller numbers are assigned to the
surrestindd paramerers:

25 = Surr. Angle
St S iversiny

R TT I L

IR Lming the Track Automation system, you won't ever have to deal with
thewe Controller numibers,

Assigning Surround Channels to Audio Outputs
The assignment of surround channels to the outpurts of your
audio hardware is accomplished via Audio > Rudio Preferences
» Audio > Surround. The standard sewtings for the Pro Logic, 5.1,
7.1, and EX formats (each of which is available with or without
center speaker), as well as Quadro, Center Only and LCR (Left-
Cenrral-Right) are pre-set, but can be edired.

Bouncing Surround Audio Files

In the Audio » Audio Preferences > Audio > Surround sctings,
vou can see which file name extensions will be applied to the
file mamies resulting from the Soeeee procedure, Bouncing a
surronnd mix will ereare more audio files than your usual
stercophonie bounee/mixdown. These extensions are used o
ilentty the files, By clicking on them, you can edit the exten-

wlis,

Seleot Surround Bounce in the normal bounce dialog window,
which is Linnehed when the bounce button at the bottom night
of s ontpae aelio object is clicked. No matter which Buee
button vou may have pressed, all outputs selected in the
surround serrings will be bounced simultaneously.
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|k TDM users please note that a Surround Bounce requires a number of
unused audio tracks equivalent to the number of channels of the
Surround format (e.qg. eight tracks for a 7.1 Surround Bounce)

Master Volume Fader

The master fader changes all ourpur gains, Lo acts as a separate
artenuator stage; The level relationships between output
objects are nor affected. "This is very helpful as a proportional
output volume control and is particularly useful for surround
mode in Logic Platinum (fades of the complere surround mix).

The master fader is an audio object with the Cha paramerer set
to Master. Moving the master fader does not affect the posi-
tion(s) of the output object sliders, but dircctly affects the
signal levels. These level changes are reHected in each ourput
channel’s level merer.

8.5 TDM Systems K
Mac

[&! TOM systems are only supported by Logic Platinum for Mae 0%

More TDM Aux Objects

The maximum number of Aux objects hus been increased fruom
32 to 64 (16 to 32 stereo) in "T'DM systems.

64 Buses
The maximum number of Buses has been increased o 64,
which can be adressed by a maximum of 8 send slots per

channel.

IO Inserts in TDM systems

In Logic Platinum, "TDMA hardware users can insert exrernal
effect processors on audio tracks, inputs, auxiliary tracks,
busses and outputs via Logic Platinum’s 170 rrack insert
olajects,
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Moo or stereo 1/O inserts can be used on both mono and stereo
track objects, 1o insert a stereo plug-in on a mono track hold

&

The send level of an /O insernt can be adjusted on the main
outpur nhjects in Logic, while the return input level has to be
set on the external sipnal processing device.

As perinternal (Moarive™) plug-ins, TDM /O inserts can now
he bypassed by [€)-clicking the TN insert point on a
chonnel, To avaid intermal feedback loops: 1O inserts can not
B prlanesesed onnn the same “Olurpae™ o “Input™ object.

Send Levels in TDM Mixer raised
The send levels on track, input and aux channels are raised by
fulld,

k| This might change the mix levels of older songs recorded with Logic
Platinum versions prior o 4,7,

AudioSuite-Plug-Ins

AudioSuite plug-ins can be used with DAE 5.0,

WAV Files under TDM/DAE

TDNM/DAE is able to play back WAV formar files. Please note
that IDAE 5.1 or higher is required. Also note thar the following
DAE limirations still apply: You can use either 24 or 16 bit files,
and no sterco interleaved hles.

Parallel Use of OMS and Logic's Proprietary MIDI
Drivers

U plugg-anes Gl U hardware by Digidesign) and several
wirteal saomplers and svoarhesieers (but nor the EXS 24 or the
1S 1 must be controlled via OMS (Open Music Svstem). OMS
amdd Logic’s proprietary M1DI driver can be used in parallel.
This provides the advantage of being able to control external
MY Toseruments with the uming precision of AMT (Active
MM Transmission, only available with Emagic’s AMTS and
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Uinitor® MEITD AMIDT Interfaces), which would not be possible
in pure OMS mode,

Select Options » Setlings > MIDI Interface Communication »
Use OMS in addition to the built-in MIDI driver. If enabled,
Logic will use the built-in MITH diver and OMS simula-
neously. Everything works very much like using just the built-
in MIDI driver. However, the difference is thar vou have a
choice for each Environment instrument:

1. Ifan OMS instrument is #of set (“OMS unassigned™), the
object sends MIDI information “normally” to the outpur
PO,

2. If an OMS instrument /s set, the object sends the MIDI
informartion o the OMS instrument.

Please note;

® The OMS output mapping is obviously not acrive bevause it
is not neccessary: the objecr port serting warks normally.

® “The OMS inpurs work in addivion ro the Laggie N i,

* [ogic iminabizes the buile-in MTDT driver fiest, anl then
CIMS. This may be significant in cases where both drivers
want to make use of the same resources—Nlike a LINTUOR
LU'SB driver. Whichever is first will win, so in this vase the
built=in MU driver will ger access 1o the Ulnitor, Please
remove the OMS Unitor driver from the QNS driver Folder
should YOLI $CC 1 *Clould not use the Unitor driver™ s s

from CMA.

Re: Emagic TDM Plug-ins

Due to technical reasons, the Auto Filter and Tape Delay
plug=ins, available ro users of TN hardware in Logic Audio
Platinum 4.x versions, can #of be used with Logic Platinum 5.
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Chapter 9
Audio in General

9.1 New Audio File Selector
Window

In the Windows version, the file selector which is opened via
Audio Window > Audio File > Add Audio File now features a Play
button which plays back the selected audio file. 'T'he Auto Play
function automatically plays back every audio file as it is
clicked. A Recent Directories flip menu allows for accelernared
access to your audio files. There are ewo different versions of
the File Selector. One is launched when [@)-right-clicking with
the pencil tool alongside an audio track in the Arrange Window
(or with the menu command: Rudio » Import Audlo Flle), nil
the other when rhe Add File menu is acvessed while in the
Avdio window. The version opencd while in the Aundio winidow
is more advanced and allows mulrple files to be impuorted or
removed. The Show/Hide Path switch allows the drive aml
folder that contains the audio Ales o be visiblefinvisible,

9.2 Audio File Format Selectable ‘_

Under Audio > Audio Preferences, the Recording File Type can Mac
be defined. SO s the defaule; Odcher choices are &1FF and WAW

9.3 Update Arrange Position

When Edit » Update Arrange Postion is engaged, a drag of the

region start in the Sample Editor also affects the position(s) of
the region in the Arrange window, provided that the anchor is

dragged as well. This ensures that the position of a given audio
region stavs at the same place in the arrangement. When
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moving the region startpoint back, the remaining portion of the
region will starr plavback at a later position.

Such edits have always been possible with Logic—but you
necded to grab the start of the region in the Arrange window,
With Update Arrange Postion switched on, vou can make these
cdits more precisely in the Sample Editor, without changing
the position of audio in the Arrange window. This is provided
that the region start and anchor are sct to the beginning of the
andio file (so that a dragging of the region startpoint also drags
the anchor),

This s the mveste comman scenaricd Anchor and regilon start are
always at the beginning of the audio file, whenever vou record
aiidio or add any audio file. Moving the repion staripoint also
moves the anchor, as the anchor can't be placed before the
reEion strtpoine.,

e [f Update Arrange Postion is engaged, moving the anchor
won't change the audible result. The movement of the
anchor in the Sample Editor and the new position in the
Arrange auto-compensate. Moving the region start in the
Sample Editor will lead to the same resulr as dragging the
region startpoint in the Arrange window. This is the default
serring.

* |fUpdate Arrange Postion is disabled, a movement of the
anchor changes the position of audio regions in the Arrange
window. "T'his is how Logic always behaved prior to version
A

9.4 ReCycle Import

et iyele as the mame of a software application from Propeller-
L] Software. T neinly serves as an editing and production
tool T loups (repearedly looped audio samples). ReCycle uses
spevilic file Tormars which can be imported by Logic. ReCyele/
RILN files also can be converted into EXS sampler instruments!
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This is described under Converting ReCyele/REX Files inro
EXS 24 Instraments section, on page 145,

¥ 1 ReCycle/REX file import requires an installed REX Shared Library
system extension—version 1.2.1 (build 45) or higher (Mac) or REX
Shared Library DLL version 1.2.1.43 or higher (PC). This systermn exten
sion is installed by the Logic 5 installer. To download the latest version
of the Iibrary wisit the support section of www.propellerheads.se

Recognised ReCycle file formats

Logic can import the following file types:

e Old ReCyele File
+ File Suffix: .y
#+ Abbreviation: RCS0

o Old ReCycle expore file
+ File Suffix: .rex
# Abbreviartion: REX

® New (2.0) ReCycle file
+ File Suffix: .2
¢ Abbreviation: REX2

Importing ReCycle/REX files into the Arrange Window
To import a ReCyele/REX file to an audio rrack select Rudlo *
Import Audio File and choose a ReCyele/REX file instead of o
regular audio fle,

With the Pencil Toaol @-righ[-r“wh {(Windows) or MMac @
click (Mac OS5, respectively) on an audio track and select a
ReCycle/REX file.

1l in the info line of the apen dialog window the properties of the
selected file are displayed. You will get information about: file type,
mongfstereo, sample rate, number of slices, beat/bar divisions,
preview tempo in ReCycle, original termpo of the ReCycle/BEX file.

Alrernatively yvou can drag a ReCyele/REX file from the
Windows Explorer/Macintosh Finder onto an audio track.
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Import Overlap Function

On occasion, vou may encounter the following dialog, when
impaorting ReCvele/REX files.

U'he Bmclong of this window results from:

® 'l song tempo used in Logic being higher than char of the
umpuornted ReCyele/REX file, The audio regions generared
during import overlup once aligned in the bar/bear grid of
apmie,

® Lisc of the Stretch funcrion on audio shices in ReCyele
without adjusting the corresponding song tempo in Logic,

You may handle the imported file in the following ways:

Don't fix: Imports the ReCycle/Rex file as is. All audio slices are
placed as individual audio regions on one audio track. “Slices”™
af the file may overlap, to match Logics tempo. In this case
playback of an audio region is interrupred in favor of the
following overlapping region.

Crossfade: All audio slices are placed as individual audio
regions on one audio track, Inoareas where the regions overlap
Logeie 5 pertorms o non-destructive audio crossfade. The cross-
Gide as eequal paswered. " The lengeh of the erossfade is deter-
maned by the value shown in milliseconds) displayed in the
Crossfade length panel.

Add tracks: will distrilate the “shices™ as andio regions across

mnltiple andio reacks, Each overlapping audio region is placed
o an sdditional audio track in Logic 5. This ensures playback
ol b i regions in the overlapping area withour interruprion
as it woere the case using a single track (see above ). Logic 5 auro-
nuatically caleulates the necessary additional track and displays
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them in the ficld: Number of additional audio tracks. You can
also enter a value manually. For minor tempo deviations one
additional audio track is usually enough. For major deviations
up w 16 audio tracks can be added.

The adjustment of the numerical values is via use of the mouse
as a shider, or double-clicking on the panel(s), and direct numer-
ical entry.

COnce all sertings are made, Logie will ereate a folder containing
one audio track (using the same Audio Mixer abject as the track
it 1s created on), which in turn contuins the slices of the
ReCyele/REX file at the appropriate positions. Each of these
“slices” will reference the same audio file, which can be found
in the Audio window, as usual.

Copying Audio Data Into the Clipboard

You can copy audio data into the clipboard for further use in
ReCycle by selecting Audio > Copy ReCycle Laop (on the
Macinrosh: in the Arrange window's Lecal Awafie menu) Tlis
option will only be active if you have selected sae audio part in
the Arrange window, and will copy the selected region of the
referenced audio file into the clipbourd. You can then use the
" Paste ay wew docament” funcrion in RHeClvele to ereane o new
ReCycle document using this audio data. In conjunction with
the " Paste ReCyele Loop™ function (see below), you can perform
a complete data transter from Logie to ReCyele, and back,
withourt using anv file selection dialogs!

(] The size of the transferred audio region is limited to 10 MB, due to
the fact that the clipboard resides in the computers RAM. 10 MB,
howvever, should be sufficient for maost ReCycle loops (e.9., an 8 bar
stereo loop in 4/4 at 70 bpm uses approximately 5 ME)

Pasting ReCycle loops into the Arrange Window

[f you use the “Copy Loop™ option in ReCycle to copy the loop
currently being edired into vour compurters clipboard, you can
puste this loop into the Arrange window by selecring Audio >
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Paste ReCycle Loop. T'he result will be the same as if a
Rt:'f.'}'{,‘h:,n"ﬂ[’lk file had been iu]purtr;:l,

(R Make sure 1o deactivate the ReCyle opticon: Transmit as one
sample. Note: Should after importing a ReCycle loop show up as one
single audio region in Logic is this an indication that the ReCyle
cption: Transmil as one sample is still active.

9.5 OMFand Open TL Import and
Export

Loogie Phitinum has the ability to export and import song
cantents using the O (Open Media Framework, also known
as OM P 1—0Open Media Framework Interchange) and
Cipen’ UL (Open “Track List) file formarts, Tyvpically, the OME
formart is used for dara exchange with Digidesign ProTools soft-
ware, and the OpenTL format for data exchange wich Tascam
hard disk recorders, such as che MX2424,

Both of these file formuts only support the exchange of andio
dara (audio media and the vsage of this audio media in a
song)—MATDT and automarion data will simply be ignored
when using the export functions,

OMF Export

T export the current song as an ONIF file, select Flle » Export
* Evport Song as OMF THe, T'his will launch a dialog with the
following oprions:

OMF File Version

s allesws vou o exporr the file in OMF Version 1 orVersion
2 tonmat. You will vsually choose Version 2 here. Version 1 is
only uselul for backwards compatibility with older OMF
capalle software,
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Include Audio

If chis box is checked, all exported audio files will be integrared
into the OMF file itself (Note: This can result in a very large
hile, and can make file export times very long), IF unchecked,
only file references are written to the OMF file, If this merthaod
is used and vou wish to copy the OMF file to another hard disk,
vou need o ensure that all referenced audio files are also
capied,

Convert interleaved to split stereo

As some applications don't suppore interleaved stereo hles,
Logic can convert interleaved stereo files to split stereo. (e.g.
when exporting an OMF file for a ProTools session) Check this
box if this is the desired behavior. More thar this only works if
the Include Audio aption is checked.

Pan tracks

If this box 15 checked, Logic adds informarion oo che OMEF file
which sets the panning of the exported tracks as they appear in
Laogic itself. {i.e., Stereo tracks in Universal Track Mode une
exported as two mono tracks. Assuming this oprion is chieched,
the left mono track is panned ro the left and the right one, 0
the right). Caution: ‘This does not work with the conversion
Software OME "Tool by Digidesign. Don'tcheck this box if you
are using OMFEF Tool to convert the OMFE file into o Pro’lTools
session a5 it is not supported by OMEF Toal,

Executing Export...

After pressing the OK button, a file dialog allows you to specify
the destinarion folder of the OMF file to be generated. Choose
a location and you're done. If you have checked the Include
Audio oprtion, Logic will display a progress bar for each
exported audio file.
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OMF Import

The Import OMF/DpenTL file to song... menu option will open
a file selector, which allows you to choose OMF files (on the
P, tiles with the “J.OMF” extension, on the Mac, *OMFT™
file tvpes are also supported). After file selection, a further
dhizlog allows you to choose the location for audio data extracred
Frommn thic OAME file. Afrer confirming this dialog, the OMFE file s
inperted into the currently open song (i.e. new andio rracks are
generated for every track contained in the OMF file and the
i parts are placed approprately on these tracks),

OpenTL Export

To export the corrent song's audio in the Open'T'l. formart,
selecr File » Export > Export Song as OpenTL File. This will
launch a file selection dialog which allows vou o specify the
destination folder, and file name, of the resulting Open'I'L file,
After conhirming this dialog, Logic will ask vou if the song’s
SMPTE start time should be added to event start positions. In
this scenario, audio parts in the resulting OpenTL file will have
the same SMPTE start time as in the Logic Song. IT you choose
Don't add, the part positions are caleulated relatively to the
song start (e, an audio parg which stares at Bar 1 will have a start

time of 00:00:00:00:00),

At the next step, Logic will ask if a copy of all audio files should
be mude. You should use this aprion if yvou want o copy the
resulting Open’ UL file, including all audio dara, to another hard
dhisk, Pasgic wall then ereate two sub=-Tfolders in the folder which
combains the Open UL file: namely “Audio Files™ and “Track
Files™ fwliieh is ihe suppested structure for (".l|1::|1'l"l. exports),
I yovin chissose that no COry is o e made, the file references in
the Orpen’ UL tile will point 1o the original audio files.

Alrenanvely, vou can have all exported files placed in one
folder, which is named after the exported file, This is the
conventin used by the Tascam MX recorders, so it is recome
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mended that Create be selecred in response to the “Create a
dedicated folder for OpenTL. export files?™ guestion.

OpenTL Import

To import an Open’T'L file, the Import OMF/0penTL file to
song... menu option is used. Files with the exvension *TL"
will be shown in the file selector. Following file selection, Logic
mav launch the following dialog (only if the first event in the
imported song starts at a nme greater than 1 hour):

[LOGIC Audio | S
";_3) et SMFTE irart beve of 2 et

avenl shail o e cava TE tess
a2 Moty o i st e pucgted 7

gt |

Confirm by pressing Set if you want the SMPTE starr time of
the song to be changed accordingly, or Don’t set if the song's
SMPTE starr rime should not be chanpged,

Should the first audio part found by the Open’ UL impert have
a start time greater than zero (less than zero s impossilile y,
Loogic will ask if you wish to: "5Set the start timve of Best impared
event to start of song?” If vou answer with Set, the first
impored audio part will be placed precisely ar the song soan
poInt,

L/ This solves the problem that may occur if the song on the Tascam
machine starts at a large time value, but less than 1 hour (such as 59
minutes), In this situation, the user can’t immecdiately see the
imported audio parts because they have been imported bevond the
song's end point {possibly even beyond the largest possible song end
point, depending on the song tTempo)

Reference Addendum
Version 5 1.8

Team TND



Chapter 9
Auvudio in General

9.6 POW-r Dithering

Logic 5.0 operates internally at 32-bit Hoating point resolution,
However, in the Bounce window the Resolution of files gener-
ated by the bounce process can be ser to 16 Bit, In this case
Laosrie 5 needs wo recaleulare its high internal resolution to
credre bt bounce Ales, This reduction in bt resolution can
procluce nnwanred digital artefacts such as quantization noise,
which is perceived as a “graininess” in the signal. This type of
artefuet s often seen in conjunction with avdio marerial
featring @ wide dvnamic range.

s counteract these rvpes of side effects, Logic 5 features
POW-r (Psyehoaconstically Optimized Wordlength Reduction)
dithering duning the Bounce process. POW-r is licensed from
the development team of the "POW-R Consortium 11O,
{www. mil-media.comfpow-rhtml). POW-r offers three distinet
dithering modes which can be accessed via the Bounce window,
The selected POW-r mode is written into the audio files,

i) Genera ly speaking, dithering the same audio file multiple times
shou'd be avoided. Dithering should only be applied once—as the last
step in the final mix. Therefor it should be turned off—Dithering:
None—if you plan to use bounced files in Logic as it would be the case
with the function Bounce&Rdd for exampla,

Anin-depth describtion of the Bounce function can be found in
the Logic Reference hManual,

I.FIIL' I’"]“'l'li.": f"“kTill‘" i!’\ .;I['I'L'."i?ﬂ.'d "i!li.l. rI:IL' F:I-I\'II'{'I['IH'IL'.HI .'J.\."I;_Iiﬂ
Adixer or via the "Track Mixer (in Global view) by pressing the
Hennee (Bnce) button of an Ourpur Object,
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There are four menu options:
® Mone: No dithering is applicd.

® POW-r #1: uses a special dithering curve to minimize quanti-
zation noise.

& POW-r #2 (Noise Shaping): uses additional noise shaping over
a wide frequency range which can extend the dynaumie range
by 5 1o 10dRB,

s POW-r #3 (Noise Shaping): uses additional, optimized noise
shaping which can extend the dynamic range by 200 B within
the 2 to 4k He range—the range the human ¢ar is most sensi-
tive oo,

! Note: Noise Shaping mirmimizes side effects caused by bit reduction by
spectrally displacing the guantization noise above 10kHz—the range
the human ear is least sensitive to.

The mode which will sound the best to you is primarily depen-
dent on the program material and on vour personal taste. The
“right” secting is best determined by auditioning the audio
muiterial with each of the dithering modes,
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9.7 Audio Drivers

The Audio Driver is the software which facilitates communica-
tion between Logic and the audio hardware.

New Audio Engine (Windows) m
All Windows versions of Logic (starting with version 4.5) now '
feature o new, significantly improved audio engine that has

much more in common with the Macintosh version, It offers

shorter lateney times, faster fader response, improved VST

support and betrer overall performance. Monitoring, that is,

histening to the inpue signal at the audio output, is now avail-

able for all driver types in Logic for Windows. There are six

driver types, in total, available for use; you will find these on the

Audio Driver and Audio Driver 2 panels, found via the Audio >

Audio Hardware & Orivers menu,

Changes from Former Logic Windows Versions

In former versions, there were four categones of hardware
types: PC AV, Reland VS, DS 2416 and Audiowerd. PC AV was
used to support KASI, ASIO, MME and Direet Sound. The inte-
gration of the D82476 wok place via an MK driver in PC AV

Now we have PO AL Rolond VS, Audfowerd, Direcr 10, DS 24716
and ASIO. PC AV now uses EAST {(Emagic Audio Streaming
Interface), with suppaort for MME (WDAD and Direct Sound
devices via FASTLUE and FEAST D8, which replace the former
ML andd DyiveetSamned support, These are accessible in the
Driver parameter ficld in the 0 AV area of the Audio > Audio
Harthiare and Urlvers meno page,

There wre sepanne drivers for Audiowerk, Direcr 1/O and
ASHOY, aned also s dedicated driver for the integration and
temee control of Roland VS-machines (VS-880, VS-R80 Y
aned VE-16H0) The direct connection to Digidesign’s /O inter-
Lace is new, This affects the Audiomedia 1T and Digi 001 hard-

W,
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ASIO drivers are now a separate category. The Yamaha DSP
factory is now supported via the ASIO driver, Assign it in the
ASIO driver ficld, bur do nor activate the ASIO selection box.
You should only activare the DS 2416 checkbox, if using this
curd. Adjustment to its parameters are made in the ASIO fields.
FFormer versions used the PC AV drver for the DSP facrory,
which 1s no longer possible. With the AS1O driver, you can use
plug-in synthesizers and other virtual instruments with the
ISP Facrory (1D52416).

New Audio Engine Parameters for Windows
Versions

[ These parameters appear in the Mac O3 versions 100, but are already
well-known there.

Volume Smoothing [ms]

This paramerter defines the length of the fade between two
consecutive volume values for an audio track. When seotng this
value to 0 vou might hear sipper noise when moving a valume
fader during playback. Higher values soften the voluime
changes and eliminate this zipper noise.

Max. Number of Audiotracks

The Audio Engine requires free svstem memaory. T he amount
of memory needed depends on the maximum number of tracks
to be played, and on the number of /O channels supplied by
the driver. This setting allows vou to reduce the amount of
memory used by the driver, by reducing the number of rracks.
This may be sensible when you wane to run other applications
ar audio hardware types simultaneously,

Larger Disk Buffer

This oprion inHuences the amount of audio daca that is read
from the disk in advance. This option is switched off by default,
matching the demands of fast hard drives and powerful
computers, [f vou receive frequent error messages while
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running Logic in this mode, vou should switch this setting on,
allowing the plavback of more tracks and achieving higher reli-
ability. More RAM is needed in this case, however.

Larger Process Buffer

This parameter determines the size of the native buffer used 1o
comnpte mixes and effects. Do nor actoivate this oprion if vou
owna fust compurer, 'This reduces response times to operations
stich as volinme chinges or solong, Experiment o find the
setting that coaxes the best performance from your svstem.

Hints Concerning Using Various Hardware Types
with the New Windows Audio Engine

DirectShow Plug-in Integration

Due to several technical changes, some Direct Show plug-ins
may not appear, I so, exit Logie, and stare the latest version of
the Plug-In Enabler (PIE} appplet in order to re-activate the
deactivared plug-ins—assuming that these worked correctly in
earlier versions,

VST Plug-in Integration

VST plug-ins are not handled by the PIE in the current version
of Logic. The PIE is only responsible for Dircer Show plug-ins,
In order to use VST plug-ins in Logic, these plug-ins must be
placed in the "Vseplugins®” folder, which must be located in the
Loge folder. In order to prevent particular VST plug-ins from
appearing in Laogic’s plug-in list, move the plug-in fle wo
another folder, which could be named “Vst unused”, for
:‘h;:unplt.',

EASI MME

Sonnud cards thar only have an MAME dnover, can be used
through urilization of the EASIMAME drver supplied by Logic.
In order to conhpure it, please start the “EASIMME. exe”
appler, found in the Logic folder. More informartion about its
use 15 supplied by the EASI MME HELP file. In order to use
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the desired configuration with Logic, select the EASI MME
driver in the Aip menu of the PC AV scction in the Audio >
Audio Hardware & Drivers page.

EAS| DirectSound

If you want to use a DirectSound (stereo) driver for vour sound
card in Logic, please select the "EAST DirectSound™ driver in
Logic’s Audio > Audio Hardware & Drivers page. In order to
configure it, please start the "EASIMME.exe™ applet and
create a virtual device containing the appropriate DirectSound
driver. More informartion about this is supplied by the EASI
MME HELP file.

Yamaha DSP Factory i

In order to directly access Yamaha's DS2416, activare the : ﬁ
1352416 option on Logic's sccond audio hardwire configuration

page. The VO handling is no longer controlled by MM, but by

ASIO. Setnings like the clock source need to be serin the ASIO)

section, directly under the 125 2416 oprion,

Yamaha ASIO) drivers (version 2.4 or higher) are availalle in 16
Bit and 32 Bit versions. The 32 Bit driver allows for the contip-
uration of lutency values between 500 and 3072 samples, In
order to use the DS2416 in combination with an SW 1000 soumml
curd, the support of the SW 1000 in the ASIO driver of the 1S
Facrory must be switched OFF! In addition, the clock source
parameter in the ASIO secrion must be set to “SI1™ (serial in).

Direct VO

I order to directly access Digidesign hardware via the Direce ff
f2 driver interface, select the Direcr 1/O checkbox in the second

audio hardware configuration page (Audio > Rudio Hardware &

Orivers). A Dircce /O driver must be installed on the system in
order to do so (Wave Driver version 1.6 or higher), For further

informarion, please contact Digidesign.
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Automatic Conversion of Compatible Song
Audio Configurations

If you load a song that was created with, say, PC AV or Mac AV,
runmng on a machine currently using an ASIO device (for
imstance), Logic will ask if yvou wish to switch from PC AV or

M AV 1o ASTO. "This allows the song to be plaved back imme-
diately, without the need to manually reassign all nsed audio
abjects trracks, busses, Audio Instruments erc.). Anv plug-in
eltects used will be recopnized, and will retain all of their
seLLings.

Software Monitoring

I'he Monitoring switch found in Audio > Audio Hardware &
Orivers > DRIVER (DDRIVER denotes the audio hardware/driver
vou use) has been renamed to Software Monitoring, indicating
its increased functionaliry. With Software Monitoring engaged,
audio monitoring is performed by Logic. With Software Moni-
toring discngaged, the audio card and its driver is responsible
tor monitoring. E.g., if vour audio hardware supports ASI02.0
sero latency monitoring and you want to use this feature, disable
Software Monitoring. Please note that Logic’s Audio Input
Objects are only fully functional (e.g. use their inserts and bus
sends for live effects) when Software Monitoring is enabled.
With Software Monitoring disabled, they will only deliver the
maonitor signal coming from the audio hardware/driver.

EASI MME Expanded

e EASENMMIE Exrension 1.0,0.3 now supports two further

UTTHTTHI

LY '-..lllllhil' IHIES HI"JHLLI I'.f_ il_'ll!'l;:l,.iduq’_l [r'u; LII‘I."'-'IL'I ;!l'Hi [I'IL’ h:.rd_
wire ofTer this feature):

® Support of WA drivers when using Windows Me, Siid
Windows 2000 or Windows XP. EE

Emagic
130 Logic



Logic|

EASI for the Mac OS Versions ﬂ-
Emagic’s standard for the integration of audio hardware, EASI,
is now also available for Logic Mac versions. Soundcard manu- Mac

facturers now have a driver interfuce thar enables their audio
hardware (e.p. PCI soundcards) to be easily adapred for the
Macinrosh,

Improved Latency with Audiowerk ﬂ‘

T'he Audiowerk’s 10 Buffer Size drver paramerer can be set 1o Mﬂl':
smuller values. This reduces the latency for monitoring and for

the use of virtual instruments, such as the ES1 synthesizer or

EXS24 sampler plug-ins. Note that reducing chis value will

place a higher strain on the CPU, and can lead wo audio glitches

and/for a reduced playback track couwnt,

Yamaha DSP Factory

Yamaha DSP Factory support has been improved in botly the
Macintosh and Windows versions of Logie. Taogie CioldMm -
inum for Macintosh (and Windows) now allow the use of virtual
instruments with the DSP Factory. 16 Audio Instroment chan-
nels are available. Tr should be noted thar only native plug-ins
can be used on instrument channels, Sends to the 1352416 are
not possible, The “Outpur™ of an instrument channel is un
audio rack pair, All instrument outputs are set o “Track 15-16"
by defaulr. It is still possible to have audio files on these tracks,
Ir che signal 15 mixed with the ourpur of the instrmmenrs.

'] Please note that Yamaha drivers for the DS2416 card are available for
download from their website, Therr newer ASIO drivers allaow the 11O
Buffer Size 10 be reduced to 512 samples, The defaultis 2048, as with
alder ASIO drivers.
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Roland VS Support

Laogic supports the Roland V5-880, VS-8R0EX and V5-1680,
The combination of Logic and a Roland VS can’t be compared
with conventional audio hardware. One advantage of the
Roland VS, however, is that it can be used as a standalone
system,

IR Please don't assume that the Roland VS-Series represent an alterna-
tive 1o other audio hardware for Logic—this wouldn't be fair on the
successtul V5 senes, or Logic. Logics VS implementation is intended
ta faciitate the cooperation between musicians working with both
systerns, and for transfernng home-recorded pre productions into
professional studio environments

MIDI Cabling

For Logic to communicate with the VS, both MIDI in and our
must be connected.

® Connect the MIDI out of yvour VS unit 1o the MIDT in of
vour MIDT interface.

® Connect the MIDI out of your interface to the MIDI in of
yvour VS unit.

MIDI Settings on Your VS

SysEx Communication

Povwer up your VS, and after it launches and initializes, make
sure thir:

® Syskox Tmsmin is ser to ON (Sywkx T = Ow) and

& Sysloy Receive isset o ON (SwuBEa Ry = Or),

Yo v awvvess these paramerers via “Sywenr™ then "D on
vonni Rolind VS, Use the “Pargmerer” kevs to select the
sttt andl the dial w adjose them. Refer to the users manual
ol yerr VS, 0 yeu can’t find these parameters,
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I'he VS stores these settings with each song, This means thar
when changing to a different song in the VS, you may need o
cvheck the above again,

MTC & MMC Parameters of the VS
The VS and Logic are svachronized via AMTC (MIDI Time
ode).

& Serthe VS o be MMCO slave., (MWE = Slrve)
& Serthe VS to transmit NTC (Gew, = T,

This parameter is accessed under “Sywe/Tempo™.

Logic Settings
Start Logic. Select Audio > Audio Hardware and Drivers.
Choose US and select vour Roland VS unit from the list.

If Logic can’t ind a VS unit yvou will see a4 warning message. In
this situation, please re-verify the MIDI settings on the VS
unit.

MIDI Machine Control (MMC)

In the main menu, select File * New. Set Logic to transmit
MMC commands. In arder to do so, click-hold the Svwe button
an the Transport window, and check MIDI Machine Control
(NINTC,

(£ you wish, you can save this newly created song, along with any
other desired settings. If saved with the name *Autoload” in the Logic
program folder, this song will automatically open when Logic is
launchead.

Tempo Changes on the VS

MNever change the song tempo in Logic, as this will probably
ciause the regions to be played ouc of syne. Do not use Logic’s
{empo List or other tempo functions! Any desired tempo
chunges should be made on the VS unit, Logie alwavs reads the
tempo exclusively from the VS,
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Playlist

When an exisung song is loaded, the VS audio regions found in
this Logic song are deleted, and the Arrange will display
nothing on the audio tracks. This is normal, as the playlist is
always stored in the VS unir itself.

Retrieving the Current VS Playlist
Define a Key Command for the retrieve-playlist function. This
only needs to be done once, and Logic will remember ir:

e (lpen the key Commands window from the global Windows
e

® Click Find and type “VS™ (without the *™),

® You should sce the Ger complete plaviist from VS Key m
Commend.

e Click on it

® Enable Learn Key.

® [Define whatever key you want by pressing it once. (A Func-
tion key may be a good choice here),

& Close the HL‘}' Commands window,

This Key Command works when the Arrange window is the top

window, When you press the defined key, the VS will be asked

to send its plavlist o Logic.

When you press vour defined key, Logic will request the

fonllowsy i Froomn thie V'S:

& | he tempoor iempao list of the currently selected song in the
L. ¥

® Il frame re of the corrently selected song in the VS:

& ‘I'hie whaole plavlist of the currently selected song in the VS,
Laogtie will reaed the plavlist of all 8 (or 16 with a VS-1680)
tracks of the currently set V-Tracks.
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This will take a while, After this is done, vou should see all VS
tracks in the Arrange window.

Waveform Overview

You will now notice a small window labeled "Creating over-
view", It may take a while to finish this for all audio tracks,
depending on the length of your VS song. Creating the over-
views for an “average"” song tukes uround 10 minutes,

You may continue working while Logic is still requesting the
overviews. Logic automarically stops reading them when you
start playback, and continues reading when vou stop plavback.

The rate at which the overview dat can be transferred is deter-
mined by factors outside of Logic's contral,

The overviews are saved on vour computer’s hard drive after
they have been completely read. This means thar when vou
lovaed this VS song into Logic in the future, the overviews do not
have to be recreared. Logic creares a directory called “(VS-
Files)” on the partition of vour hard drive where the Operating
Svstem folder is located. A folder within this directory for each
V'S song is creared. Logic manages this folder automarically.

Refresh QOverviews

If you later find thar overview data stored on the hard drive
does not match what you hear when plaving:

® [n the main menu, select Windows > 0pen Audio.
® Sclect the track files vou wish recreare the overview(s) for,
® [n the Audio window, select File > Refresh ouarview(s).

T'he overviews may be displayed incorrectly if vou work on the
VS without Logic, and later work with Logic. There is no way
for Logic to know whart has changed in such cases, unless you
subsequently refresh the averviews,
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Editing in the Arrange Window

Ediring works on a Cut/Copy/Paste principle.
The Following is possible:
® Mloving a region (simply click-hold and move),

® Copymga region—click-hold and move while holding (58]
(Mac OS) or (PC) respectively.

Performing any of the above edits will automatically send a
command via M1 o che VS, which will then perform the
opertion. Please nore that editing multiple regions simulta-
neonsly will ke some time to complete in the VS, A small
window will show the sturtus of the edit with a progress bar.

If you initiate oo many commands at once you may hit the Ger
romififete plaviist Key Command to abort, The commands not yer
completed are skipped, and those already completed are
reflected after the playlist is loaded,

The following operations are not possible:
¢ Changing the length of a region;

® (irabbing the left or the right corner of a region to change its
start or end point.

If you move a region in the Arrange window so that it overlaps
another region, the overlapping dara from the end of the earlier
region will be removed. "This cannot be subsequently undone.
If you acardentally do chis, and wish to recover, the only
reconrse would e o reload the playlist from the VS, This
wonld, of course, discard any other changes made in Logic
sime the song was last saved on the VS,

The same applies iF you copy a region so that it overlaps
another region, " he VS does not offer realtime non-destructive
tlefiegion based editing: What is gone is gone, so be careful
when editing, "'he following cannot be undone in Logic:
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It is not possible to delete a region and to undo this, The only
way to get it back is to re-load the song in the VS and perform
the Get complete Playfise Tunction in Logie again.

I% highly recommended that you undo audio editing mistakes
dircetly on the Roland VS unit, rather than in Logic. Use the
Cret comprlete Playlise function after the undo operation.

Saving Changes in the VS

Linless you save the song in the VS, vour changes are not stored.
‘lfﬂll cian go h.l{'l{ Cor T]'.IL'.' I'l[l:‘t'lll']ll“i sCALus l,'!l'}' rclﬂ.'u“ng rl'lﬁ 51][1.[_‘; i.l'l
the VS and selecting Ger complete Playlist from V.S in Logic again,
The songin the VS can not be saved remotely by Logic, Saving
can only be done from the VS front panel.

Saving Changes to the Overview Files

When vou select Ger the coaervent playfisr and you have nde edirs
in the Arrange window, Logic will ask you to save the overview
data which also has changed. You should respoid with:

Yes, when you are also saving the song in the VS,

Mo, when yvou have reloaded a previously saved version of your
VS song into the VS,

Mo, when vou have loaded a different song into the VS and you
have NOT previously saved the changed song in the VS,

Changing a Song in the V5

MAdrer changing a song in the VS, vou will need o Ger the complere
Plavdist from the V'Y before making anv kind of changes ro the
arrangement inside Logic,

Effects Control from Logic

I the “Track Mixer, accessed via Windows > Open Mixer, you'll
fid two return objects, called Effecr 1 and Effecr 2. Below the
Inserts text on the channel strips, you will see a blue field. This
heled allows vou to select one of the effects available in the VS
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effect processors. Click-hold to sclect the effect from a list.,
Once the desired effect is selected, double-click the blue insert
panel to open an edit window for the effect’s parameters. Each
audio channel strip has two Sends (Efff and Eff 2, both of them
‘post fuder’), which define the amount of effect added to cach
of the channels.

V-Tracks

Pasgiv always reads the playlise from the currently active V-
Track in the VS, When you want to see, hear and edit a different
Vlrack, ser this in the VS and get the plavlist again,

T'he Regons are named in this manner: *lrackA1-1" for Bank
AL Track 1and ¥-"Track 1; " TrackA4-7" for Bank AL 'Track 4 and
V' Track 7.

V-Track Banks (VS-880EX only)

Currently, only Bank A is read by Logic,

Digidesign Digi001

Emagic has optimized its support of Direct 1/O for the Digi001.,
To make use of the Digi001 support, DigiSystems INIT 5.0 15
reouired,

Logic Platinum allows the plavback of up to 96 tracks with the
[3igit1, dependent on the performance of your computer and
your hard=drives. All inputs and outputs of the Digi001 can be
aeldressed, Irois possilile to use Split Stereo, Interleaved and
Moo files simultaneonsly, Logic’s Audio Engine allows the
st tneons plivlsieck of 16 and 24 bir files.

o Lo you can wtilize the internal effects, external plug-ins in
VST il WSTE2 Foroaes and all vircual instruments for play-
Pk v il gl

Tovevreder v use all 18 inand ourpurs of the Digili) ], check Audio
» NMudio hardware and drivers > Direct 1/0 > Use 16 (or more)
ins and outs.
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[&] When first launched after a new installation, Logic checks all
supported hardware drivers, Due to technical reasons it looks for the
presence of a Digidesign TDM system first. Starting “Launch DAE®
will lead to conflicts with Digi001. Please ensure that DAE is not
active, and that Audio > Audio Hardware & Drivers > Direct 17005
engaged, instead

General Remarks on Digidesign Direct I/O

On Mac O8S with DigiSyseeon INTTYTH) 3.0 and Windows with
the Digidksign Wavedriver, you can sct the /O Buffer Size to . 125,
which reduces the latency. This makes the Digidesign device
suitable for input monitoring and for real-rime playing of virtual
instruments. T'he downside of this is that the CPU load is
increased, so it may not be possible to play back as many audio
tracks as with larger buffer sizes,

[ For the Audiornedia Il card, 0.5 is still the smallest possible value for
the WD buffer size.

fAudio > Audio Hardware & Orivers > Direct 1/0 > Hardware
setup allows vou to set various parameters available for the
different Digidesign cards, such as Clock Source and Input Gain.

The global Awdio Hardware Setup Key Command directly opens J',a
this windaow,

iz Systerm (TMHYINIT 5.0 cannot be used with alder [DAE :
versions; If vou also address vour Digidesign Hardware via

YAL, please retain the corresponding DegrSystear INFL Mac

ASIO Clock Source

Seane ASIO Dirivers allow vou to switch the synchronization i
somrree for the audio sample rre. IF a driver offers this choice, :E
vou can select it via Audio > Audio-Hardware and Drivers » e

ASID Clock Source. In cases where there is no choice, vou'll see
it "e===" or a read-only text entry in the Aip menu ficld.
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Chapter 10
Improvements

T'his chaprer deals wich addirional improvemenrs, changes and
miscellaneous informartion on the Logic product range.

10.1 Audio-related Changes and

Enhancements
® Windows: Song-specific configurarions pertmining w [Direct-
Show plug-ins are now handled berrer. :E
& Platinum PC: PC AV: ReWire lubels now show correctly, i
e Platinum Mac O8: Third parey "T'DM plug-ins: Due o the f
mature of some third parey "TDM plug-ins, cheir settings
would not be restored afrer opening a song. "his has been Mac

fhixed.

® [E51: Further increases in ES1 performance. It is now avail-
able as a mono or stereo Audio Instrument and fearures
new chorusfensemble effect. The chorus/ensemble effect
can be switched into the ES] outpur via three presets, All
parameters are now visible on the slightly modified graphic
user interface,

& When Creating a new Audio objecr, the default for *Val as™ s
now “dB".

& Windows: Noises thut accurred {on some svstems) before e
Audio Regions processed via DirectShow plug-ins have 5

been removed.

® |n the Sample editor, Edit > Insert Loop has been removed.
Edit > Selection to Loop offers the same functionality,
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® I'he Chase Events feature, which allows Logic to react o
sustain pedal, other controller and pitch bender messages
which lie before the starr of playback, also works with Audio
Instruments.

10.2 General

o Disconnection and reconnection of a USB Uniror Family
interfce while Laogic is running 1s improved.,

® ‘I'he syiwchronization of video playvback to sequencer clock
s Deen improved.

® e eransmsston of AT Time Code (MTOC) under heavy A
performance load has been improved,

® T'he Spanish localization has been further enhanced. Mac
® DirectShow plug-ins (Windows) now support 48kHz audio

files in Logic 5.
® The combination of Logic and the Logitech MouseWare ﬁ'_

Extension has been improved,

® The OMS connection for MIDI-driven TIDM plug-ins (e.g.
the Access Virus TDM) has been improved,

o Further refinements of the OMS implementanion. ‘-
® [he MDD burst behavior with USB MIDT interfaces has Mac
been vastly improved,

& LS TDAE A specihe svnchronzanon problem between
DALS VDA and Direct "I'IDA has been resolved.

Improved Handling of Windows MIDI Drivers

1o AT dover crashes when sending SvsEx or opening the
port, Logie will notify vou that the driver has been disabled in
the next session. You can re-activare it in Logic after you have
ipelared the driver. Please contact the driver’s manufacturer for
an updlated version, if required,
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[ s MIDI driver cannot be opened, the message now contains
a butron to disable it permanently. To reactivate a deactivated
dover, open the “winuini™ file with a suitable editor. In the
[Laogic] section you will find a lisc of all MIDI drivers recog-
nized by Logic. Following the driver name youn will find a
number, Set this number to “17 (activated) or “0” (deactived),
wecording to your needs (Windows).

The defaule MIDT input buffer size for non-Emagic drivers has
changed from 3ZKkB to 60kB. This increase improves the
handling of large sysex dumps (Windows),

10.3 Preferences

The Global Preferences window has been slightly reworked.
The parameters are grouped more logically. Al Automarion
settings are saved in the preference file.

"Warning” Sound Levels

Global Preferences > Disable Motification Sounds allows fur the
disabling of alert sounds, such as those heard during error
messages or the “Autolink Success” Hop sound. 1F enabled, all
Sound Labels are much lower in volume than in rre v IO
versions,

Compatibility Settings to Open Logic 4.x Songs in
Logic 5

Switch Sample Accurate Automation

Audio > Audio Preferences > Sample accurate automation
allows to fully or partially switch the new sample accurate auto-
tation system for audio channels. In the OFF sering the auto-
mation responses exactly as it did in Logic 4.x ensuring compat-
ilvility with songs utilizing audio channel automation created
andd saved in the Logic 4.x song format, The sering Volume,
Pan, Sends offers sample accurate automution for volum, pan
and send conerols, the plug-in automarion however, is executed
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as it were in Logic 4.5 This reduces the CPLU load when
sample accurate plug-in parameter automation is not crucial.

Compatibility of Software Instrument Automation

T'he flip-menu serting Options > Settings > MIDI Dptions > Soft-
ware Instruments use MIDI Controller 65-127 for plug-in
parameters (Version 4.x behaviour) ensures compartibility when
apening sones utillizing audioplug-in autemation created and
svessh i Laogie %,

Logic 4o nsed MDY controller messages starting with CC 65
tontonite software instruments, However, third party soft-
wire instruments may nse other MIUDI contraller numbers to
control thewr parumerers. In this case use the setng: Software
Instruments use MIDI Controller as standard MIDI controls.

10.4 MIDI File Import

The way Logic interpretes multiple Note On and Note Off
messages on the same channel and track (which overlaps) has
changed. As a result, the shortening of nore lengths for identical
overlapped notes does not happen any more,

10.5 EXS24

An addendum o the EXS24 manual—available as an elec-
tromie dovoment on the CD-ROM—describes these fearures:

lproved Sample Instrument and file management
Stinpale v nse Search faciliny

SoundFont 2 formae Sample Import

SampleCell T formar Sample Tmport
ReCyelef/RIEN formuat Sample Import

Akai format Sample ITmport improvements
Addirional h:llnplc IMpPort options

Mew menu oprions

onhanced and additional editing oprions
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Further to the facilitnies outhined in the electronic addendum,
Version 5.0 of Logic introduces the following EXS 24 features.

VSM (Virtual Sample Memory)

Laogic 5 suppores Virtual Sample Memory (VShD for the
XS24 Thanks to VSA, the EXS24 can play back audio files of
practically any size, The in-depth documentation and the
nceessary system file can be found in the download section of
www.emagic.de. [f vour compurer is connected to the internet
during installarion, these files will automartically be installed.

Converting ReCycle/REX Files into EXS24
Instruments
This funcrion only is available with the EXS 24 installed.

[&] The conversion of ReCycle/REX files requires an installed REX Shared
Library system extension—wversion 1.2.1 (build 45) or hagher (Mac) o
REX Shared Library DLL version 1.2.1.43 or higher (PC). This system
extension is installed by the Logic 5 installer. To download the Litesl
version of the library visit the support section of www.propellerheads.se ‘:

Another possible use of ReCyele/REX files in Logic is 1o

convert them into EXS 24 sampler instruments, For this Mac
purpose, the Instrument menu in the EXS 24 Instroment

Editor offers a ReCycle convert submenu. Here's how it works:

Extract sequence and make new instrument

Llsing this menu oprion will create a new EXS24 instrument
with the name of the ReCycle loop.

|&] 1f an EX524 instrument with this name already exists, a # sign and a
number will be appended 1o it, making the filename unigue, in the
campler Instruments folder)

After selecting a ReCyele/REX file, vou will be prompred o
enter a Velocity Factor (see below). Usually, you will leave this
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ser to zero (all MIDI notes set o velociry 127 Press the OK
button after entering the desired value,

You will now see that Logic has generated a number of Zones
tone for each slice of the ReCycle/REX file vou have imported)
and one Ciroup that all of these Zones are assigned o,

I acdddivion, a AT sequence has been generared on the
currently selected track, at the current song position (rounded
towhaole bars), This MIDI sequence is used to play the
imported shices ar the timing given by the ReCycle/REX file.
You van penerate new MIDI sequences at any time from the
imported XS 24 instrument (see below), so feel free to modify
or telere this sequence.

Extract sequence and add samples to current instrument

With this menu option, you have the option of adding a
ReCyele loop to the EXS 24 instrument currently opened in the
Instrument Editor. 'T'his allows you to assign several different
loops to one EXS instrument, enabling their use on the same
Audio Instrument track.

If there is no instrument open in the Instrument Editor, this
function works jusr like Extract sequence and make new
instrument.

Extract sequence(s) from ReCycle Instrument

Use this oprion to generate MIDI sequences from an EXS24
instrument creared from a ReCyele/REX file impart. The
sequences are created on the currently selected track, at the
current song position, and rounded to Bars, One MIDI
seepenee is penenited for every imporred ReCyele loop in the
virrently apen instroment. I there is no imported ReCyele
lesapr in the currently open instrument, this menu option is
ihiscelsleel,

You will be usked for a velocity factor (see below), as well,

Yo'l faaed the same function in the Options Menu of the
KNS 24 (beneath the instrument selection box). Here, it is
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custer o see which Audio Inscrument (and EXS 24 instance )
vour're using—in cases where several instances are active.

50, to Extract sequencels) from ReCycle Instrument;
& [psert the EXS24 into an Audio Instrument track.

& Load asampler instrument created by the ReCyele Import
funccion,

#® (Choose Dptions > Edtract sequencels) from ReCycle
Instrument. ['he MIDI sequence will appear on the desired
track.

Paste loop from clipboard as new instrument

This works just like Extract sequence and make new instru-
ment, except that the content of the clipboard 15 wsed
fassuming you've copied a loop into it by using ReCycles oy
feap function}, rather than an audio file.

Paste loop from clipboard to current instrument

This works just like Extract sequence and add samples to
current instrument, except that the content of the chpboard 15
used (if you have copied a loop into it by using the Copy foop
feature in ReCycle).

Velocity Factor

1he velacity factar (in %) allows you to control how the loudness
of each slice in the imported ReCyele/REX file affects the
veloeiry values of the MIDI note generated to trigger it If you
enter a positive value, higher velocity values will be generated.
The highest value vou can enter 15 100, Negative values resul
in lower velocities, Velocity Factor 0 ses all velocity values of
the corresponding MIDI sequence o 127,
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Intelligent Deletion of Sampler Instruments

EXS 24 instruments can now be deleted intelligently via the
new “Delete” option in the Instrument menu of the EXS 24
Edit window. A built-in security function prevents the acci-

dental deletion of audio files that are used by other Sampler
[nsrruments.

Load Multiple Samples

In the EXS instrument editor, it's possible to Load Multiple
Samples.

R
AR

Prelistening to Samples

There is a PreListen function within the new file selector on -:E
Windows.

Sine as Surrogate Signal
The EXS 24 plays a sine wave in place of the assigned wave file,
should ir not be found.
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Chapter 11

Time and Key
Signature Editor

In the Time and Key Signature Editor window it is possible to
copy, move and delete dime signature changes, key signature
changes and global score svmbols (repeat signs, special barlines
cre ) Toopen this window, choose Signature/Key Change List
Editor from the (global) Options menu,

*-’ﬁ 1 SEard af Lust
| o i

[ 1 %ignature L T ]
i i i Signagure 4= 4
= 12 1 o1 1 ERy £ ma| o
|' i i i Signature [T ]
Lo 1 bouble Barilne
i i i Signaiure 4’ 4

This editor looks and waorks very similar to the Fyvent Last
editor, except that new hist entries can only be creared by
copving existing ones. The following score symbals wre
displaved in this window as list entries, if they are present in

the seore of the song:

® Time signature changes

o key signatures and key changes, as displayved in the Score
Feir window

® Repeat signs (repeat start, repear end, repear end+start,
brackets for Arst and second endings)

® Special barlines: double barlines, final double barlines (“end
of score”™ ), halffshart barlines, hidden barines (displayved as
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doted lines on the screen) and manually inserted regular
barlines,

i mote: the mitial brme and key signature of the song s ahwvays displayed
here, without bar position indications at the 1op of the list,

Meuse note: None of these symbols affects Logic’s MIDI and
anlion plan bawk. However, time signatures not only affect the
seore display, but also the bar position display in all windows
annd therefore all funcions which somehow depend on the
ehiesen tiine signature ol on bar positions, like the MR
metromine ek o the funcoons in the Transtorm Edu
winkdow, iF bar positions are used 1o reserict its chosen funcrion
toa eerinin part of the song,

11.1 Copying Time and Key
Signatures

In this window, rime signatures, key changes, repeat signs and
special barlines can be copied exactly as in the Event Last
wincow:

Selecr all list entrics which vou want o copy by clicking on
them ([©)+click for multiple selection) and use menu Edit >
Copy or the kev command {Mac QS) or {(Windows)

to copy them to the clipboard.

Bvow it the copied entries by choosing Edie = Paste or the
Lt."_«'q,'l:unru.lm,ll"'nl'.u'l:.'-‘."ih:ll["L"l.huln“.:nl.'I'Iu:q_'{n-pi:.':l
st coeries are nowe bemne imseried o the hst an enory box
apens for the bar position of the st inserted list event. Type
the desived bar position i the usoal way (Like 27,71,y and
b that b by pressing the | Return] or [Lnter] ey, Sulsse-
cpuent st entres ane mserted at bar positions that correspond to
their original distance in relation o the Rse copied list entry.
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11.2 Moving and Deleting List
Entries

Al lise entries in this window (except the initial time and key
signatures ar the top of the list) can be moved or delered. Again,
this corresponds exacely o the way the Event Edir window
works:

® ‘o defere a list entry, select it and press the |Backspace] kev.

® [0 move an entry, you can cither click on its bar position with
the mouse, keep the mouse burtton pressed and move the
maouse up or down; or vou douhle-click on the bar position of
the list entry and type the desired bar position into the entry
box which opens after the double-click.

11.3 Changing Time and Key
Signatures in the List Editor

Existing time signatures and key changes can be alwered
directly in this list

#® Their poesitren can be changed as deseribed in the previous
section,

® Time signatures can be changed by positioning the mouse
puinter at the nominator or denominator in the list and drag-
ging the mouse up or down to increase or decrease thar
vilue,

® loaleera dfev sigwature, either click on the word major or
minor to switch between parallel major and minor keys, or
click and hold on the roor of the kev: This opens a pop-up
menu with the root notes of all available keys, Se lecr the
desired key by moving the mouse to the corresponding note
in that pop-up menu.

All these changes will immediarely affect the display in the
Aueore Edic Window and in all ether windows.
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Chapter 12

Step Input

The step input functionality has been reworked completely in
Logic 5.0 and has been expanded significancly. In addition o
the already existing MIDI Step Input—which has been adapred
to correspond with the new scep input features—you can also
use Ley commands (using the computer kevboard as a kind of
music typewriter) or mouse clicks in the new Keyboard Window,
which can be opened via the (global) menu Windows > Dpen
Keyboard Windows:

@

i i BT

This new window is the central element of the graphical user
interface for all types of step input. However, it is only the
visidle part of the new funcrions, Much more important is a
whole group of dey commands that allows the user to insert notes
via the computer keyboard. Many of those key commands
correspond to the butrons in the Keyboard Window, like those
which derermine lengrh or velocity of the notes which are to be
inserted. Before we go into detail about those key commands,
here is an outline of the basic principles:

ma

12.1 Preparations for Step Input

In order to use the step input functions, there has to be a MID]1
sequence into which notes are going to be inserted. Usually you
will creare a new sequence for that purpose, using the Pencil
Tool on the desired track of the Arrange Window,
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The next step will be to open (or activate) an editor window

that displays the contents of that sequence. This can be either

a Score Edit Window, a Martrix Edit Window or an Evenr List
Window, depending on personal preference. The Input Mode @
has to be activated in that window (Click the MIDI IN button

or use the key command MIDJ [N vo toggle Input Mode onand

offl. Now you can open the Keyboard Window if it’s nor already

apen anyway (menu Windows > Dpen Keyboard Window),

It yemn decide o waork in the Score Edir Window, vou have o
adjust the display sertings for that sequence accordingly: Inter-
pl‘ﬂ'tﬂtiﬂl‘l lias tor be off, the display quantize serting (Qua)
shuwstalel e ser ro the smallest note value Vol intend o insert,

12.2 Input

Before you start, set the Song Position Linc (SPL) 1o the spor
where you want to insert the first note, for example by adjusting
the song position in the Transport Window.

Single Notes

For gerting to know things it's easier to use the mouse in the
beginning, clicking the key for the desired piteh in the
kevboard Window, and also the buttons for note length,
velocity etc. This inserts a note with thar picch an the current
song position into the selected sequence, with the length and
velocity chosen in the Kevboard Window before. This can also
be done with key commands—we will talk about thatin a
e ..

1he pitch of an inserted note is determined by the key that you
click in the Keybourd Window. Length and velocity are deter-
mined by the corresponding buttons in thar window, 1f the
buttons look like shown in the illustrations to the right, a
sivteenth note with velocity setting 96 would be inserted—rthis
corresponds o the forte () indication. The eight available
velocity values are represented by the tradition volume indica-
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rions gan, oo, o, e, il 5O and fF which :‘ul‘l‘t.,‘:i.pq‘lr'ld o the
velocity values 16, 32, 48, 64, B0, 96, 112 and 127,

The A1DI channel of an inserted note is determined by the it i
Channel setting in the Keyvboard Window. Remember: T'he &E}
channel settings of individual notes usually has no effect on the

plavback channel and therefore the sound of char sequence—

this is determined by the track instrument sectings in the

Arrange Window. The channel sertings of individual notes are

mainly used for polyphonic score display,

Proceeding

After a note is inserted, the song position line will always jump
to the end of the inserted note, The following note can be
inserred righe awav, following the same principles again.

Chords )

To insert several notes at the same bar position, the Chord ._F
Maode has to be acrivated by clicking on the button on rthe far

left side of the window or using the key commuand Chore Mode,

This will keep the song position line from moving after

inserting a note, allowing the user to insert as many NOLCs as

desired ar the same bar position, one after the other, Another

click on the chord button (or the same key command again) will
deactivare the Chord Mode (rhis is best done before inserting

the last chord tone); the song position line will now move

forward again after inserming notes.

12.3 Step Input Using the
Computer Keyboard

Nore inpur with the computer keyboard works according to the
sume principle as just described. However, instead of choosing
pitch, velocity, note lengeh ere. with mouse clicks, key
commands are used for all functions. "To have betrer control
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over what you are doing it is recommended to still open the
Keyboard Window when yvou start using these functions,
however, it actually isn't really necessary to open thar window
when using key commands.

All key commands for step inpur are user definable. In the Key
Command Window (open via [global] menu Options > Settings
> Key Commands) they can be found ar the very bottom of the
list, wodder the header Kevboard {npur,

The tollowing key commands are available: ﬁ]
Neete '€ Ortaey =2

Nivte 'CH Oereve =1

Nate 'TY Cletave +1

Note "I Chetaree +2

Nore 'F° 1 note

Note 'F”’ K2 nore

Nore ‘I’ T note

Nowe ' 118 pate

Note 'GH' 1116 note

Nowe ‘A’ 132 nore

Nove ‘AR’ 1164 note

Nave ‘H" 128 pate

FPause Next three notes are triplers

Next nate awill be sharp Next rwro wotes are a dotted group
Next wote wilf be far Veloriry 16 fppp)

O heeed Waele Velaeity 32 (pp)

fovarsee Vedaerty 48 (p)

N Dol Velociry 64 (mip)

Neepr farveeeeed Velocity 80 (mf)

{ e deatw () Velarity 96 (f)

Cheserce | Velociry 112 (ff)

Cleterine 2 Velociry 127 (1)

Fiterve 4
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Cictave +
Cictave 5
Cletarve &

12.4 Key Commands—More
Details

Pitch

The vwelve key commands Nese £ o Nate I will insert that note
with the currently set length and velocity at the current posi-
tion of the song position line (SPL) into the currently selecred
sequence. To insert chords, use the Chord Mode command,
Switch off chord mode using the same command once again.

Instcad of assigning key commands to all ewelve pitches there
is5 also the option to only define key commands for the seven
pitches of the C major scale and vse these in combumnien with
Nexe note woill be sharp and Nexr wote will be flar to insere the other
pitches.

When creating a svstem for these key command assignments
two dpproaches seem obvious: either to arrange these
commands on the computer keyvbouard similar to a plano
keyboard (C D E F G A B in a row next to each other and C# D#
I'# G# A# above rthese ar corresponding positions), or—espe-
cially when the second system mentioned above is used—io
assign keys to pitches of the C major scale according to their
IS Names,

Octave Ranges

'I'he octave where a note will be inscrted depends on the
current position of the insert range bar, This can be seen in the
Kevboard Window: There is a small horizontal bar above the
piano key image that spans exactly one octave. The chosen
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note will always be inserted inside the range marked by thar
byar.

This bar changes its position all the time according to the last
inserted note: The center of the insert range bar will always be
aligned ro the last inserted note. The next note will be inserred
in that range unless the range bar is moved using key
commands or the mouse,

An example: 1fa GG s inserted right after inserting a C, the G
will be put below the C: Inserting the C places the range beam
between O (lefr end) and =2 (right end), with the C in the
venter. Regardless which note is chosen now, it will always be
insereed inside that range. However, the beam will move on as
further notes are inserted, its center always aligned to the last
inserted note,

Since larger intervals would be impossible that way, there are
key commands for placing the range bar in different octaves:
Oletave 0 1o Octave 6, and also Octave +1/=1/+2/=2, which move
the range bar up or down onc or two octaves. Apart from that
the range bar can also be moved with the mouse,

Note Length and Velocity

Note Length and Velocity are determined defore one of the
pitch commands is used to actually insert a note, The currently
selected values can be seen in the Kevboard Window,

K] 1f you are working in the Score Edit Window, don't forget 1o adjust
the display parameters for the sequence accordingly (see above).

Rests, Correction, Moving Forward and
Back

I'he key command Rese moves the song position line forward
avcording to the currently set note value without inserting a
note, therely ereating a rest,
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The Stepp faclasards and Step forward command also move the
SPL forward or back by the length of the selected note value.

I'hve £ rase command will delete the last inserted note and
move the SPL to the position where that note began. This
allows quick corrections—another note can be inserted righe
away replacing the crased one,

Triplets, Dotted Note Groups

The key command Next shree notes are tripless 1s self-explaining,
The rhvthmic value of the triplets corresponds to the currently
selecred note value in the Kevboard Window. If an cighth note
is sclected there, an eighth note triplet will be created. After
three nates have been inserted, binary values will be inserred
again, unless the command is applied again.

Next two notes ave a dotted group works in a similar way, The
special thing abou it is, that a pair of notes will be inserred
which complement each other, like a dotted eighth and a
sixteenth note,

12.5 Interaction with Other Key
Commands

If the input mode is activated in an editor window (Score,
Matrix or Event List), these key commands have priority over
all other key commands.,

This means that you may also assign keys or key combinarions
to these funetions which already are assigned to other fune-
rions. As long as the inpur mode is active, the key assignments
for step input funcrions will apply; if the input mode is
switched off, the other kev assignments (for the same keys) will
lave priority.

So you can use key assignments that are already in use for other
functions, vou should just be careful not to use keys thart are
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assigned o funcnons which you also might want to use when
vou work with step input.

I A reminder: There are lots of other key commands for editing notes
and for moving the SPL which can also be very usefu! when working
in step input mode: Transport functions iike forward and rewind,
various Nudge commands for moving nOTeEs ot changing their length;
eommands like select next/previous event or ranspose event +1/=1,
and all the Note Attributes in the Score Edit Window
Consider that the last inserted note is always selected, 50 it can imme-
diately be moved, changed in pitch or made longer or shorter using
the mentioned key commands. Therefore the key assignments for
these rommands should not be used for step input commands—that
way all these functions are etill available in step input mode.

12.6 MIDI Step Input

MIDI Step Input is very similar to key command step input as
deseribed above:

First there has to be a (often empty) MIDI sequence, which has
10 be selected in an editor window. Input Mode has to be active [ giE
(MIDI IN button or key command}. ﬁa

Selecting the desired note values is done using the same key
commands as described above. The same applies 1o the func-
tions Rest, Step forward, Step backwards and Erase.

However, pitch and velocity arc simply determined by what-
ever keys are pressed on the MID key board. Also, there is no
need for the Chord Input function: Simply play the desired
chord on the MIDT keyboard, it will be inserted at the current
SO POSITION.
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13.1 Score Display Using External
Symbol Fonts

The use of external symbaol fonts for the score display can
change the appearance of the score completely. Apart from
Logic’s own font, which is directly integrated in the program
itself, it is possible o usc JaszFont, Seringlont or the Sonata
font. These fonts are distributed by other companies (see
below) and are not included with the Logic program puckage.

Someata has a rather traditional character. Jazs and Swing have a
hand-written appearance, as it can be seen in varions fake-
books. For comparison, here is the same shore phrase printed
four times with the different fonts:

i i - ] .
Irrernal LOgIC B T L gy
font: -éﬂbﬁ-f py it et e = 3
mf

fazz font. &Eiﬁ_—-—j@ i
=

CO T
yEar T e
-

Swing font: {b?jﬁ_ﬁ___’ SR b —:,__,; s
o~

[ - r: ’ ‘ - & )
Sonata font. i lempil Al Lt T
o . g PP

Maore samples can be found on the web pages of the distribu-
tors. The Jazz and Swing font also come in a bundle with
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matching text fonts which can be used in Logic for textinpur of
all kinds.

These fonts can either be acquired in music and computer
stores or at the following internet addresses:

® JaszFonrand SaringFont can be purchased direetly from
Richard Sigler, their creator, at http:/iww.jazzfont.com/

e Sonata is distribured by Adsde. The following URL takes
vou directly 1o the page where Sonata is offered:
http:/iwww.adobe.com/type/browser/P/P_021 html

Requirements and Installation

‘I use these fonts wirh Logic, they have to be properly
installed in the system, just like regular rext fonts. If you use a
Macintosh, copy or move the font files into the Fonts folder,
which is inside the system folder. If you are a Windows user,
just start the installation program that you get when acquiring
the fonts and follow the instructions on the screen.

Then choose menu Options » Score Preferences, In the dialog
window that opens, activate the option Use External Symbol
Font (if available). Since especially with Sonata the screen
display in small zoom levels is rather unclear, there is also an
option Only far Printont, which causes the chosen font to be
used only for printing, but uses the internal Logic font for the
screcn display,

Emagic
162 Logic



Team TND
1c|5
Screen Display—New Functions LO gl C ‘

13.2 Screen Display—New
Functions

Multiple Page View

In Page View mode, Logic will now automatically display as
many pages next to each other as possible, according ro the size
of the Score Edit window and the current zoom level.

“T'his is especially useful when working on the overall layout of
an extended piece,

More Zoom Levels—Finer Resolution

‘I'here are a lot more zoom levels in the Score Edit Window
now, the difference berween them has become much smaller.
"I'his enables users o choose the score display in each Score
Lidit Window size exactly according to their individual needs.

|& A reminder: For selective zooming of only a small part of the window
that is to be displayed as large as possible, use the magnifying glass
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tool or better the zooming shorteut: While keeping the [ai]-key
fWindows)/fan)-key (Mac O5) pressed, use the rubber-band selection
technigue 1o select the desired part of the score display. A chck on the
background while holding the same key again will bring you back to
the original zoom level.

13.3 General Score Display
Functions

Alia in the Score Display

L] A reminder: Afias (pl. Alia} is a term used for objects in the Arrange
Window which are not independent sequences, but only “mirror”
other sequences at different positions andfor tracks. Wherever an
Adias ewsts, its oniginal sequence 5 played back.

Alia can now also be displayed in the Score Edit Window and

also be printed. The display of Alia has to be activated in the

Global Format dialog window (menu Layout * Global Format),
by checking the option Show Alias there.

A! This opticn is a Song Setting. If you always want to see Alia in the
score display, you should activate this option in your Autolead song.

An Alias can be assigned a different Score Style than its original
sequence. For example, a melody played in unison by several
instruments can be handled as a regular MIDT sequence and
several Al of that sequence. Different Score Styles can be
pised for the different instruments, also transpoasing Score
Styles, 11 you devide to change somerthing in the melody, vou
et lave o edic all the copies of thar melody, bur just make
the change in one sequence. ' Thar change will auromarically be
reHecred inoall Alia of that sequence. The same applies to
repeared sections within a piece.

By default, Logic will not let vou edit the contents of an alias
(only the settings in the Display Paramerers Box). If vou try 1o
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edit the contents of an Alias (for example move a note), the
following dialog will appear:

pracend, Yyou con aliher enabie
alias editing or create a copy of the
sPQuUIPrnLE

i Mias editing is curréntly disabled. Ta

ﬂ Cancel '

Enable Allas Ediling | [ Copy Sequence |

There are three choices now:

o Cancel reverts the last edit.

» Copy Sequence converts the Alias into a separate, indepen-
dent sequence, which can now be edited withour affecting
the original sequence.

e Enable Alias Editing activates a mode which allows you to
edit the contents of an original by editing irs Alias, In this
case, the original and all its Alia will reflect the changes you
apply to any of them.

Enable Alias Editing is a song setting which can also be activared
in the Global Format dialog window (menu Layout » Global
Farmat).

Apart from that, there is also an option to convert an Alis toan
independent sequence by sclecting it in the Armange Window
and choosing Functions » Alias > Convert to Real Copy or the
corresponding key command. (This option already existed in

furmer versions of Logic.)

Alternating Page Margins

"I'he option Alternating Margins can be found in the Glodal
Forwar window {menu Lagout > Global Format), If activared,
the left and right page margin settings will be swapped on every
second page. This can be useful if a score is going to be bound
as u book: Usually the inner margin has to be a bit bigger than
the outer one. Bur also the opposite is possible imaginable in
order to leave space for remarks added later to the score.
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13.4 Score Layout Details

Individual Alteration of Stem Length

The stem length of each note can be changed individually.
T'his can be used o change the stem length of notes which are
not beamed o any other notes, to alter the inclination of a beam
that connects several notes by changing the stem length of the
tirst and/for last note under that beam, or to move a beam up or
down as a whole in parallel motion, which is especially useful
for cross-staff beaming sitnations (see below).

There are three new menu commands in the Attributes > Stem
* oo submenu and also corresponding key commands, which
can be found in the Score section of the Key Command
window:

stem end: move up
srem end: move down
stem endd: defanlr length

As the name implies, sfemm end. move up works independently
from the actual stem direction—rthe end of the stem is always
moved &p, which results in an increased stem length if the stem
points up, and in a shoreer stem length if the stem of the
selecred note points down. The same principle (with opposite
effect) applies to stemr end: wove down,

Although this method might scem odd at first glance, it is very
useful when cross-staff beaming is used and the beam is posi-
tioned berween the staves: In this case you can simply select all
beamed notes and move the whole beam up or down in parallel
FLLTHINERT

bl Reminder: The general defauht setting for the stemn length can be
changed in the Extended Layout Parameters window (open via menu
Layout), This setting apphes to all notes in the song,
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Cross-staff Beaming

Music for kevboard instruments or harp, which is notared in
two staves, sometimes contains passages where notes in the
upper and lower staff (played by lefr and right hand) are
connected with a beam to emphasize the continuing musical
phrase, as shown in the following illustration:

(B =r————=_ccca:
?l s . a— !.---.- I-I':Jl - - ’
i

Please note: If you want 1o use this function, you should already have
a good knowledge of all functions associated with Logic's Score
Styles, Extensive information albout this topic can be found in the
Logic reference manual,

Required Settings:

Cross-staft beaming is only possible berween staves which
belong to the same Score Seyle and therefore to the same MIDI
sequence. ."'kp'.ll't ﬁn:n tllut_ 1|u: UﬂiEES 1 I:h i:a Sg;{:-n.: f'it}-'le have o
have to different MIDI channel assignments—it is not possible
to achieve cross-staff beaming with a Score Style that only uses
i splic point pitch for Voice separation.

The Procedure in Detail

Since notes can only be connected with beams, if they belong
to the same Voice (in the sense of Logic’s own terminology), it
is not possible to simply select notes in both staves and apply
the usual beaming attribute funcrions to them.

As an example, lecs imaging o two-staff Score Seyle with one
Voice per staff. Before beaming the notes, it is necessary to
assign all nores which are to be connected by a beam to the
sume Voice, let’s choose the Voice of the upper staff.

To change the Voice assignments for the notes in the lower
staff, you can cither use the Vadce Separasion Tooland draw a line

Reference Addendum
Version 5§ 67



Chapter 13
Score Edit Window

below those notes or select all these notes ([&)-click or rubber-
band selection) and change their M1 channel in the Event
Parameter Box to the channel of the upper Voice. In the
example shown above all notes would have to be assigned to
the upper Voice first. Now all those notes will be displayed in
the upper staff, probably with a lot of ledger lines as in the
following illustration:

5
=1

I'he next step s to define the beaming connections as desired.
T'his can be done with the regular note atrribute funcions
{(menu Attributes > Beaming > Beam selected or corresponding
kevy command).

: : o
. - 5 -

MNow select those notes once more which should actually be
displaved in the botrom staff and choose the menu Attributes >
Upice/Staff Assignment > staff below Uoice or the corre-
sponding key command.

Soncepation
LrBr pratatien
| radls i 0

Mair oAt Aaasgaine o8 IICEINTETTE
Calars

Hesed Al A ribates

=15
SAwT Abawd Yolos =7 1 5
SR haplirw D] ==F =

R In Logic Windows the mend bar looks a bit different, but the Attribure
menu itself contains exactly the same functions

I'his moves all selected notes down to the lower staff, although
they sl remain pare of the upper Voice.

You could also choose the opposite approach—first assigning all
notes to the lower Voice, then moving part of the notes to the
upper staff with Attributes > Voice/Staff Assignment > staff
abouve Upice,
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To display all selected notes in their original staff, use
Attributes > Voice/Staff Assignment > default stafr.

Stem Direction

The default stem direction for notes that beamed across staves
is towards the center. Le. the beam is displayed berween the
two staves, stems in the lower staff point up, stems in the upper
staft point down,

The vertical position and the inclination of that beam can be
altered by applving the stem length change functions desenbed
above: To move the whole beam in parallel motion, select all
beamed notes at once and choose Attributes > Stems > Up or
... Down, to change the inclination of the beam, select the first
or last note of thar group and apply those functions.

However, vou can also define the same stem direction for all

notes with the regular note atribute functions, thereby placing
the beam above the tap staff or below the bottom staff, If you
decide that vou like the in-berween beam better, you'll have to
select all notes again and choose Attributes > Stems > Default.

Rest Display

As always, rests are displayed automarically in Logic, according
to the Rest settings in the used Score Style. However, since in
the cross=stafl beaming situation deseribed above, most or even
all notes belong to the Voice of the top staff, the lower staff will
contain rests—some even directly at the position of notes. 'To
avoid this, you should use a Score Style where the automaric
rest display is deactivated for the Voice of the bortom staff.
Wherever rest display is desired, User Rests can be inserted
with the mouse from the Partbox.
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Colored Notes

Motes can be displayed and printed in color, This could serve
scveral purposes:

¢ Forteaching: Colored display of pitches as additional help
for beginners, especially small children,

& [ distinguish beoween different Voices in the sume staff
when using polyphonic Score Styles, which also can be
helpful in the Voice separation process.

& o distinguish beoween different AMIDI note velocities,

® |ising custom colored notes for any conceivable purpose.

T'he use of colors for notes can be emploved on several levels:
For individual notes, for all notes of a particular Voice within a
Score Style or for all notes displaved in a Score Edit Window,

Color Settings for all Notes Displayed in a Window
The Ulew menn of the Score Edit Window contains the entry
Color which has a submenu with five options. These settings
here always have prionty over all other color sertings, However,
they only apply to this particular window,

& Prim Voew
Exphade Febders S VoL AbE IGAMEAE

[xploss Palyppher o Force Blackdwhite

Partbax ¥
& Todlbox
FPIL TR —_
& Paramsiers H
# il F e b M % St
Pages Rslifa 3
Wikabe Bacindraund - = +—t
Imvemried Dinpley ]Q]:#@d:—_‘:
¥

Hyeer D

& Mormal or Individual means that colors are assigned
according to the color settings in Score Styles and Nore
Artribures. As long as those haven't been changed in new
songs, this will result in a regular black & white printout and
black notes on vellow background on the screen.,
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& Show Piteh applics colors according to the pitch of notes,
The colors for thar can be edited in a special window thar
open via the menu Layout » Colors (see below). There vou
cun also derermine whether notes with accidencals will have
the same color as without accidentals, or if each note in the
chromaric scale will have its own color,

& Show Uelocity applics cight different colors according ro
MIDI velocity. Also these colors can be edited in Layout »
Colors.

® Show Uoice Assignment assigns different colors to different
Voices, This only makes sense in Score Stvles that contain
more than one Voice. This mode employs the colors of the
user palecte, which can also be found and edited in Layout >
Colors.

® Force BlackBWhite does exacrly that. This maode is useful
when calor nptiunﬁ have been used in Score Styles or colors
have been assigned o notes using Note Arribures, buat one
wants to print a regular black & white score and then return
to the colored display,
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Color Palette

I'he menu Layout > Colors opens the color palette for the
currently active song:

—

[ s = aorromean: Song umﬁgt e T e U ] El

-]

=Pl b Cadirs
Patonio
Chrosmtic

hbddL

= YalE ity Calors

TR

17 13 4p 48 mi

s

e Ctar Dptions
[ Hdsecigantals
B fols
[ATien

[ #teemn

e e

This fs the window in the Mac version. However, apart from the window
fayout itself, there is no difference to the Windows version

This is where all the color palettes can be found which the
different coloring moedes refer to. Clicking on any color opens
the standard color editing window, where this particular color
can be chanped.

These colors are saved with the song and can be different in
cach song. T'hey can be imporred from any other song as part of
the score song settings using menu Options » Import Settings >
Store Settings,

Phere are three palettes and some additional options for details
i this serndosa

® Pitch Calors: Each note of the ocrave gets a color, thev are
arranged like piano keys. Diatonic/Chromatic dercrmines
whether there are twelve or seven different colors,
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e Velocity Colors: These eight colors are applied according to
the MILDI velocity of notes, from left (minimum) o right
Cmaximum),

# User Palette: I'hese colors not only can be edited freely, bur
also named, using rthe rexr entey boxes next to them. These
names are displayed as color oprions in different color selec-
rion menus (Score Styles, Mote Arcributes),

* Note Color Options: These options determine whether acci-
dentals, dots, stems and beams are displayed colored
{according to the notes they belong te) or black. Rests refers
to user rests, which ure mainly used in polyphonic Score
Stevles.

Color Settings in Score Styles

In Score Styles, cach Voice can be displayved with colured notes.
This has to be ser in the Color column of the Score Srvle
Window for the desired Seyle.

= 17 Farbpmiet.Fiate tHimma =

AT il

The color oprions are the same as listed above: Black (*=-="),
Pitch, Velocity and the 16 colors of the user palette,

"Phese sertings only affect sequences which use an according
Score Style. Inaddition, the active color mode inthe Score Edir
Window has to be Narmal (Individual), which is the defaule
SCLTINE,

Color Settings for Individual Notes

Single notes can also be assigned colors individually, again
according to the three color palettes, The nore has w be
selected, then menu Attributes > Colors »... is used to assign the
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desired color (user palette 1 to 16) or color mode (pitch or
velocity )

Being Mote Attributes, these settings have priority over the
Score Style settings. However, they only apply if the color
mode in the Score Edir Window 15 set to Normal (I ndividual).

Oversize Staves

The size range in Logic’s Score Styles (until now 0 to 10) has
been exrended to po o 15, This makes it possible w print
staves with a heighe of up to app. 14.5 millimeters (= app. (.57
inches), as its often done in beginner's books for small children,

I cConsider the note color options in combination with this featurel

A hine: IF vou want to create even bigger staves, vou can addi-
tionally use the Scaling funcrion in the Instrument Set Window,
Creare an Instrumenr Ser containing the desired instrument/s
and ser the Scaling paramerter vo 20068, This can produce staves
which are almost 3 centimerers high (= app. 1.14 inches). You
might want to use landscape format in this case,

Octave Symbols

The Partbox group that contains clefs also contains octave signs
which automatically affect the note display when inserted: [fan
Sowr sign is inserred above a staff, all notes berween the bar posi-
tiom of the ¥ow symbol and the end of its bracket will be
displayved an octave lower, which in conjunction with the Sve
sign means the same resule as the onginal notation, The ML
playback remains unaltered. The same applies to the other
availuble octave signs (one octave lower, two octaves higher or
lower). Below vou see the same MIDT scquence before and
after ocrave signs are inserted:
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the same sequence after ffi‘u'-!"'.r?'.l.'i'l._'.' M Taw ‘\.L'I".li'.‘!‘{"l.'.‘i

The end of the bracker can be deageed oo ol oonese o the

right or lett as desieed, also ey ond e oeaks

1 he st dppeaninuo of thesy = peibeenls o bee el e s
Layout > Clels & Signatures » Octave Syombiods, [ lope o
possilile to detine any desired west aeconding to e vl pac o
ence for each of these svmbnls by inseromge i the corne
sponding rexr boxes, This makes ir possible for esoample v nse
Bvh instead of Bva bassa, (" Theoreticallv, aov rext wonrhd Dae
possible to represent each of these svmbaols b Alse tlie e st o,
size and stvle for octave svmbols can be changed here,

|&] The octave symbols displayed 0 the partbox are only wons which
dan't change when the default definitions are changed in the Clefs &
Signatures cralog.

Distance between Notes and Barlines

The detaulr serting for the relarive distunce berween the first
and last note of 4 bar and the preceding or subsequent barline
van now be affected by changing the following two paramerers
i the Extended Layout Parameters... (menu Layouwt):

Bar Start Spacing
Bar End Spacing
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Please note: To change the defaulr sertings of these parameters
only makes sense if rather extreme settings have been chosen
for the general Spacing parameters in the Global Format
window.

Accidental Size in Chord Symbols

T'he size of aceidentals in chord symbals (ro {ﬁ5|.1||11":' the root
note, like Ab or F2)in general changes with the font size used
by the Chord Root “Text Style. However, the Chord Symbol Acci-
dental Scale paramerer in the Extended Layout Parameters...
window {menu Layout) allows to change the accidental size in
relation to that font size serting: Positive values result in an
increased size, neganve values in a diminished size of chord
symbaol accidentals. The default setring 1s zero.,

Additional Bar Number Layout Options

Centered Position for Bar Numbers

There is a new option for the display of bar numbers, which can
be found in Layout > Numbers and Names... > Bar Numbers >
Hor. Position > at Bar Center: Bar numbers can now be
displaved not only above or below fanfives, bur also above or
below the censer of the bars.

£ |

I

(2] @ @ (T @ (i)

L' in the example shown above, a negative Vert. Position value and a
circled text format have been used for the bar numbers,
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Hide Bar Numbers in Linear View

T'his option can also be found in Layout > Numbers and
Mames... > Bar Numbers and will hide che bar rumibers in
linear view (where 'u:il:l;L”} the bar numbers are Li\.|r4,|-..._._| 1 the
brar ruler anyway)

Key Commands for Moving Symbols

The following key commands can e used oo s e any seme

symbol that can be positioned independens o vore o stanes,

as well as rext evenrs anad cliesrd ss gl ool
Nudlae Posivion {'p | a

Noudloe Posifton oure
Nieeloe Poseison | oir
Nivelee Posetron Kok

Chese Functions olooo alicn il Do e it cal e olblesre ol
svmbols anmel test ey e |||||1||-||Inu||-| T R N T R PRI

erers ]P':\. &1,

Reminder: These parmmeteis detin 1 o e apehie b
tion of an ebject from its bar posivion chon o s el tean e g
line of the hTHﬂ'I\FEI'LPDS.J. Tl s e on vene Go ihe o
sertings is one sixteenth of the distanee beoween two B oo
staff. Therefore these commaunds only canse ven sunill i
ments, so it is recommended to work inoa very lugh soomm el
when using rhese funcrions for ivout work,
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